Winmail Server 系统介绍

系统介绍

Winmail Server 是安全易用全功能的邮件服务器软件， 不仅支持SMTP/POP3/IMAP/Webmail/LDAP(公用地址簿)/多域/发信认证/反垃圾邮件/邮件过滤/系统通信组/公共邮件夹等标准邮件功能， 还有提供分布式部署/第三方认证/IPv6/系统迁移/PushMail/RBL/SPF/SpamAssassin/DKIM/邮件签核/邮件杀毒/邮件监控/内置MySQL数据库/外部MySQL等数据库/微信绑定/钉钉绑定/邮件单副本存储/网络硬盘及共享/邮件密级/邮件撤回/短信提醒/只读邮箱/定时邮件/邮件备份/SSL安全传输协议/邮件网关/动态域名支持/远程管理/Web 管理/独立域管理员/在线注册/二次开发接口等特色功能。 它既可以作为互联网邮件服务器、局域网邮件服务器，也可以作为动态IP接入方式的邮件服务器和邮件网关。

运行环境

· 硬件配置 Intel i5 以上CPU, 硬盘500G, 内存4G。
· 软件要求 中英文 Windows 2003/2008/Windows 7/2012/Win10/Win11/2012/2016/2019/2022/2025 等 Win32/64 操作系统平台。
· 网络要求 安装并正确配置 TCP/IP 的网卡，架设互联网邮件服务器需要公网Ip和正式注册的域名。

主要特点

· 支持通用邮件客户端软件 Outlook、Foxmail 等收发邮件。
· 提供多语言多风格全功能 Webmail，可以在网页上在线注册新邮箱、收发邮件、修改密码、在线预览 Office 附件、自动转发、自动回复等操作。
· 支持邮件杀毒功能，支持四种模式，支持几乎所有的杀毒引擎，有效的拦截、清除带毒邮件。企业版、旗舰版支持内嵌查毒引擎，支持自动更新。Winmail 和杀毒引擎
· 支持 Internet 光纤专线、主机托管、云主机、VPS收发邮件，以及动态接入方式的连接 Internet 收发邮件。企业版、旗舰版支持 IPv6。
· 支持 ESMTP 验证(SMTP 发信认证)，更安全。
· 支持 IMAP，可以在服务器上操作邮件，支持中文邮件夹和子文件夹。
· 系统配置和认证信息默认使用内嵌式轻型数据库 SQLite，企业版、旗舰版支持内置 MySQL、外部 MySQL/MariaDB、外部 PostgreSQL。
· 支持公用地址簿，Outlook、Foxmail、Webmail 等可查看, 方便企业共享用户信息。
· 支持公共邮件夹功能, 可以设置读写权限，方便企业共享公用信息。Webmail 可以读写邮件，也可以在 Outlook, Foxmail 里查看。
· 企业版、旗舰版支持分布式部署功能，支持单域名多主机，满足多分支机构系统架设需求，可实现负载均衡架构。
· 企业版、旗舰版支持第三方 LDAP 认证、Radius 认证。
· 企业版、旗舰版支持用户密级和邮件密级。邮箱用户不可以发送和阅读高于自己密级的邮件。
· 对 SMTP, POP3, IMAP, LDAP, HTTP 可以支持 SSL 加密传输, 防止网络侦听, 通信更安全。
· 提供多种 Webmail 页面风格，支持移动设备：智能手机、平板, 提供 iPad 专用 Webmail 风格。
· 企业版、旗舰版提供 Push Mail 模块，可以用常用的智能手机和移动设备同步邮件、联系人、行事历，支持 iPhone、Android等。
· Webmail 全面支持 UTF-8。
· 提供网络磁盘功能，可以设置有密码保护的共享，可通过 Webmail 或通用的 FTP 客户端软件来访问。
· 提供网络行事历和网络记事本服务，标准化行事历，兼容 Outlook、Foxmail，支持共享。
· 支持创建、导入 CA SSL 证书。
· 支持密码安全策略，支持密码强度设定，支持定期强制改密码，不符合规则强制修改密码，可批量更新用户密码。支持邮件客户端授权码。
· 提供邮箱密码被猜解行为和群发行为检测功能，支持异地登录提醒功能。
· 支持邮件撤回功能, 支持 Webmail 和 Outlook，其他客户端发送的邮件满足条件的也可以在 Webmail 上进行撤回。
· 提供自动迁移第三方邮件系统数据的邮箱搬家功能，自动迁移原系统账户、密码和邮件.
· 支持新邮件手机短信提醒，微信提醒和钉钉提醒，有新邮件到达时，可在手机上及时获得通知。
· 支持邮件签核，可以在邮件发出前进行签核，支持条件签核，支持收件签核。
· 完全支持多域(虚拟域)。可以在单机中安装多个邮件域。
· 可与 Windows AD 帐号进行整合，方便管理。企业版、旗舰版支持自动同步 AD/LDAP 中账户。
· 企业版、旗舰版支持 Outlook 2013 Pushmail连接方式，支持邮件、日历、联系人、任务同步。
· 提供帐号导入,导出功能, 方便升级服务器。
· 提供快速设置向导, 只需输入几个简单参数, 让您一分钟内设置好邮件系统。
· 提供 SMTP/POP3/IMAP 客户 IP 访问频率限制的功能.
· 提供 SMTP/POP3/IMAP 同一 IP 同时连接次数限制的功能.
· 多IP服务器，可以设置外发邮件连出ip，可选择网卡上绑定的ip，支持单网卡多ip和多网卡多ip.
· 支持管理员新建、删除、禁用用户邮箱和设置用户邮箱大小。
· 可控制单用户发外部邮件，收外部邮件，修改密码等多项功能权限，可设置帐号有效时间。
· 可以设置只读邮箱，用户无法删除邮件，包括客户端和 Webmail。
· Webmail 支持大附件自动网络磁盘中转。邮件客户端发信也支持自动网络磁盘中转。
· Webmail 支持发送定时邮件。
· Webmail 可发送加密码邮件，同时也兼容 Foxmail 和腾讯邮箱系统相关功能。
· Webmail 里可以查看本邮箱的访问记录、发信记录、删信记录、隔离邮件。
· 企业版、旗舰版支持发信流量控制，系统、域、邮箱可以设置每小时和每日发信量。
· 企业版、旗舰版支持查看用户邮箱访问记录、发邮件记录、收邮件记录。
· 允许创建多个管理员, 支持单独的域管理员功能。
· 管理员可以远程管理服务器，连接协议采用了 SSL 加密。
· 支持 Web 管理, 管理员可以进行在网页上在线管理系统的邮箱和域名。
· 用户既可以接收公司内部的邮件，也可以接收通过 Internet 发来的邮件。
· 用户可以发送邮件到公司内部的用户，也可以发送邮件到 Internet 上其他用户。
· 支持多层级系统通信组，发往系统通信组邮件地址的邮件会自动分发给每个组成员, 支持 Everyone 组。
· 支持两种方式的邮件网关：POP3 下载和 ETRN 下载，可以实现多人共享一个邮件帐号而互不干扰。
· 支持垃圾邮件地址、IP、域名过滤、SPF 检查、RBL(Real-time Blackhole Lists)检查、DBL检查、白名单，识别虚假信头。
· 支持拒绝 SPF、PTR 不存在的连接和邮件。
· 支持邮件内嵌图片里文字识别过滤，有效过滤图片垃圾邮件。支持在线更新垃圾邮件规则库。
· 支持 DKIM 过滤和签名，设置 DKIM 也可以提高外发邮件的到达率。
· 支持系统级和邮箱级自定义过滤规则。
· 反垃圾邮件支持隔离区功能，用户和管理员可以取回和设置白名单，用户可以收到系统发的隔离通知邮件。
· 过滤整合 SpamAssassin, 实现智能化自学习过滤。
· 邮箱用户可以设置个人级发件人黑白名单，个人地址簿中的联系人自动加入白名单。
· 支持过滤指定的附件文件名、类型和附件个数过滤功能。
· 支持邮件归档功能, 可以将所有收发的邮件备份到指定邮箱或目录，用户和管理员可以在 Web 上查询、下载和恢复系统归档邮件，可以设置归档数据保留时间，支持单副本存储。
· 支持系统级备份和恢复功能, 可以设置自动备份，可以设置备份数据文件保留时间。
· 支持计划任务, 可设置执行时间段。
· 支持邮箱双向监控功能，被监控邮箱和监控人邮箱可以任意组合，支持条件监控，让管理无漏洞。
· 显示当前的当前活动连接，系统状态统计。
· 显示各系统服务流量统计图。
· 多种邮箱使用情况报表，让管理员及时了解系统运行状况。
· 多线程设计，满足大量用户的同时访问。
· 系统故障和恢复，不丢信，不并发冲突，不死锁。
· 系统退信可以设置语言，支持简体、繁体、英文，简体中文退信里提供原因解释和处理建议。
· 记录系统运行情况和各服务器的访问日志，可设置日志记录等级。
· 管理工具提供多语言版本，目前版本支持英文、简体中文和繁体中文。
· 操作方便、通俗易懂。
· 支持固定IP和动态IP接入 Internet 方式。
· 方便地安装和反安装 Install/Uninstall。
· 提供COM 接口组件, 可以编程操作用户账号,域名,管理员, 提供 asp, php, asp.net, c++, java 实例。
· 提供 OpenAPI 二次开发接口，HTTP 协议请求使用 GET/POST 方式，返回数据采用 JSON 格式, 方便与其他企业应用全面整合。


功能模块

它主要具有以下功能模块组成：

· SMTP 服务
SMTP服务可以支持多域名、域别名、ESMTP 发信验证等功能，可以将外发邮件通过MX记录直接递送给目的域名，也可以将其递送某台外发邮件服务器（如：ISP的SMTP服务器）， 并支持 SSL 安全传输协议加密通信。

· POP3 服务
用户可以通过通用邮件客户端软件 Outlook、Foxmail 等来收取服务器上的邮件，并支持 SSL 安全传输协议加密通信。

· IMAP 服务
用户可以通过通用邮件客户端软件 Outlook、Foxmail 等来直接操作服务器上的邮件, 支持中文邮件夹和子文件夹，并支持 SSL 安全传输协议加密通信。

· Webmail 服务
内置 Web 服务器，提供多种语言，多种界面风格的全功能 Webmail, 可以在网页上在线注册新邮箱, 收发邮件, 修改密码, 邮箱用户自设时区、自动转发、自动回复、设置短信等操作。 并支持 SSL 加密通信。 目前支持简体中文/繁体中文/英文/法语/德语/日语/韩语/西班牙语/等多种语言。Webmail 也可以与其他 Web 服务器整合
提供多种 Webmail 页面类型，支持移动设备：智能手机、平板, 提供移动设备专用 Webmail。
可发送加密码邮件，同时也兼容 Foxmail 和腾讯邮箱系统相关功能。可以查看本邮箱的访问记录、发信记录、删信记录、隔离邮件。 系统后台经过配置后，Webmail 可以在线预览 Office 附件。

· MySQL 支持
系统配置和认证信息默认使用内嵌式轻型数据库 SQLite，企业版、旗舰版支持内置 MySQL、外部 MySQL/MariaDB、外部 PostgreSQL，几种方式可以切换，数据可以迁移。

· 公用地址簿 ( 内置 LDAP 服务)
用户可以通过 Webmail 查看公用地址簿中的用户信息， Outlook 也直接访问公用地址簿。

· 公共邮件夹
支持公共邮件夹功能, 可以设置读写删除权限。有权限的用户可以在 Webmail 上进行邮件读写，也可以通过 Outlook、Foxmail 等支持 IMAP 协议的客户端软件查看公共邮件夹中的邮件。

· 密码安全策略
支持密码安全策略，可以设定密码强度，支持定期改密码，可以设置下次登录必须修改密码。不符合规则强制修改密码，批量更新用户密码，支持邮件客户端授权码。 提供邮箱密码被猜解行为检测功能，提供邮箱被盗用转发垃圾邮件行为检测功能，支持异地登录提醒功能。

· 邮件撤回功能
支持邮件撤回功能, 支持 Webmail 和 Outlook，其他客户端发送的邮件满足条件的也可以在 Webmail 上进行撤回。

· 网络磁盘
提供网络磁盘功能，并且可以设置有密码保护的共享。可以通过 Webmail 或 通用的 FTP 客户端软件来上传与下载网络磁盘中的文件。可以将网络磁盘上的文件以附件方式或者链接方式发邮件。

· 网络行事历与记事本
提供网络行事历功能和记事本，用户可以设置事件与任务来提醒完成某项任务，支持共享。

· 中继转发
通过别人的邮件服务器(中继服务器)将你的邮件系统的邮件递送到目标地址，支持多中继。

· 邮件签核与监控
管理员可以限制一些用户发信是否要经过指定管理员签核。签核管理员可以允许和拒绝需要签核的用户发送邮件。可以设置要签核邮件的条件，满足条件的邮件才签核。
支持收件签核。管理员对一些用户接收和发送的邮件进行监控，自动拷贝一份给管理员，可以设置要监控邮件的条件，满足条件的邮件才监控。

· 邮件杀毒
支持邮件杀毒功能，支持四种模式，支持几乎所有的杀毒引擎，有效的拦截、清除带毒邮件。企业版、旗舰版支持内嵌查毒引擎，支持自动更新。
Winmail 和杀毒引擎

· 邮件密级
[企业版、旗舰版]支持用户密级与邮件密级控制，密级从低到高分为“无”、“限制”、“秘密”和“机密”，对应的邮件也分“无”、“限制”、“秘密”和“机密”三个密级，邮箱用户不可以发送和阅读高于自己密级的邮件。

· Push Mail
[企业版、旗舰版]可以用常用的智能手机和移动设备同步邮件、联系人和日历，支持 iPhone、iPad、Android等，也支持 Outlook 2013 以上版本同步。

· 新邮件提醒
支持短信提醒，有新邮件到达时，可在手机上获得通知。采用网络短信平台通道方式。
支持系统级新邮件消息推送，可指定 URL，数据格式支持 JSON、XML、Form。
支持与微信认证服务号或企业微信整合，可以实现新邮件微信通知（企业微信），微信中登录 Webmail 收发邮件，微信里可以定制邮件相关菜单项。 Winmail 与微信绑定
支持与钉钉整合，可以实现新邮件钉钉通知，钉钉中登录 Webmail 收发邮件，钉钉里可以增加邮件微应用。 Winmail 与钉钉绑定

· 快速设置向导和系统迁移
本系统的提供快速设置向导工具, 只需输入几个简单参数, 让您一分钟内设置好邮件系统。 具体请见 安装与初始化设置。
提供自动迁移第三方邮件系统数据的邮箱搬家功能，自动迁移原系统账户、密码，后台使用POP3、IMAP下载原系统邮件， 也支持不同域名之间的迁移，以满足更新域名的要求。

· 多域
完全支持多域(虚拟域)，可以在单机中安装多个邮件域。

· Windows AD 认证和 LDAP 第三方认证
系统中的邮箱用户可以与 Windows AD 系统用户进行整合，收发的邮件的认证采用 AD 进行认证，提高系统的安全性，降低系统维护的复杂性。 企业版、旗舰版支持自动同步 AD/LDAP 中账户，还支持第三方 LDAP、Radius 认证。

· 用户管理
管理员可以新建、删除、禁用用户邮箱和设置用户邮箱大小、最多的邮件数、最大的允许发邮件字节数，以及用户信息是否公开等。可控制单用户发外部邮件，收外部邮件，修改密码等多项功能权限，可设置有效时间。可按部门管理用户。可以设置只读邮箱，用户无法删除邮件，包括客户端和 Webmail。 用户可以导入和导出。

· 系统通信组（邮件组、用户组）
管理员可以根据情况设置一些系统通信组（邮件组、用户组），系统会将发往系统通信组的邮件自动分发给每个组成员, 支持 Everyone 组, 支持外部邮箱地址。支持多层级系统通信组，实现树形企业通讯录。系统通讯组可以导入和导出。企业版、旗舰版： 系统通信组可以排序，系统通信组成员可以排序。

· 邮件网关
本系统还可以作为局域网的邮件网关，自动收取远程服务器上指定帐号的邮件，然后按照预设定的规则进行邮件分发给本地用户的功能。系统主要以两种方式来收取远程邮件：POP3收取和ETRN下载。 可以实现多人共享一个邮件帐号而互不干扰。

· 远程管理
本系统的管理工具可以远程管理邮件服务器，让管理员可以管理远在托管中心的邮件服务器，并支持同时管理多台服务器，协议采用SSL加密。 允许创建多个管理员, 支持单独的域管理员功能。支持 Web 管理, 管理员可以进行在网页上在线管理系统的邮箱和域名。

· 垃圾过滤
本邮件系统还提供了 IP 地址，域名，邮件来源，邮件头内容，邮件信体等方式的过滤，有效的的防止垃圾邮件和非法信息；支持SPF、RBL(Real Black List) 检查、DBL(Domain Black List)检查；支持白名单和识别虚假信头；支持过滤指定的附件文件名，类型和附件个数过滤功能。
提供自定义的系统级和邮箱级过滤规则。整合 SpamAssassin, 实现智能化自学习过滤。
邮箱用户可以设置个人级发件人黑白名单，个人地址簿中的联系人自动加入白名单。
s支持拒绝 SPF、PTR 不存在的连接和邮件。
支持 DKIM 过滤和签名，设置 DKIM 也可以提高外发邮件的到达率。
垃圾邮件处理方式支持放入隔离区，用户和管理员可以取回邮件和设置白名单，用户可以收到系统发的隔离通知邮件，在邮件可以点击链接取回。
支持邮件内嵌图片里文字识别过滤，有效过滤图片垃圾邮件。支持在线更新垃圾邮件规则库。

· 分布式部署
企业版、旗舰版支持分布式部署邮件系统，支持单域名多主机，满足多分支机构系统架设需求，支持不同地点不同网络下系统整体化部署，支持同环境下不同主机分但式部署。支持组织内账号、用户组信息同步，支持账号批量迁移。可实现负载均衡架构。

· 计划任务
管理员可以设置一些在某个特定时间或按某一个周期运行的任务（如，发送邮件到远程服器，收取远程服务器的邮件），还可以设置定期清理用户指定邮件夹下的邮件，处理长期不使用的邮箱。

· 访问控制
提供 SMTP/POP3/IMAP 服务 IP 访问频率限制的功能，提供 SMTP/POP3/IMAP 同一 IP 同时连接次数限制的功能， 可以针对特定用户设置特定服务访问控制。

· 系统日志和流量统计图
提供详细的系统运行日志，分 system(系统)、smtp、pop3、imap、queue(队列)、webmail、ftp(网络磁盘)、msms(短信/微信)、admin(管理) ，以便管理员能随时的了解系统运行情况或分析错误信息。
系统日志可以设置记录语言，支持简体、繁体、英文。
显示各系统服务流量统计图，数据保留30天。
多种邮箱用户使用情况报表，让管理员及时了解系统运行状况。

· 流量统计和控制
[企业版、旗舰版]可以记录用户邮箱访问记录、收信记录和发信记录，支持发信流量控制，可以设置系统、域、邮箱可以设置每小时和每日发信量。

· 系统备份和恢复
支持系统级备份和恢复功能, 可选择备份系统设置数据和用户邮件数据, 可以自动进行，可以设置备份保留时间。

· 系统邮件归档
支持收发邮件实时归档功能，用户和管理员可以在 Web 上查询和恢复系统归档邮件。可以设置归档邮件数据保留时间。

· 二次开发接口
提供 COM 接口组件, 可以编程操作用户账号,域名,管理员, 提供 asp, php, asp.net, c++, java 实例。提供远程 http url 开发接口和 Webmail 部分页面嵌入开发说明。
提供 OpenAPI 二次开发接口，HTTP 协议请求使用 GET/POST 方式，返回数据采用 JSON 格式, 方便与其他企业应用全面整合。


安装与初始化设置

准备

如果您还没有 Winmail Server 安装包，可以到 http://www.winmail.cn/download.php 去下载最新的安装程序；
如果您想要服务器可以给 Internet 上的其他信箱发信（如: test@163.com），您必须保证要安装的服务器可以联接 Internet，并设置了可用的 DNS；
如果您想要接收来自 Internet 的邮件，必须要拥有 Internet 上的合法域名（如：ourcompany.com），并将此域名MX解析到您的邮件服务器IP地址。如果你没有固定的IP地址，可以参考应用实例。

安装

在安装本系统之前，首先必须选定操作系统平台，可以考虑安装在 Windows 2016 等操作系统。然后运行安装包按照屏幕提示进行安装。

在安装过程中，安装程序会让您进行一些必要的选择，如安装组件、安装目录、运行方式以及设置管理员的登陆密码。

安装组件

安装组件有服务器核心(Server) 和 管理工具(Admin)两部份。管理工具支持远程管理，为了方便邮件系统管理员的日常管理，管理工具可以单独安装到另外一台计算机上。

选择运行方式、配置文件处理、默认语种

服务器核心(Server)运行方式主要有两种：作为系统服务运行和单独程序运行；两种运行方式的主要区别在于：系统服务运行方式，只需要计算机启动后，无需要登录到系统，程序就能够自动的运行；单独程序运行方式必须在用户登录系统后才能运行。 建议服务器核心程序采用以系统服务方式运行。

设置管理员的登陆密码

安装过程中，如果是检测到是第一次安装，或您选择覆盖已有的配置文件时，安装程序会提示的输入邮件系统管理员的登陆密码(必须输入)。默认的管理员名是 admin 。

在安装完成后，可以启动邮件服务器程序。这时应该会在系统托盘区的图标上显示一个服务器的图标。 表示成功运行。 表示运行失败。

运行失败的可能有以下几种情况：
1. 管理端口6000被占用，解决办法请见：安装后,为什么总是不能启动SMTP/POP3/ADMIN/HTTP/IMAP/LDAP服务？
2. 以前装过同一版本的软件，并且已经超过试用期。
3. 授权不正确。如用户数超过授权许可。

初始化设置

在成功运行后，管理员必须对系统进行一些初始化设置，系统才能正常运行。服务器在启动时如果发现还没有设置域名会自动运行快速设置向导，用户可以用它来简单快速的设置邮件服务器。当然用户也可以不用快速设置向导，用传统的管理端设置方法。

快速设置向导设置

用户输入一个要新建的邮箱地址及密码，点击“设置”按钮，设置向导会自动查找数据库是否存在要建的邮箱，如果发现不存在向导会向数据库中增加新域名和新的邮箱，同时向导也会测试 SMTP/POP3/ADMIN/HTTP 服务器是否启动成功以及是否要停止 IIS 中的 SMTP 服务。设置结束后，在设置结果栏中会报告设置信息及服务器测试信息，设置结果的最下面是也会给出有关邮件客户端软件的设置信息。

管理端设置

1.登陆管理端程序

运行 Winmail Server 服务器程序或双击系统托盘区的 [image] 图标，使用用户名(admin)和在安装时设定的密码登陆，有关管理工具的使用请见：管理工具

2.检查系统运行状态

使用"系统设置"/"系统服务"查看系统的 SMTP，POP3，ADMIN 服务是否正常运行， 可能会发现 SMTP 或 POP3 没有启动成功，使用"系统日志"/"SYSTEM"查看系统的日志信息，一般显示Port被占用无法启动，请关闭占用程序或者更换端口再重新启动相关的服务，例如在Win Windows 缺省安装时会 安装IIS的SMTP服务，从而导致邮件系统SMTP起不来。如果您找不到占用程序，可以用 fport 软件查看那个程序占用了端口，可到 http://www.winmail.cn/download_other.php 下载。

3.设置邮件域

为邮件系统设置一个域，如 ourcompany.com。请使用"域名设置"/"域名管理"，具体请见 域操作。

4.增加邮箱

使用"用户和组"/"用户管理"加入几个邮箱，有关操作请见 用户管理。

收发信测试

可以使用常用的邮件客户端软件，如 Outlook，Foxmail 来测试，“发送邮件服务器(smtp)”和“接收邮件服务器(pop3)”项中设置为邮件服务器的IP地址或主机名，pop3 用户名和口令要输入用户管理管理中设定的。

也可以用 Webmail 进行测试, 登陆地址是 http://yourserverip:6080/
也可以用 Webadmin 进行邮件系统管理, 登陆地址是 http://yourserverip:6080/admin/
注意：系统强制启用SMTP发信认证，用户在客户端软件中增加帐号时也必须设置SMTP发信认证。

对上述安装设置步骤如果还有问题，请见更详细的文档“Winmail 架设指南”


管理工具

邮件系统的管理可以通过专门提供的管理工具程序和 Web 管理两种方式。管理工具功能全面可以管理全部系统设置，支持远程管理。 Web 管理可以管理邮箱和域名基本设置。

启动

用户在安装邮件系统，如果在“选择组件”时，选择了“管理工具”，安装结束后就可以从“开始”->“程序”->“Winmail”->“Winmail管理工具”启动管理工具。当然如果在安装时，选择了创建快捷方式，也可从桌面图标，快捷工具条上启动管理工具。

使用

用户启用管理工具就可以看到如下的画面。

如果这时候没有出现登录窗口，请点击菜单上“连接”->“连接服务器...”。

如果您想管理本地的邮件服务器，请在“被管理服务器”中选择“本地主机”；如果您想管理远程的邮件服务器，请在“被管理服务器”中选择“远程主机”，并输入主机名或 IP 地址和连接端口。输入管理员的用户名和密码。同时您也可能选择“启动时显示此对话框”，以便每次启动时能自动显示登录窗口。用户登录后，会见到如下的画面：

这时候您可以在左边选择要管理的项目，在右边的画面中选择参数设置等。

在使用管理工具时，最好使用管理工具与邮件服务器软件是同一版本号的。一般管理工具的服务器版本不能低于邮件服务器软件的版本号。

如在登录时“服务器无响应”的提示框，则表示邮件服务器没有启动或管理服务程序没有启动。
如在登录时“Your IP address has been denied!”的提示框，则表示您的机器不允许被连接。
如在登录时“Login failure! The username or password is error.”的提示框，则表示用户名和密码不正确。
如在登录时“The server has too many concurrents, please try again later!”的提示框，则表示服务器同时在线的并发连接数太多，稍后再试。
在进行管理时，如果长时间等待状态，没有操作动作，系统将会提示“Your session is time out, please login again!”，这时请重新登录。

Web 管理

为方便管理员进行邮箱用户的日常维护，邮件系统还提供了“Web 管理”。

登陆地址是 http://yourserverip:6080/admin/

输入管理员的用户名和密码， 支持域管理员。

用户登录后，管理员可以对有权限域名及域名下的用户，组和别名进行管理。


系统信息

系统信息中主要列出了一些服务器系统信息(如：操作系统版号，内存情况，磁盘情况等)和有关本系统的情况(如：是否已授权，最多可用邮箱数，最多可用域名数，还能使用的天数，技术服务和版本升级截止日期等)。


系统设置

系统服务
SMTP设置
邮件网关
计划任务
高级设置
公共邮件夹
防病毒设置
新邮件提醒
系统备份


系统服务

系统服务中主要列出了系统中所有提供的服务的运行状态，绑定地址以及端口，超级管理员可以选择某个服务进行设置或启停。

服务功能

ADMIN 服务 | 本邮件系统所用的管理服务，管理工具可以通过此服务对邮件系统服务器进行的管理，此服务不能停止。如果此服务启动失败，则邮件系统不能正常运行。ADMIN 是 SSL 安全传输协议加密的。
SMTP 服务 | (Simple Mail Transfer Protocol，简单邮件传输协议) SMTP 服务用于发送邮件和接收其它邮件服务器发过来的邮件。
SMTP MSA 服务 | 功能与 SMTP 服务类似，主要用于客户端与服务器之间发信，必须要进行发信认证。
Secure SMTP 服务 | 通过 SSL 安全传输协议加密的 SMTP 服务，防止网络监听。
POP3 服务 | (Post Office Protocol，邮局协议) 用户通过客户端软件将存放在其邮箱中的邮件接收到本地。
Secure POP3 服务 | 通过 SSL 安全传输协议加密的 POP3 服务，防止网络监听。
IMAP 服务 | (Internet Message Access Protocol，Internet 邮件存取协议) 用户通过 Internet 直接在服务器上存取邮箱中的邮件。
Secure IMAP 服务 | 通过 SSL 安全传输协议加密的 IMAP 服务，防止网络监听。
HTTP 服务 | (Hypertext Transfer Protocol，超文件传输协议) Webmail 程序操作所用的协议。
Secure HTTP 服务 | 通过 SSL 安全传输协议加密的 HTTP 服务，防止网络监听。
FTP 服务 | (File Transfer Protocol 文件传送[输]协议) 网络磁盘所用的协议。
Secure FTP 服务 | 通过 SSL 安全传输协议加密的 FTP 服务，防止网络监听。
LDAP 服务 | (Lightwighted Directory Access Protocol 轻目录访问协议) 分布式目录型数据库服务器，主要存放公用地址簿，方便用户查询公共联系人。
MSMS 服务 | 新邮件消息通知发送服务。

功能选项

1.启动

从服务列表中选择某一已经停止服务，进行启动。如果服务一直启动不成功，应该到“系统日志”/“SYSTEM”中去查看启动失败的原因。
一般失败原因都是所用端口被占用。具请解决办法请见：安装后,为什么总是不能启动SMTP/POP3/ADMIN/HTTP/IMAP/LDAP服务？

2.停止

从服务列表中选择某一正在运行的服务，进行停止。
注意：ADMIN 服务是为邮件系统的管理提供服务，不允许停止。

3.设置

对选定的服务进行参数设置，如更改绑定 IP 地址，监听端口，存取控制设置等。

基本参数

IP 和端口 | 增加服务要绑定的 IP 地址和侦听的端口，可以增加多个IP地址和端口。
并发连接数 | 同时允许的最多并发连接数量，超过会拒绝连接。
超时时间 | 网络连接，数据传输的最长等待时间，单位：秒。
本系统启动时自动运行 | 系统启动时启用该服务，如果不希望开启某个服务，请不要勾选此选择项。
设置立即重启该服务 | 选择此项后，点击“确定”，即会重启该服务。

点击“增加”，从网卡上选择 IP 地址，设置服务要侦听的端口

存取控制

不限制访问服务的 IP 地址 | 任意的 IP 地址都能访问该服务。
禁止以下 IP 地址访问服务 | 列表框中的 IP 地址不允许访问该服务。限制某一段的 IP 地址，如 192.168.0. 这个网段的所有 IP，可以输入 192.168.0.即可。
只允许以下 IP 地址访问服务 | 只有列表框中的 IP 地址才有权访问该服务。允许某一段的 IP 地址，如 192.168.0. 这个网段的所有 IP，可以输入 192.168.0.即可。

频率控制

每个 IP 的最大连接并发数 | 每个 IP 的同时连接服务器的最大连接数。
每分钟每个 IP 最大连接数 | 每分钟，每个 IP 允许连接的最大数。
不受限制的 IP 列表 | 在列表框中的 IP 地址不受上述的两种情况限制。

注意事项

1. SMTP 服务一般不能更改端口，要用 25，如果 SMTP 服务更改了端口，其他邮件系统无法给你发信。
2. 目前 HTTP 服务不是采用的标准端口 80，而是用的 6080 端口，所以用户在使用Webmail时,必须注意指定端口。如在本机访问时，IE的地址栏必须输入 http://yourserverip:6080/ 当然如果您的服务器上没有其他 HTTP 服务使用 80 端口, 您可以将 Winmail 的 HTTP 服务的端口改为 80, 这样就可以直接使用 http://yourserverip/
3. 如果服务器一块网卡有两个地址（内部地址或为外部地址），如果要让两个地址都能访问，请设置SMTP/POP3/IMAP属性的“绑定地址”不应该设为固定地址（内部地址或为外部地址），应该设为0.0.0.0（服务器上的所有IP地址）。


SMTP 设置

主要是对 SMTP 服务和邮件递送的各参数进行设置。

基本参数

系统管理员邮箱 | 接收系统错误信件或发送系统错误邮件的邮箱。请填写有效的本系统内邮箱地址，请不要清空。经常查看此邮箱可以及时了解系统的运行状态。
HELO/EHLO 主机名 | SMTP 命令交互过程中，HELO/EHLO 用的主机名。空白表示使用主域名。这里一般填写能解析到邮件系统外网 IP 的主机名，如：mail.demo.com
每封邮件的最多收件人数 | 每封邮件最多允许的收件人数。
每封邮件的最大字节数 | 每封邮件允许的最大字节数。指信头（发件人，收件人，邮件主题，发信时间等内容），编码后的邮件内容，编码的后的所有附件的字节总和。
接收外域邮件最大字节数 | 接收来自外域邮箱的邮件时，允许的最大字节数。
发往外域邮件最大字节数 | 向外域邮箱发送邮件时，允许的最大字节数。
接收邮件的最多跳数 | SMTP 服务允许邮件最多经过的 SMTP 服务器个数。邮件每经过一个邮件服务器一般都会在邮件头上增加一个 Received 字段，这里主要计算 Received 个数
单次连接最多的重置次数 | SMTP 服务一次连接时，所允许的最多的重置次数（REST 命令次数）。
队列中失败邮件的重试间隔时间 | 邮件递送失败后，在队列中等待多长时间进行重新发送。建议值：20 分钟
队列中邮件的最长停留时间 | 邮件递送失败后，在队列中最长停留多长时间。建议值：2 小时
队列中未签核邮件的最长等待时间 | 需要等待签核的邮件，在队列中等待管理员签核，最长等待时间。
连接远程主机的超时间 | 外发邮件时，连接远程主机的超时时间。
外发邮件时连出 IP 地址 | 外发邮件时，绑定此 IP 发送邮件.如果服务器有多个 IP，可以设置其中一个 IP 作为外发 IP，不是本机的 IP 填写无效。
启用发信认证 | 只有经过身份认证的用户才能使用 SMTP 服务转发邮件。可以有效的防止非信任主机借用服务器发垃圾邮件。这个选项默认选中，无法修改的。
认证发信时发件人必须是本系统的域下用户 | 认证发邮件时，发件人地址必须是本系统中的邮箱地址。
发件人和认证用户必须一致 | 发件人和认证用户必须是同一邮箱帐号。可以有效防止系统内没有权限外发的用户借用有权限外发的帐号来发邮件。
以本系统中域名发邮件时必须认证 | 以包含本系统中域名的邮件地址来发邮件时必须认证。可以防止发垃圾邮件者伪造发件人来发垃圾邮件。
将 MS-TNEF 邮件转换成MIME格式邮件 | MS-TNEF 是 Microsoft Outlook 的特殊格式邮件（只有一个名为 winmail.dat 的附件），大多数非 Outlook 的邮件客户端软件都不能正常的解析。 启用此功能后，能自动的将 MS-TNEF 的邮件转换为通用的 MIME 格式的邮件。
支持 STARTLS 命令(SSL/TLS 传输) | 接受外部邮件时, 可以支持安全连接（SSL）。一般远程服务器会自选择连接方式。
支持 VRFY/EXPN 命令 | 支持 SMTP 的 VRFY/EXPN 命令。有的邮件系统(例如：verizon.net )需要该指令做验证。
禁止明文认证 | 启用此项后，SMTP 服务禁止用 PLAIN 和 LOGIN 的认证方式；Secure SMTP 和 SMTP MSA 服务，不受影响。
禁止 25 端口认证 | 启用此项后，侦听 25 端口的 SMTP 服务不允许提供认证功能，可以有效的防止的外网连接猜测密码。
邮件头增加“Sender”字段 | 启用此项后，当 SMTP 命令的 MAIL FROM 地址和邮件头的发件人地址不一致时，会增加 Sender 字段。

外发递送

通常情况无需设置这个功能。外发中继递送一般用于解决黑名单问题，本主机外网 IP 在黑名单里，无法外发部分邮件，可以使用中继服务商的主机外发。

递送规则 | 1. 当选择“通过查询 MX(邮件交换)记录直接递送”，发到外域的邮件会查询这些域名的 MX(邮件交换)记录，取得收件人服务器进行连接递送。如果选择“记录递送失败后，用中继服务器递送”，则在直接递送给收件人服务器失败后，接连中继服务器进行递送；如果不选择，则等待下次递送。 2. 当选择“启用中继服务器递送”，则所有发送到外域的邮件都直接到递送到中继服务器。如果中继服务器需要发信认证，还必选中“中继服务器需要认证”选项，同时也要正确设置认证的用户名与口令。
中继服务器 | 1. 当设置多个中继服务器时，系统会从上至下连接中继服务器递送邮件，直至递送成功。 2. 如果中继服务器需要发信认证，必选中“中继服务器需要认证”选项，同时也要正确设置认证的用户名与口令。 3. 有的中继服务器会在发信的交互过程中检查认证用户与 Mail From 中的地址是否一致，如果不一致将不允许发送，这时候要设置“发件人地址”，如：用 163.com,sohu.com 作为中继服务器。 4. “启用 SSL”选择后，可以支持只提供 SSL 连接的服务器做中继服务器(端口默认是 465)。如使用 gmail.com 作为中继服务器
远程服务器支持 STARTTLS 时，启用 SSL/TLS 连接 | 发信时, 如果远端服务器支持 STARTTLS 命令时，Winmail 会自动启用 SSL 加密连接通讯发送邮件，可以防止网络窃听；如果远程服务器不支持，则会继续使用普通连接发送邮件。

中继服务器设置，点击“增加”，在弹出对话框中输入中继服务器配置。也可以在中继服务器列表中，选择服务器记录，进行修改和删除。

允许转发域

当开启了“SMTP发信认证”时，发给这些域的邮件，可以不需要进行发信认证。切记不能将免费邮箱的域名加入，如 hotmail.com, aol.com, yahoo.com, qq.com 等等。

信任主机

当开启“SMTP 发信认证”时，此列表中主机地址发过来的邮件可以不需要进行发信认证直接转发出去。例如企业的OA，CRM系统需要发信，可以将这些系统的 IP 加入列表。谨慎增加，防止有人乱发邮件。

外域直接递送

针对某一域名，可以设置直接递送某个指定的主机。同一域名可以增加多个直接递送的主机，并且可以根据网络情况调整递送顺序。
需要使用这种功能的场景，在一个专网内有几个台不同的邮件系统，各邮件系统使用不同的域名，而又没有设置 DNS 的情况。
如果直接递送主机需要发信认证，可以选择“服务器需要认证”选项，同时正确设置认证的用户名与口令。
有的递送主机会在发信的交互过程中检查认证用户与 Mail From 中的地址是否一致，如果不一致将不允许发送，这时候要设置“发件人地址”，如：直接递送到 163.com

点击“增加”，在弹出对话框中输入域名和主机地址。也可以在主机列表中，选择主机记录，进行修改和删除。

域名直接递送失败后，使用系统外发递送规则：启用此项后，当直接发送域名指定的目标主机失败后，会使用系统外发递送规则查询域名的交换主机继续进行发送。如果没有启用，则始终使用域名直接递送，发送给目标主机，直至成功或超时回退。
有关外发递送规则设置请见：“外发递送”。

邮件头替换

设定邮头中要替换的内容。例如：内部邮箱 @look.com, @alook.com, @look.net 发出去的邮件中的地址要被替换成 @winmailserver.com，则只需要增加一条类似于列表中的第一条记录。同时至少选择一种替换方式。

点击“增加”，在弹出对话框中邮件头替换内容。也可以在列表中，选择记录，进行修改和删除。

邮件密级

客户端需要发送密级邮件时，可以通过暗送到不同密级指定的邮件地址，来实现对应邮件的密级。

注意事项

1. HELO/EHLO 主机名一般是填写您的主机名，能够正确解析出邮件系统所在主机的 IP 地址。
2. 如果您的邮件系统是在 Internet 上使用，请一定要开启“SMTP发信认证”。不然您的邮件系统很快就会成为垃圾邮件转发服务器。如果您邮件系统邮件已经被人转发垃圾邮件，请将“启用发信认证”，“发件人和认证用户必须一致”，“SMTP 通讯中，检查邮件地址的有效性”，“通过 DNS 检查发送者的邮件地址”和“给本系统内用户发邮件时，检查邮箱是否存在”这几个选项全选项，以阻止不合法邮件发送，同时也要分析“系统日志”/“SMTP”中的相关日志，来过滤可疑的发送主机 IP 地址，增加到“系统服务”中“SMTP”服务的“存取控制”列表中。
3. 发信时不需要认证的情况： 1) 发邮件主机的地址在“信任主机”列表中；2) 收件人地址的域名是本系统中的域名，域别名或在“直接递送域”列表中。
4. Winmail 中 SMTP 服务启动了，但无法发送邮送呢？
5. 本地能正常收发，能发给外域，但外域发过来不能收到，问题出现在哪里？
6. 我的邮件系统能收不能发，请问可能是什么原因呢？


邮件网关

POP3下载
ETRN设置


POP3下载

系统的 POP3 帐号记录，可以从其他邮件系统中通过 POP3 协议将指定帐号的邮件收取下来，然后可以按照各帐号设置的规则进行分发，从而实现邮件网关功能。

功能选项

1.新增

增加新的系统的 POP3 帐号记录

服务器地址 | 接收邮件的服务器地址。
服务器端口 | 接收邮件的端口。
生效 | 选中表示此条记录生效。
帐号名 | 用户邮箱帐号名。
密码 | 用户邮箱密码。
使用安全链接（SSL） | 启用加密链接转输数据，需要服务支持此功能。
下载邮件大小限制 | 允许下载的最大邮件尺寸。
下载邮件数限制 | 允许一次下载的最多邮件数。
在服务器上保留备份 | 选中则在邮件服务器上保留邮件，否则删除邮件。
直接递送至邮箱 | 将下载的邮件转发到其他的邮箱。
按信头分检 | 将下载的邮件按邮件头的有关字段分发到不同的内部邮箱。
用邮箱地址中的用户名替换邮箱名 信头中的邮箱地址的用户名替换邮箱名，从而产生新的邮箱地址。
例如：邮箱地址 "steven" <default@winmail.cn> 经过变化产生新的邮箱名为：steven@winmail.cn， 以此新邮箱名作为收件人的邮箱地址。可以实现多人共享一个邮件帐号而互不干扰。

高级设置

通过分析信头中的指定字段，取得其有效的邮箱地址进行递送。
用户可以针对实际情况选择要分析的信头字段，也可以自定义要分析的字段（多个字段间用分号[;]隔开）。

2.编辑

修改选定系统的 POP3 帐号记录。

3.删除

删除选定的系统的 POP3 帐号。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。

注意事项

生效条件:在"计划任务"中，必须有一条“接收系统 POP3 邮件”的事件。


ETRN设置

ETRN 帐号记录，通过 SMTP协议 中的 ETRN 命令将指定邮件系统队列中发给所设置的域名的邮件收取到本系统的邮件队列中，然后邮件队列程序将这些邮件分发各个接收人，从来实现邮件网关功能。ETRN 是 SMTP 服务器的一个扩展功能。用这种功能来实现邮件网关，需要指定的邮件系统的 SMTP 服务支持 ETRN 功能。

功能选项

1.新增

增加新的 ETRN 帐号记录。

域名 | ETRN帐号的域名。
描述 | 由客户自由填写。
生效 | 选中表示此条记录起作用。
需要认证 | 选中表示需要。
用户名 | 认证用户名。
密码 | 认证密码。

2.编辑

修改选定的 ETRN 记录。

3.删除

删除 ETRN 记录。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。

注意事项

生效条件:在"计划任务"中，必须有一条“接收外部 ETRN 邮件”的事件。


计划任务

用于设置某一时段或每隔一个周期去完成某些指定的任务。如：发送邮件到外域，收取系统或用户的POP3、清除用户邮件等。

功能选项

1.新增

任务名称 | 用户自己定义的任务名称。
生效 | 选中表示此计划任务生效。
定时执行 | 选中表示本任务只在指定时间执行。
循环执行 | 选中表示本任务每隔一个循环周期会自动执行一次。循环执行时可以设置执行时间段。
发送队列中的邮件 | 将队列中的所有等待外发的邮件全部发送出去。
接收系统 POP3 邮件 | 接收所有生效的系统 POP3 账号的邮件。在“邮件网关”/“POP3 下载”中设置账号。
接收外部 ETRN 邮件 | 接收所有生效的 ETRN 账号的邮件。在“邮件网关”/“ETRN 下载”中设置账号。
接收用户 POP3 邮件 | 接收所有用户的设置的 POP3 账号的邮件。系统中的邮箱用户可以通过 Webmail 下的“外部 POP3 邮箱”来设置。
清理用户的邮件 | 设置清理用户多少天前的指定文件夹的。
处理未使用的用户 | 设置删除或禁止多少天没有使用的邮箱用户帐号。
如果未在线则自动拨号 | 当执行“发送队列中的邮件”、“接收系统 POP3 邮件”、“接收外部ETRN邮件”和“接收用户 POP3 邮件”事件时，如果没有连接在 Internet 上，则可以选择是否要自动拨号连接到 Internet。
任务完成后自动挂线 | 如果拨号连接到 Internet，在任务完成后是否要断线。
动作指定对象 | 设置计划任务动作（接收用户 POP3 邮件，清理用户的邮件，处理未使用的用户）生效的对象。

当循环执行时，选择执行的时间段。

设置计划任务动作（接收用户 POP3 邮件，清理用户的邮件，处理未使用的用户）生效的用户对象。

2.编辑

修改选定的计划任务。

3.删除

删除选定的计划任务。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。


高级设置

系统参数
Webmail 设置
邮件模板
系统广播
邮箱监控
邮件签核
Internet 设置
SSL/TLS 证书
IP 归属地


系统参数

主要是对整个系统的一些参数进行设置，如：邮件存储目录，系统邮件模板，DNS设置，Webmail设置等。

基本参数

本地主机名/IP 地址 | 设置本机的主机名或 IP 地址。主要是用于企业版、旗舰版分布式布署时，主机识别。
服务欢迎信息 | 指定各服务（SMTP/POP3/IMAP/FTP）中的欢迎信息。有时候更改此标识可以有效的防止系统攻击。空白则显示“Winmail Server” 再加上系统时间。
系统邮件模板语言 | 设置邮件模板的语言。
IP 地址认证失败次数 | 同一个 IP 地址平均每分钟内认证失败的最大次数，可以有效防止某个 IP 来猜测密码
用户认证失败次数 | 同一个邮箱用户平均每分钟内认证失败的最大次数，可以有效防止猜测某个邮箱用户的密码
SMTP 认证次数 | 同一 IP 地址或邮箱用户平均每分钟内认证发信的最大次数，可以有效防止某个IP 地址不断连接认证发信或邮箱用户被猜到密码被转发垃圾邮件。
SMTP 外发收件人数 | 同一 IP 地址或邮箱用户平均每分钟内发到外域的最大收件人。可以有效防止某个IP 地址不断连接认证外发邮件或邮箱用户被猜到密码被转发垃圾邮件。
同样主题的邮件数 | 同一用户每天发送同样主题的邮件数，有效防止用户被利用来群发同样主题的垃圾邮件。
日志语言 | 设置记录日志的语言。
日志等级 | 设置日志的记录级别，可以控制日志信息量。
日志文件天数 | 保留的多少天的日志文件。
日志文件大小控制 | 可设置当日志文件达到多大后创建新的日志。

存储目录

邮件存储目录 | 设置用户邮件将被存放的目录。 单副本保存邮件：一封邮件同时发给多个收件人时，只保存一份邮件，提高递送效率，节约磁盘空间。
邮件队列目录 | 设置邮件队列存放在目录。
邮件备份目录 | 设置邮件备份存放在目录。有关邮件备份的设置，请见“系统备份”。
网络磁盘存储目录 | 设置网络磁盘存储目录。
日志文件存放目录 | 设置日志文件存放的目录。* 此项设置完成后，需要重启系统才能生效
其他邮件存储目录 | 当邮件存储目录的可用空间不够时，可以增加其他磁盘目录来存放邮件
磁盘空间软限制 | 如果磁盘的可用空间低于软限制，将出现警告消息，提醒管理员释放更多的磁盘空间。
磁盘空间硬限制 | 如果磁盘的可用空间低于硬限制，邮件系统将被停止。
注意： 1. 邮件存储目录、邮件队列目录、邮件备份目录、网络磁盘和日志存放目录不能设置成相同的目录。 2. 当修改目录时，为保证数据不丢失必须把旧目录结构拷贝到新目录下去。 3. 更改日志文件存放目录，必须重启邮件系统才能生效。

IPv6 设置

启用 IPv6 | 当服务器网卡支持 TCP/IPv6 协议时，Winmail 可以选择启用 IPv6
优先使用 IPv6 | 当邮件外发时，先通过 DNS 查询收件方域名是否有 IPv6 地址，优先使用 IPv6 协议连接发信。

DNS 设置

DNS 设置 | 可以选择使用操作系统网卡设置的DNS服务器或者设置指定的 DNS 服务器。
查询失败，从下列服务器查询 | 当 DNS 查询 MX 记录失败，从更多的 DNS 服务器查询。
DNS 缓存总数 | 临时记录最近查询的域名的 MX 记录和 A 记录，减少 DNS 查询，提高发信效率。可以清空和显示当前缓存。
注意： 1. 如果您不能确定 IP 接入商的DNS地址，可以使用以下公共 DNS。 114DNS: 114.114.114.114 , 114.114.115.115 阿里DNS: 223.5.5.5 , 223.6.6.6 DNSPod: 119.29.29.29 Google DNS: 8.8.8.8 , 8.8.4.4 Open DNS: 208.67.222.222 , 208.67.220.220 2. 如果对域名和DNS有疑问，请见：邮件/域名/DNS相关知识。

系统报表

系统报告接收邮箱 当产生系统报表时，将会发送到此邮箱。

系统签名

签名内容 用户发送邮件时，邮件附带的签名内容。
当要增加 HTML 签名内容时，直接输入 HTML 代码，选中“HTML 格式”。

FTP 配置

FTP 是提供网络磁盘服务。也可以用 FTP 客户端工具连接。

FTP 数据传输 | FTP的连接模式有两种，PORT(主动模式)和PASV(被动模式)，当FTP 连接时，使用“PASV 模式”进行数据传输时，返回给客户端的 IP 地址和连接端口。一般 IP 地址设置成外网的 IP 地址和对外开放的端口。
Secure FTP 数据传输 | 当Secure FTP 连接时，使用“PASV 模式”传输数据，返回给客户端的 IP 地址和连接端口。

HTTP 配置

HTTP 是提供 Webmail 服务。

以 FastCGI 运行 | FastCGI 运行方式相对于传统的 ISAP 运行方式具体效率高，响应快。
启用 PHP 缓存 | PHP 缓存可以生成中间代码，优化 PHP 脚本，提高 PHP 执行速度。
强制 https:// 访问 | 将通过 http:// 的访问重定向到 https://
最大上传文件 | 设置 Webmail 最大允许上传的文件大小。
Web管理访问目录名 | 为了安全可以修改默认的Web管理端的访问目录名
访问主机名 | 仅允许的主机名访问Webmail，阻止 IP 或其它恶意解析的主机名访问

LDAP 配置

Winmail 内置的 LDAP 主要存放公用地址簿联系人信息，方便用户查询公用联系人。

LDAP 写操作密码 | 设置向 LDAP 中写入信息时的操作密码
允许匿名访问 | 设置是否允许匿名读取 LDAP 中的用户信息。 这样通过客户端软件来查找公用地址簿时，就可以不需要设置查询的用户名和口令。具体请见“公用地址簿客户端”

ADMIN 配置

管理端配置

会话超时时间 | 管理端会话失效时间
登录需要二次验证 | 输入用户名和密码登录成功后，要输入令牌 APP 上的动态口令进行验证
防止猜密码 | 设置登录错误统计时间，允许的失败次数，来源 IP 禁用时间

数据库设置

系统配置和认证信息默认使用本地数据文件
企业版、旗舰版支持：内置 MySQL、兼容 MySQL 接口的数据库(外部)、兼容 PostgreSQL 接口的数据库(外部)、ODBC 连接(外部)，几种方式可以切换迁移。

本地数据文件 切换到 内置 MySQL 操作步骤：

1. 点击"内置 MySQL" - "测试连接"，系统会后台启动内置的 MySQL 服务，再连接，正常显示"连接数据库成功！"提示框，有时可能启用比较慢，导致提示无法连接，没有关系，再点击一次。
2. 选中"内置 MySQL"，提示"使用新数据库，如需要迁移当前数据，则应用前先执行导入数据操作"提示框，点击"是(Y)"，再点击"导入数据"，提示"导入数据将会重建数据库。是否要执行?"，点击"是(Y)"
3. 系统后台自动从 本地数据文件 导入数据到内置 MySQL, 完成后提示"数据导入成功！"
4. 点击本页最下面的"应用"保存本次修改，提示"修改数据库设置，必须重启邮件系统。"，手工关闭 Winmail 管理工具，再操作托盘上 Winmail 图标 [image] 重启一下 Winmail 服务器程序。

其他迁移操作类似，一般先"测试连接"，再"导入数据"，注意导入将先清空目标数据库中相关 Winmail 表的全部数据。如果连接或者导入到外部数据库不成功，检查访问权限，可以在服务器上使用其他数据库管理软件测试。

帐号同步

自动同步 Windows 域服器、第三方 LDAP 上用户到邮件系统中[仅企业版、旗舰版支持]。

同步第三方 LDAP 或者 AD

AD 帐号同步时，AD 用户信息修改的会同步更改邮箱用户信息，AD 用户禁用的邮箱用户自动禁用。


Webmail 设置

主要是对 Webmail 页面参数进行设置。

首页设置

Webmail 登录页不显示域名选择列表 | 启用此项，可以防止用户在登录时，看到系统的所有域名，不显示域名列表。普通域下用户登录时需要输入完整的邮箱地址。
允许使用“Web 管理”功能 | 启用此项，允许管理员通过 Web 方式进行管理。
Webmail 登录页显示“Web 管理”连接 | 启用此项，Webmail 登录页面显示“Web 管理”的连接。
Webmail 登录页显示“忘记密码”连接 | 启用此项，Webmail 登录页面显示“忘记密码”的连接。
Webmail 允许自动登录 | 启用此项，允许 Webmail 可以自动登录。
Webmail 启用会话 cookie | 启用此项，Webmail 登录后用 cookie 记录会话信息，防止拷贝登录后的 URL 直接访问。
Webmail 启用 IP 检查 | 启用此项，Webmail 登录后用访问者的 IP 信息，提高安全性。如果有多个出口 IP ，随机变化，建议不要启用此项。
显示在线帮助 | 显示 webmail 在线帮助。
显示语言列表框 | 登录页面显示语言选择列表框。
显示界面风格列表框 | 登录页面显示界面风格选择列表框。
不同界面风格，登录首页保持一致 | 在不同界面风格下，选择不同的登录风格，登录首页保持一致。
默认语言 | 设置默认的登录语言。
默认界面风格 | 设置默认的登录界面风格。
显示图形码 | 设置显示图形验证码。

登录后设置

登录后的默认页 | 设置邮箱用户登录后的默认显示页面。
会话超时时间 | 设置 Webmail 登录后不操作的等待时间。
公告板邮件夹 | 设置 Webmail 公告板的邮件夹。
读邮件时，显示附件中的图片 | 阅读邮件时，附件是图形文件，直接在邮件内容后显示。
默认编辑器 | 设置邮箱用户的默认编辑器
外发邮件编码 | 设置邮件编码方式。
使用云附件 | 有网络磁盘权限的用户，可以使用云附件。发邮件时超过指定大小，会自动使用共享链接发送。
自动保存新邮件到[草稿箱] | Webmail 每隔一段时间自动保存新邮件到“草稿箱”
保存已发送的邮件到[已发送]邮件夹 | 邮件发送后，将发送的邮件存储到[已发送]邮件夹。
启用阅读回条 | 设置是否默认开启阅读回条。
允许拼写检查 | 开启/禁止拼写检查功能。
允许用户启用新邮件通知 | 启用后，用户可以通过 Webmail 来设置短消息参数。
允许用户发送自写短信 | 允许用户通过 Webmail 直接发送短消息。

注册页面设置

邮箱名长度限制 | 设置邮箱名的最小长度。
密码长度限制 | 设置密码的最小长度。
显示图形码 | 注册页面和取回密码设置是否显示图形码。
字段值必填项限制 | 设置不能为空的字段项。
不能被注册邮箱名 | 设置不能被注册的邮箱名。

弱密码设置

弱密码字典 管理弱密码字串

二次验证

二次验证 设置是否启用二次验证，以及需要二次验证的场景和方式


邮件模板

主要是对邮件服务器的常用的系统邮件模板进行设置。

邮件模板

注册欢迎信 | 欢迎信是邮箱新建成功后，发送到该邮箱中第一封邮件。
错误回弹信 | 当一封邮件无法成功递送时，系统将错误回弹信发送给发件人，说明错误原因。
过滤通知信 | 当邮件系统检测到有病毒的附件或符合过滤条件的附件，会给收件人和邮件系统的管理员发过滤通知信。
容量警告信 | 当用户邮箱的容量达到设定的警告值时，系统会发送到警告信给该邮箱。
邮件签核通知 | 当邮件需要签核时，会发送签核通知信给管理员。需要签核的邮件会作为通知信的附件一同发给管理员。
邮件签核拒绝 | 当管理员拒绝签核邮件时，会发送签核拒绝信给发送者。
重载默认值 | 重新载入系统出厂的默认邮件模板。


系统广播

主要是对系统内的所有用户或指定域下的所有用户发送广播邮件。

系统广播

发送给 | 可以根据需要选择发送给所有用户或指定域下的用户。
主题 | 广播邮件的主题。
内容 | 广播邮件的内容。如果是 HTML 邮件直接输入 HTML 代码，然后选中“HTML 格式”选择框。


邮箱监控

对系统内的指定邮箱帐号所有的接到和发出邮件进行监控。

功能选项

1.新增

增加新的邮件监控规则

内部邮件 | 指内部邮箱互相送的邮件。
外部邮件 | 指发送到外部邮箱或从外部邮箱发过来的邮件。
输入邮件地址 | 可以输入某个邮箱地址或某域名下的所有邮箱地址。当输入 *@domain 时，监控 domain 域下的所有邮箱。
选择邮箱地址 | 从列表中列出的所有内部邮箱中选择一个（批）邮箱，增加到“被监控邮箱地址”、“监控发邮件的管理员”或“监控收邮件的管理员”列表中。
被监控邮箱地址 | 被监控的邮箱地址。
监控发邮件的管理员 | 満足条件的被监控邮箱所发出的邮件将会拷贝一份发送监控发邮件的管理员列表的邮箱中。
监控收邮件的管理员 | 満足条件的被监控邮箱所收到的邮件将会拷贝一份发送监控发邮件的管理员列表的邮箱中。
邮件主题增加前缀 | 监控管理员邮箱收到的监控邮件主题前面将加 [monitor] 标记。
注意：监控管理员邮箱地址不存在或收信出错，受监控的邮箱将会收到错误回弹信！！！

当需要设置邮箱监控条件时，可以点击“高级...”来设置条件规则。

2.编辑

修改选定的邮件监控规则。

3.删除

删除选定的邮件监控规则。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。


邮件签核

管理员可以限制一些用户发信是否要经过指定管理员签核。签核管理员可以允许和拒绝需要签核的用户发送邮件。

功能选项

1.新增

输入邮件地址 | 可以输入某个邮箱地址或指定域名下的所有邮箱。当输入 *@domain 时， domain 域下的所有邮箱都要签核。
选择邮箱地址 | 从列表中列出的所有内部邮箱中选择一个（批）邮箱，增加到“发送邮件需要签核的邮箱”、“发邮件到外域由下列管理员签核”或“发邮件到本域由下列管理员签核”邮箱地址列表中。
发送邮件需要签核的邮箱 | 发送邮件需要由管理员签核的邮箱。
发邮件到外域由下列管理员签核 | 需要邮件签核的邮箱发邮件到外域时，需管理员列表中任一管理员签核。
发邮件到本域由下列管理员签核 | 需要邮件签核的邮箱发邮件到本域时，需管理员列表中任一管理员签核。

当需要设置邮件签核条件时，可以点击“高级...”来设置条件规则。

2.编辑

修改选定的邮件签核规则。

3.删除

删除选定的邮件签核规则。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。


Internet设置

对邮件系统连接到 Internet 的方式进行设置。

如果是使用 Socks 代理服务器连接到 Internet 的，请设置 Socks 参数。 外发邮件和 POP3 下载时会用到代理服务器。


TLS/SSL 证书

SSL/TLS 证书

Winmail 服务器和客户之间所有的安全(Secure)通讯都使用加密的方式，以保护通讯数据的安全；Winmail 使用 SSL 加密通讯协议，服务器首先 使用一对不对称密钥与客户交换一个共享的对称密钥，此密钥被用来对通讯 数据加密。

不对称密钥有两个密钥: 公钥(Public Key)和私钥(Private Key),使用其中任 一个密钥加密的数据，必须要用另一个密钥解密。正如它们的名字，公钥被提供 给任何想和服务器通讯的客户，而私钥仅仅被服务器使用，且必须保密；对客户 而言需要鉴别服务器的身份(防止服务器被假冒)，通常使用证书标识服务器，证书包含服务器的公钥、服务器的名称、有效日期和其它细节；为确保证书的真实性，证书 应该被第三方(CA)证明和签署。

客户与服务器的通讯原理概要：客户产生一个对称的密钥K，然后接收服务器发送过来的 服务器的证书，并使用证书中公钥(服务器的公钥)加密对称密钥K，然后把加密的密钥发送给 服务器，服务器使用只有自己知道的服务器的私钥解密数据得到对称密钥K；因此对称密钥 只有通讯双方的客户和服务器知道,保证了通讯数据的安全。

Winmail 证书

请访问 http://www.winmail.cn/docs/ssl/ 查看网站上的 "Winmail 配置SSL服务器证书"

Winmail 证书和私钥一般放在安装目录的certs子目录下，扩展名为“.crt”的文件 是存放证书的文件，扩展名为“.csr”的是存放请求的文件（下面部分有解释），扩展名是“.key”的是存放私钥的文件，证书文件(或请求文件)同文件名相同的私钥文件意义对应。
安装完成后 会有一个初试的示例证书，建议客户要及时创建、使用自己的证书。

下面以OE(OutLook Express 6.0)使用Secure IMAP客户为例，说明证书的应用，如果服务器 发送给OE的证书不被OE信任将会看到一下的信息，如果被OE信任将不会显示以下的信息。

点击 "是"， 那么同服务器连接将接续
点击 "否"， 将断开同服务器的连接

注意： 如果要让客户端直接信任服务器所发送的证书，不产生警告对话框； 可以将服务器正在使用的证书导出，然后将此证书发放给各个客户； 客户将此证书导入客户端机器即可，具体的证书的导入可以参照具体 客户端软件的帮助文档(以Windows Outlook为例， 只要双击证书，再点击安装证书按钮即可)。以上操作的必要条件是： 证书中的主机名必须和服务器正确的主机名以及客户端软件设置部分 填写的服务器主机名保持一致才能让客户端信任此证书。

证书管理

Winmail 提供了管理证书的功能，主要创建，管理证书和证书请求。
证书：可以创建和管理自签名证书，是不被信任的(除非是根证书)，但是可以完成加密的通讯。也可以导入外部证书机构颁发的可信任的加密证书
证书请求：按指定要求生成公私钥证书请求(CSR)，但没有被签名，不能用来做为证书完成加密通讯。需要先导出请求，发送第三方证书机构签署后可以正常使用。

1. 新建...

创建新的自签名证书或证书请求。
当多个域名同时使用一个证书时，需要设置“使用者备用名”，如，DNS:mail.winmail.cn, DNS:mail.119.com, DNS:mail.test.com

2. 查看...

3. 导入...

导入新证书：把本机（管理端）中的证书和与证书对应的密钥导入服务的证书管理数据库
导入已签名证书：当请求被选中时，可以导入一个这个请求第三方被签名后生成的证书， 如果选择的证书不是本请求本第三方签名的证书，本导入操作将失败

4. 导出...

导出证书，导出请求：导出被选中的证书或者请求，并以文件的形式存储在本机中，证书的默认扩展名“.crt”，请求的默认扩展名“.csr"，导出的证书可以产看更为详细的信息。
导出私钥：导出与被选中证书或者请求相对应的私钥，并以文件的形式存储在本机中，默认扩展名“.key”

5. 删除

删除被选中的证书或者请求，与之对于的私钥也被删除

6. 激活

指定 Winmail 服务使用被选定的证书进行 SSL 通讯

7. 刷新

重新获取 Winmail 服务器中证书或者请求的列表


IP 归属地

设置 IP 地址对应的归属地。对于IP 归属地库中标记不正确的 IP 地址，可以设置正确的归属地进行修正。

功能选项

1.新增

增加 IP 地址段的归属地进行调整。

排序号 | 查询的优先级
起始 IP | 设置起始 IP
结束 IP | 设置终止 IP
归属地 | IP 的归属地，一般以省市形式命名，如江苏南京

2.编辑

修改选定的IP 归属地。

3.删除

删除选定的IP 归属地。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。


公共邮件夹

公共邮件夹可以使被授权用户通过 Webmail 或 IMAP 客户端共享一个邮件夹，以实现邮件在用户间的共享。

功能选项

1.新增

步骤一：设置邮件夹名称及容量

公共邮箱名称 | 用户在 IMAP 客户端中可以看到的邮箱名称，系统自动加上@前缀以标识是非用户邮箱
邮箱容量限制 | 指示本公共邮箱的最大容量
允许最大邮件数 | 指出本公共邮箱可容纳的最大邮件数

步骤二：设置邮件夹操作权限

公共邮箱的权限有三种:读、写、删除。将指定的被授权用户加入右边的指定的权限列表框即可，用户不能看到未授权公共邮件夹。

输入帐号时，“@domain”代表 domain 域下所有的用帐号。

2.编辑

修改邮件夹的属性设置，画面和操作同新建；此时不能修改邮件夹的名称。

3.删除

删除已经建立的公共邮件夹。

4.刷新

重新获取在服务器上公共邮件夹的列表。

5.查看方式

可以通过支持 IMAP 协议的客户端软件，如 Outlook、Foxmail 等软件查看，也可以通过 Webmail 来查看公共邮件夹。


防病毒设置

本系统能与 Windows 上装的杀毒软件(支持几乎所有的杀毒引擎)进行整合，扫描来往邮件，有效的隔离和清除带毒邮件。

防病毒引擎

工作模式 | 命令行程序, 杀毒程序 API 接口, 病毒防火墙, 集成防病毒引擎
一、使用命令行程序
杀毒产品名称 | 给出杀毒产品名称。
执行程序路径 | 列出杀毒产品的可执程序的路径。注意路径中最好不能有空格；如有空格，请将路径以引号括起来。
命令行参数 | 输出执行程序运行时的参数。
发现字串 | 检毒结果报告中，发现病毒时的特征码。
没有发现字串 | 检毒结果报告中，没有发现病毒时的特征码。
注意： 1. 在命令行参数中，用%TEMPDIR%来表示要杀毒的目录；用 %REPORTFILE% 来表示扫毒结果报告文件。 2. 使用邮件病毒扫描功能前，必须关闭病毒防火墙或病毒实时监控。
二、使用杀毒程序 API
杀毒产品名称 | 选择杀毒产品名称。支持AVG 6.x 和 AVG 7.x
三、使用病毒防火墙
支持几乎所有的病毒防火墙。使用病毒防火墙时，要设置防毒软件发现病毒自动清除, 并且关闭警告提示。
四、集成防病毒引擎
Winmail 自带了 ClamAV 防病毒程序和病毒库，winmail 会自动更新病毒库。(白金版才有此功能) ClamAV 介绍 http://www.clamav.net
发送测试信
发送一无害的国际标准病毒样本，如果设置正确管理员信箱会收到一封警告信。 您可以到 http://www.eicar.org/anti_virus_test_file.htm 下载这个病毒样本。
注意： 1. 不要在服务器上安装多个杀毒产品，否则可能带来无法预知的结果。 2. 为什么服务器上安装了诺顿 Norton 防毒程序后 Winmail 有时会自动关闭？ 3. 为什么服务器上安装了瑞星防毒程序后不能正常收发邮件？
常用杀毒产品和 Winmail 详细设置文档: Winmail 和杀毒引擎配合

附件过滤

过滤邮件中含中指定特征的附件。

防病毒动作

注意：
1. 如果设置“发送病毒通知信给接收者”，当接收者很多的时候可能会比较影响效率。
2. 一般可以不开启病毒警告邮件通知，因正常的邮件收发过程中附件含病毒机率比较小；病毒邮件一般都没有正确的发件人和收件人地址，通知邮件会经过多次递送，最终递送给管理员，病毒邮件频繁的时候会比较影响效率。


系统备份

支持系统级备份和恢复功能，可选择备份系统设置数据和用户邮件数据，可以自动进行。也可以对邮件系统的所有发出的和收到的邮件进行实时备份。

邮件归档

启用邮件归档 | 设定是否启用邮件归档。
要归档的邮件类型 | 有四种类型：本地邮件、收到的邮件、发出的邮件和中转的邮件。
备份位置 | 可以分为归档到邮箱和归档到文件。 当归档到文件夹时，用户可设定文件夹的名称。文件夹是建立在“高级设置”/“系统参数”中的设置的备份目录中。如果没有设置备份目录，则备份到邮件系统所在目录下 server\archive 中。
按用户分目录保存 | 选择后每封邮件按各用户创建目录保存邮件。如果不选择这项，系统是单副本存储归档邮件的。
自动清除 | 可以设置系统自动清除旧的归档文件。
指定用户 | 可以设置要归档的邮箱用户，或者排除指定邮箱用户。

系统备份

备份方式 | 有两种方式：备份系统数据和备份所有数据。
备份方式 | 备份文件夹名称格式。文件夹是建立在“高级设置”/“系统参数”中的设定的备份目录中。如果没有设定备份目录 则备份到邮件系统所在目录下 server\backup 中。
备份文件清单 | 列出已有的备份文件。
备份 | 按现在的备份方式进行即时备份。当选择备份所有数据时，如果系统用户邮箱中邮件较多时可能会要等待很长的时间。 建议：如果系统用户邮箱中邮件较多时，即时备份仅备份系统数据。
恢复 | 选取某一个备份档案进行恢复。
删除 | 删除某一个备份档案。
自动备份 | 选取一个执行频率系统自动按照已选的备份方式进行备份。
自动清除 | 可以设置系统自动清除旧的备份文件。
注意：系统即时备份与恢复时，最好停止系统的 SMTP/POP3/IMAP/HTTP 等服务。具体操作请见“系统服务”


新邮件提醒

Winmail 支持三种新邮件提醒示方式：手机短信通知，微信消息提醒和钉钉消息提醒，有新邮件到达时，可在手机上及时获得通知。

方式一：短信方式

管理员在管理程序里设置短消息参数，邮箱用户都使用系统级设置，可以设置使用权限。
邮箱用户自行在 Webmail 中设置自己是否启短消息提醒，以及设置接收短信的手机号。

目前采用短消息网关和 GSM 短信猫两种工作方式。

1）采用网络短信通道方式

请参考 Winmail 产品网站相关介绍 http://www.winmail.cn/technic_sms.php

方式二：微信方式

请参考 Winmail 产品网站相关介绍 http://www.winmail.cn/technic_wx.php

方式三：钉钉方式

请参考 Winmail 产品网站相关介绍: http://www.winmail.cn/technic_dd.php

短消息设置

启用新邮件短信通知 | 是否允许启用系统的新邮件短信通知
最多接收短消息数 | 每个用户，每天允许接收的最多新邮件通知短消息数。
手机短信 | 可以选择短信网关或 GSM 短信猫通知方式
注意： 要使用 GSM 短信猫来发短信，首先要在服务器的串口接口上接入 GSM 短信猫，然后要从 Winmail 提供商购买一个 GSM 短信猫支持的激活码，激活此功能后才能使用。
微信 | 可以选择使用认证服务号或企业微信来发送微信提醒消息
钉钉 | 可以使用钉钉的开放接口来发送钉钉提醒消息

用户列表

设置允许的使用的此参数的进行短消息通知的用户。

短消息内容

设置发送通知的手机短信内容和企业微信的通知消息。

新邮件推送

新邮件到达后，可以推送到指定的网址

推送 URL 接收新邮件数据的网址，支持 http 和 https。
数据格式 POST 提交 json/xml/form 新邮件数据，数据格式如下：

json数据格式 (UTF-8 编码)：
{
"to":收件人邮件地址;
"msgid":邮件ID;
"sender":SMTP 命令发件人;
"from":邮件头发件人;
"subject":邮件主题;
"body":邮件内容(前 512 字符);
"attachnum":附件个数;
"attachlist":附件文件名列表(以 || 分隔);
};
xml 数据格式 (UTF-8 编码)：
<?xml version="1.0" encoding="UTF-8"?>
<Request>
<To>收件人邮件地址</To>
<MsgId>邮件ID</MsgId>
<Sender>SMTP 命令发件人</Sender>
<From>邮件头发件人</From>
<Subject>邮件主题</Subject>
<Body>邮件内容(前 512 字符)</Body>
<AttachNum>附件个数</AttachNum>
<AttachList>附件文件名列表(以 || 分隔)</AttachList>
</Request>
form 数据格式 (UTF-8 编码)：
wm_to=收件人邮件地址;
wm_msgid=邮件ID;
wm_sender=SMTP 命令发件人;
wm_from=邮件头发件人;
wm_subject=邮件主题;
wm_body=邮件内容(前 512 字符);
wm_attachnum=附件个数;
wm_attachlist=附件文件名列表(以 || 分隔);

Webmail 新邮件提醒

用户可以通过 Webmail 来设置新邮件提醒的手机号或绑定微信号和钉钉号。


系统状态

SMTP 过滤
黑白名单设置
RBL/RWL 设置
灰名单设置
邮件过滤
内嵌图过滤
在线垃圾邮件库
邮件隔离区


SMTP 过滤

通过设置 SMTP 服务过滤规则，来增强对垃圾邮件的检查和过滤。

SMTP 过滤

允许 MAIL FROM 命令中出现空地址 (MAIL FROM: <>) | 允许 MAIL FROM 命令中出现空地址(MAIL FROM: <>)。在有的邮件系统，发送退信时为了防止邮件循环，MAIL FROM 地址是作为空地址。
SMTP 通讯中，检查邮件地址的有效性 | SMTP 命令交互过程中，检查邮件地址是否符合 rfc822 标准。
给本系统内用户发邮件时，检查邮箱是否存在 | 给本系统内用户发邮件时，检查收件人邮箱是否是系统内的存在的邮箱用户。
查询 DNS 检查发件人邮件地址中的域名是否存在 | 用 DNS 查询发件人邮件地址的域名是否是 INTERNET 上的有效域名。检查发件人域名的 MX 和域名本身指向的地址是否存在。用此项来检查时需要 DNS 服务器比较稳定可靠。
连接发件人的邮件服务器校验发件人地址是否存在 | 通过 DNS 查询域名发件人的邮件服务器，连接对方服务器校验发件人的地址是否存在。 说明：需要对方服务器支持 Mail from: <> 的命令
检查 HELO/EHLO 主机名的 A 记录或 MX 记录 | 检查 HELO/EHLO 主机名的 A 记录或 MX 记录与连接的 IP 地址是否匹配。用此项来检查时需要 DNS 服务器比较稳定可靠。 匹配类型： A Class：比较 A 类地址，如：119.119.119.119 与 119.51.127.156 是匹配的 B Class：比较 B 类地址，如：119.119.119.119 与 119.119.127.156 是匹配的 C Class：比较 C 类地址，如：119.119.119.119 与 119.119.119.156 是匹配的 D Class：比较 D 类地址，如：119.119.119.119 与 119.119.119.119 是匹配的
拒绝 HELO/EHLO 的主机名 | 拒绝“HELO/EHLO 过滤”中列出的 HELO/EHLO 的主机名。
启用 SPF 检查 | SPF 是发送方策略框架 (Sender Policy Framework) 的缩写，主要是通过 DNS 查询来检查邮件来源的服务器地址是不是域名所有者所设定发件服务器地址，防止伪造邮件地址发送垃圾邮件。 拒绝没有 SPF 记录的发件人域名: 如果对方域名没有设置 SPF 记录，就拒绝邮件，这项比较严格，一般不建议启用。
启用 DKIM 检查 | DKIM 是域名密钥识别邮件 (DomainKeys Identified Mail) 的缩写，DKIM 的基本工作原理是基于传统的密钥认证方式，有公钥(public key)和私钥(private key)组成，公钥将会存放在 DNS 的 TXT 记录中，而私钥会存放在寄信服务器中。发件者服务器会自动产生数字签名，并依附在邮件头中，发送到寄信者的服务器里。收信的服务器，将则通过 DNS 查询获取域名的公钥，验证邮件头中的签名是否有效。如果验证无效，则判定为垃圾邮件。
拒绝没有 PTR （Reverse DNS, RDNS） 的发信 IP | 拒绝没有 IP 反向解析的连接，这项比较严格，一般不建议启用。
检查 MAIL FROM 命令与信头中的 FROM 字段地址一致 | 检查发信时，SMTP 命令中的 MAIL FROM 命令的发件人地址与邮件信头中的 From 字段中发件人地址是否一致，这项比较严格，一般不建议启用。
检查 RCPT TO 命令与信头中 TO/CC/Delivered-To/Received 字段中的地址一致 | 检查发信时，SMTP 命令中的 RCPT TO 命令的收件人地址与邮件信头中的 TO/CC/Delivered-To/Received 字段中收件人地址是否一致，这项比较严格，一般不建议启用。 注意：启用此项检查后，发送时不能使用“密送(Bcc)”
启用陷阱邮箱 | 将一个本系统内的邮箱公开在网站上，让垃圾邮件发送者收录，当给这个邮箱发邮件时，系统会自动将发送者的 IP 屏蔽一段时间。
启用 SpamAssassin 过滤 | 启用知名的垃圾邮件过滤软件 SpamAssassin 来对可疑邮件进行检查过滤。 SpamAssassin 过滤是采用判断邮件是否符合某种特征并加以评分的方法来对邮件进行分类。 有关 SpamAssassin 介绍参考 http://spamassassin.apache.org/
动态过滤主机 | 显示被系统屏蔽主机的 ip 和加入时间，可以手工清除，系统自动清除 15 分钟以前的数据； 通过系统过滤检查信任主机的 ip 和加入时间，可以手工清除，系统自动清除 60 分钟以前的数据；。
垃圾邮件处理 | SMTP 接收邮件进行上面过滤动作，如果被判断为垃圾邮件，可以对此邮件进行如下处理： 1.拒绝接收 － SMTP 通讯过程中，直接返回错误提示。 2.发送到指定的邮箱 －将所有的垃圾邮件发送到指定的邮箱。 3.邮件主题前缀 － 垃圾邮件的主题前增加 [SPAM] 字串，继续递送给收件人。 保存到隔离区：被判定为垃圾邮件的，可以选择保存到隔离区。收件人可以在 Webmail 上可以查看隔离区，并取回隔离邮件。隔离邮件最长保留 30 天。
流量控制 | 启用后，认证用户发信时会进行流量检查。详细的用户流量控制可以在“用户管理”中“流量控制”进行设置。(特殊版本才有此功能)


黑白名单设置

对发件人，收件人，IP地址等设置黑名单和白名单。

发件人过滤

发件人黑名单和发件人白名单列表可以是：邮件地址、域名。这个地址一般应该从 “系统日志”/“SMTP”中分析出的邮件地址，而不是从收到的邮件头中看到的邮件地址。因为邮件头中发件人地址与实际发邮件命令中的发件人( SMTP 协议中的 MAIL FROM 命令)的地址可以不一样。如果需要过滤或允许 demomail.com 域名所有用户发过来的邮件，可以将 @demomail.com 增加到黑名单或白名单列表中。

发件人黑名单：禁止列表中邮件地址发过来的所有邮件。
如果想过滤发件人的 IP 地址时，请在“系统服务”中，对“SMTP 服务”和“Secure SMTP 服务”的“存取控制”进行设置。

发件人白名单：允许列表中邮件地址发过来的所有邮件。
如果信任发件人的 IP 地址时，请在“SMTP 设置”中，对“信任主机”进行设置。

收件人过滤

收件人黑名单和收件人白名单列表可以是：邮件地址、域名。这个地址一般应该从 “系统日志”/“SMTP”中分析出的邮件地址，而不是从收到的邮件头中看到的邮件地址。因为邮件头中收件人地址与实际发邮件命令中的收件人( SMTP 协议中的 RCPT TO 命令)的地址可以不一样。如果需要过滤或允许 demomail.com 域名所有用户发过来的邮件，可以将 @demomail.com 增加到黑名单或白名单列表中。

收件人黑名单：为了防止垃圾邮件发送者的攻击，始终给系统中的某些用户发邮件。
用户可以过滤一些系统中不存在的用户的邮件地址，请选择“给本系统内用户发邮件时，检查邮箱是否存在”。

收件人白名单：如果需要对某些收件人不作过滤规则的检查，请增加到白名单的列表中。

IP 过滤

发信 IP 黑名单和发信 IP 白名单列表是填写 SMTP 日志中来源服务器的 IP 地址。

发信 IP 黑名单：拒绝某个 IP 地址或某段 IP 地址连接发送邮件。可以填写 219.159.20. 表示过滤 219.159.20. 开头的所有 IP。

发信 IP 白名单：对某个 IP 地址或某段 IP 地址发送邮件不进行垃圾邮件检查。

HELO/PTR 过滤

HELO/PTR 主机黑名单和HELO/PTR 主机白名单填写 SMTP 日志中的 HELO 主机名。
如果用户不想接收动态域名主机发过来的邮件，可以填写动态域名到黑名单列表中来过滤动态域名发过来的邮件。

HELO/PTR 主机黑名单：拒绝 HELO 主机名是黑名单列表中的主机发来的邮件。如果用户不想接收动态域名主机发过来的邮件，可以填写动态域名到黑名单列表中来过滤动态域名发过来的邮件。

HELO/PTR 主机白名单：接收 HELO 主机名是白名单列表中的主机发来的邮件，可以解决有的邮件系统 helo 主机名设置错误或 helo 主机名没有正确解析，导致被拒绝接收。如：Microsoft Office 365 的企业邮局。


RBL 设置

RBL(Real-time Black List, 实时黑名单)：接收来自外域的邮件时，通过 RBL黑名单服务器对来源 IP 进行检查，决定是否过滤此邮件。

DBL(Domain Black List, 域名黑名单)：接收来自外域的邮件，通过 DBL黑名单服务器对发件者的主机名和域名进行检查，决定是否过滤此邮件。

常用的 RBL 服务器:
sbl.spamhaus.org
cbl.abuseat.org
b.barracudacentral.org
bl.spamcop.net
psbl.surriel.com

常用的 DBL 服务器:
dbl.spamhaus.org
multi.surbl.org


灰名单

灰名单(Greylisting)： 系统第一次收到未通过验证的发件人和 IP 地址来信时，回应4xx的回传代码，待稍后对方系统邮件重新发过来时，才接受邮件，可提高垃圾邮件的识别率，针对正常重新发过来的发件人，邮件系统会自动加白名单。 可以显示当前灰名单的列表。功能原理请访问：http://www.greylisting.org/ 建议设置运行时间段为垃圾邮件比较多的时间。比如每天的晚上19点到第二天的早上7点，要避开工作时间段。


邮件过滤

在邮件递送过程，分析邮件中的内容是否满足设定的规则。管理员也可以根据实际情况，通过设定过滤规则来完成邮件的分发。

功能选项

1.新增

增加新的过滤规则。

规则名称 | 由用户自己命名，各过滤规则的名称不能相同。
排序号 | 过滤规则的优先级
过滤字段 指出所要过滤的信头中的字段名。如要包含如下几种字段：发件人，收件人，抄送，主题，Received，邮件头，邮件内容 等。
Received 是指经过各邮件服务器，由邮件服务器增加的标识字段。
匹配方式 | 多种类型：为空、不存在、包含(不区分大小写)、包含(区分大小写)、不包含(不区分大小写)、不包含(区分大小写)、等于(不区分大小写)、等于(区分大小写)、不等于(不区分大小写)、不等于(区分大小写)。
过滤内容

要过滤的内容。可以写表达式，如：过滤类似这样串 test{sex}test 可以写能表达式 *{*}*
注意：多个过滤内容可以用分号(;)隔开
启用 | 设置此过滤规则是否生效。
动作 满足条件：丢弃、发送通知信给发送者、继续递送给接收者、保存到隔离区。同时也可以设置递送给某个用户。
递送给栏目可以增加多个邮件地址，各邮件地址用分号(;)分隔开。
不满足条件：可以继续过滤规则或终止过滤过滤规则。

2.编辑

修改选定的过滤规则。

3.删除

删除选定的过滤规则。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。

注意事项

当系统设有“邮件监控”和“过滤规则”情况下，满足过滤条件的动作没有选择“继续递送给接收者”时，被过滤的邮件不会被监控到。


内嵌图过滤

通过 OCR 识别邮件内嵌图中的文字，包含指定关健字的内嵌图邮件，会被判断成垃圾邮件


在线垃圾邮件库

服务期内的客户可以享受从 Winmail 官网在线更新最新的垃圾邮件过滤规则库


邮件隔离区

如果在“SMTP 设置”中，设置了垃圾邮件保存在隔离区，收到垃圾邮件时，会被自动保存在特定文件夹，以便用户和管理员能取回。

功能选项

1.发送

重新发送区选中的隔离邮件给收件人。

2.加白名单

将隔离邮件的发件人地址加入到系统的发件人白名单。

3.设置

设置隔离邮件是否发送通知给收件人以及隔离邮件保留多少天。

用户 Webmail 取回

收件人也可以登录 Webmail 看到自己的隔离邮件并取回；如果设置了上面的"Webmail URL"，用户也可以通过隔离通知邮件中的链接来取回。


过滤统计

统计各项过滤规则，在某个时间段内过滤的总数


域名设置

域名管理
域别名管理


域名管理

对邮件系统中的所用域名进行管理。

功能选项

1.新增

步骤一：基本参数

域名

本域的域名。如果要正常的与外域其他邮箱能正常收发邮件，一般是要经过域名机构的注册过的域名。
如果要加入中文域名，需要将域名在 http://www.cnnic.cn 进行转码，然后加入 punycode 码的域名，Webmail 可以正常显示，也能正常收发邮件。
描述 | 本域的相关描述。
域类型 域名类型：主域和普通域。
主域的用户在 Outlook 或 Foxmail 设置中 POP3 用户时只要邮箱地址的用户名，不需要域名；而非主域的用户在 Outlook 或 Foxmail 设置中POP3用户时要用写全地址。
如：设置邮件地址 test@domain.com，当为主域下邮箱时，POP3 用户名为 test；当为非主域下邮箱时，POP3用户名要写成 test@domain.com。
所有邮箱总容量 | 本域下所有邮箱最多能用的总容量。
最多支持邮箱数 | 本域最可用的邮箱数量。
所有网络磁盘总容量 | 本域下所有网络磁盘最多能用的总容量。
邮件密码加密方式 | 本域下所有新增用户的密码存储时的加密方式。
本域下，增加新用户自动增加到 everyone 组 | 此域名下的，新增用户时自动增加 everyone 组。
本域下的用户，增加个人信息到公用地址簿 | 当启用了公用地址簿功能，允许增加个人信息到公用地址簿。
用户可以决定个人信息是否到公用地址簿 | 允许用户选择是否将个人信息增加到公用地址簿。
公用地址簿只允许本域下的用户访问 | 本域下的公用地址簿信息只允许本域名下的用户来访问。

步骤二：高级属性

NT 域认证 | 与操作系统下的域进行整合。用户登陆邮箱或发邮件认证时，将使用NT域下的同名用户的密码进行认证。 支持 LDAP 格式，如 LDAP://192.168.120.102/dc=test,dc=local
域管理员邮箱 | 本域的管理员邮箱地址。
直接登录URL | 直接登录本域的URL, 用此URL登录WebMail时只显示本域名。
允许通过webmail注册邮箱 | 允许通过webmail注册新邮箱。
新注册的邮箱需管理员确认才生效 | 所有新注册的邮箱在正常使用前，必须经过管理员确认。
发送注册通知邮件给域管理员 | 当有用户注册新邮箱时，发送通知邮件给本域的管理员。
弹回错误信给发送者 | 若用户所发的信不在本域，则postmaster会发错误信给该用户。
递送至邮箱 | 若用户所发的信不在本域，则系统会把此信投递到该邮箱。
发送到Internet | 若用户所发的信不在本域，则系统会把此信外发到Internet。

步骤三：默认容量

邮箱容量 | 本域下新增邮箱的默认容量。
邮箱邮件数 | 本域下新增邮箱的默认邮件数。
邮箱容量警告 | 本域下新增邮箱的默认容量警告限制。
邮箱存储目录 | 本域下新增邮箱的默认存储目录。为空时，使用系统定义的邮箱存储目录。
网络磁盘容量 | 本域下新增邮箱的网络磁盘默认容量。
网络磁盘文件数 | 本域下新增邮箱的网络磁盘默认文件数。
网络磁盘存储目录 | 本域下新增邮箱的网络磁盘默认存储目录。为空时，使用系统定义的网络磁盘存储目录。

步骤四：默认权限

失效日期 | 本域下新增邮箱默认失效时间。设置禁止后，域管理员无权来对域下用户取消失效日期。
禁止 SMTP | 本域下新增邮箱默认禁止 SMTP。
禁止 POP3 | 本域下新增邮箱默认禁止 POP3。
禁止 IMAP | 本域下新增邮箱默认禁止 IMAP。
禁止 Webmail | 本域下新增邮箱默认禁止 Webmail。
禁止修改用户信息 | 本域下新增邮箱默认禁止网络磁盘。
禁止外部 POP3 邮箱 | 本域下新增邮箱默认禁止外部 POP3 邮箱。
禁止自动转发 | 本域下新增邮箱默认禁止自动转发。
禁止自动回复 | 本域下新增邮箱默认禁止自动回复。
禁止删除 | 本域下新增邮箱默认禁止用户删除邮件。
禁止公用地址簿 | 本域下新增邮箱默认禁止访问公用地址簿。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止查询归档邮件 | 本域下新增邮箱默认禁止通过 Web 来查询和取回本人接收和发送时系统归档的邮件。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止 PushMail(EAS) | 本域下新增邮箱默认禁止通过 PushMail(EAS) 来同步邮件，联系人以及行事历。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止网络磁盘 | 本域下新增邮箱默认禁止网络磁盘。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止网络行事历 | 本域下新增邮箱默认禁止网络行事历。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止网络记事本 | 本域下新增邮箱默认禁止网络记事本。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止短信通知 | 本域下新增邮箱默认禁止新邮件短信通知。
禁止发送短信 | 本域下新增邮箱默认禁止 Webmail 上发送短信。

步骤五：默认发送/接收

发送 | 本域下新增邮箱默认的“禁止发送邮件到本域下其他用户”，“禁止发送邮件到系统内的其他域”，“禁止发送邮件到系统外的域”设置。
收外 | 本域下新增邮箱默认的“禁止接收本域下其他用户发来的邮件”，“本系统内其他域发来的邮件”，“接收系统外的域发来的邮件”设置。

步骤六：默认流量控制

发送限制 | 本域下新增邮箱默认的发送的最大邮件字节数和每小时发送的收件人数。
本地递送 | 本域下新增邮箱默认发系统内邮件时，每天发送的收件人数限制和发送的邮件总字节数限制。
远程递送 | 本域下新增邮箱默认外发邮件时，每天发送的收件人数限制和发送的邮件总字节数限制。

步骤七：默认密码策略

安全 | 本域下新增邮箱默认设置下次登录必须修改密码，多少天必须修改密码以及禁止用户修改密码。
强度 | 本域下新增邮箱默认密码最小长度和密码字串的必须达到的强度。
客户端授权码 | 第三方客户端（如 Outlook、移动设备上的邮件 APP）专属的授权密码，用授权码代替邮箱密码登录客户端，用户可以在 Webmail 里设置多个授权码。

步骤八：默认邮件处理

归档邮件 | 本域下新增邮箱默认自动归档设置。
删除邮件 | 本域下新增邮箱默认自动删除设置。

步骤九：第三方认证

类型 | 选择第三方认证协议，支持 LDAP, Radius
主机名 | 设置第三方认证服务器的主机。如 LDAP://192.168.120.102/dc=test,dc=local
端口 | 设置第三方认证服务器的访问端口。
用户名 | 设置第三方认证服务器访问用户名。如：cn=mytest,cn=users,dc=mydomain,dc=com
密码 | 设置第三方认证服务器访问密码。Radius 服务器设置密钥
搜索起点 | LDAP 服务器设置搜索起点。如 dc=mydomain,dc=com
搜索过滤器 | LDAP 服务器设置搜索过滤器。如 Windows 活动目录：(&(objectCategory=person)(objectClass=user)(sAMAccountName=$uid))

步骤十：迁移

协议 | 选择邮件收取协议，支持 POP3, IMAP
主机地址 | 设置原邮件服务器的地址
端口 | 设置原邮件服务器相关协议的访问端口。
用户名格式 | 设置认证用户名的格式
保留备份 | 设置是否在原服务器上保留备份
邮件数 | 设置每次收取的邮件数

步骤十一：签名档

签名内容 本域下用户发送邮件时，邮件附带的签名内容。当要增加 HTML 签名内容时，直接输入 HTML 代码，选中“HTML 格式”

步骤十二：Webmail 定制

公司名称 | 设置域名对应公司的名称，这个名称会显示在网页的标题里，可以设置成：***公司邮件系统
网站地址 | 设置公司的网站的地址。Webmail 首页链接可以访问
ICP 备案号 | 设置ICP 备案号，可以在 Webmail 首页显示
Logo 图像 | 域名对应的的 logo 图像。可以上传 jpg/gif/png 图片，为了有更好的显示效果，建议图片的像素大小不要大于 180 * 60 px

步骤十三：DKIM 设置

选择器 | 设置 DKIM 的选择器
私钥 | 设置 DKIM 的私钥，有关 DKIM 密钥生成参考 DKIM Core

步骤十四：分布式

同步密码 | 设置主/从服务器之间同步帐号信息时的认证密码
作为主服务器 | 设置作为主服务器运行，同时增加允许的从服务器的地址。
作为从服务器 | 设置作为主服务器运行，同时设置主服务器的地址和端口。

说明：
1. 启用分布式域必须在“系统设置”/"高级设置"/“系统参数”中设置"本机主机名/IP 地址"。
2. 主服务器的管理端口必须对外开放，允许从服务器访问。
3. 主服务器损坏时，必须另选择一台服务器设置成主服务器，否则影响从服务器的正常运行。

步骤十五：用户同步

同步类型 支持从 AD, LDAP, 企业微信，钉钉同步用户

步骤十六：邮箱限制

最多签名数 | 本域下用户允许的最多的签名数。
最多联系人数 | 本域下用户允许的最多的联系人数。
最多POP3邮箱数 | 本域下用户允许的最多的外部POP3邮箱数。
POP3收取的最多邮件数 | 本域下用户每个外部POP3能收取的最多的邮件数。
POP3收取的最大邮件 | 本域下用户每个外部POP3能收取的最大的邮件。
最多的过滤规则 | 本域下用户允许的最多的邮件过滤规则。

2.编辑

对选定的域参数进行修改。各项内容与“新增”相同。

3.删除

删除选定的域。支持单条和多条记录的删除。注：主域不能被删除。

4.重算占用空间

重新计算域下已分配的空间情况。

5.刷新

从后台数据库重新读取数据，刷新界面。

注意事项

1. 主域的用户在 Outlook 或 Foxmail 设置中 POP3 用户时只要邮箱地址的用户名，不需要域名；而非主域的用户在 Outlook 或 Foxmail 设置中POP3用户时要用写全地址。
如：设置邮件地址 test@domain.com，当为主域下邮箱时，POP3 用户名为 test；当为非主域下邮箱时，POP3用户名要写成 test@domain.com。
2. 主域不能被删除。但可以被改名。普通域可以被删除，但不能改名。
3. 删除域名前的一定要删除此域名下所有用户邮箱，用户别名以及邮件组记录。
4. 如果对域名和DNS有疑问，请见：邮件/域名/DNS相关知识 邮件/动态域名专题。


域别名管理

对邮件系统中的域别名进行管理。

功能选项

1.新增

输入域别名，选择对应的域名。

2.删除

删除已选的域别名。支持单条和多条记录的删除。

3.刷新

从后台数据库重新读取数据，刷新界面。


用户和组

用户管理
组管理
用户别名管理
管理员管理
公用地址簿


用户管理

对系统中的邮箱用户进行管理。

功能选项

1.新增

步骤一：基本设置

用户名 | 用户登陆邮箱的帐号。用户名和密码不能为空
密码提示问题 | 取回帐号密码时的提示问题。
取回密码答案 | 取回帐号密码时的问题答案。
认证类型 支持以下三种认证方法：
“内部数据认证”，用系统内密码进行认证。
“NT 域认证”，连接域名参数中设置 NT 域名相关用户的密码进行认证。
“第三方认证”，连接域名参数中设置认证服务器进行认证。
帐号状态 “正常”：此用户为可用的正常邮箱。
“禁止”：此用户为无效，无法登录、接收和发送邮件，管理员将状态修改成“禁止”不会影响该邮箱里原有的邮件。
“待审核”：用户为 Webmail 申请新用户，等待管理员审核批准，管理员将状态修改成“正常”后就可以正常使用。
“暂停”：用户被临时冻结，无法登录邮箱，一般是登录密码多次错误导致的，10分钟后系统自动解冻，管理员也可以手工将状态改回“正常”。
“休眠”：用户休眠，无法登录邮箱，可以收到其他邮箱发过来的邮件。
失效日期 | 邮箱用户的失效时间。域名设置禁止后，域管理员无权来启用/禁止此功能。
密级 | 设置邮箱用户的密级，密级从低到高分为“无”、“限制”、“秘密”和“机密”。相对应的邮件也分“无”、“限制”、“秘密”和“机密”三个密级。 邮箱用户不可以发送和阅读高于自己密级的邮件。

步骤二：个人信息

注意：若开启公用地址簿功能，选择了“增加个人信息到公用地址簿”，则可以增加这些信息到公用地址簿中。

步骤三：组设置

步骤四：容量设置

邮箱容量 | 分配给用户邮箱的最大容量；值为0，则不限邮箱容量
最多的邮件数 | 此邮箱能容纳的最多邮件数；值为0，则不限邮件数目
容量警告限制 当用户邮箱容量使用率的达到所设的值，系统会给此用户发警告信；
值为0，则不予警告
邮件存储目录 | 此用户的邮箱存储目录路径。为空时，使用域属性中定义邮箱存储目录。
网络磁盘容量 | 分配给用户邮箱网络磁盘默认的最大容量。
最多的文件数 | 此邮箱网络磁盘默认的最多文件数。
网络磁盘存储目录 | 此用户的网络磁盘的存储目录路径。为空时，使用域属性中定义网络磁盘存储目录。

步骤五：权限设置

禁止 SMTP | 禁止用户使用 SMTP 服务。
禁止 POP3 | 禁止用户使用 POP3 服务。
禁止 IMAP | 禁止用户使用 IMAP 服务。
禁止 Webmail | 禁止用户使用 Webmail 服务。
禁止修改用户信息 | 禁止用户修改用户信息。
禁止外部 POP3 邮箱 | 禁止用户使用 POP3 邮箱。
禁止自动转发 | 禁止用户设置自动转发。
禁止自动回复 | 禁止用户设置自动回复。
禁止删除邮件 | 禁止用户删除本邮箱的邮件，包括客户端和 Webmail。
禁止公用地址簿 | 禁止用户访问公用地址簿。域名设置禁止后，域管理员无权来启用/禁止此功能。
禁止查询归档邮件 | 禁止用户通过 Web 来查询和取回本人接收和发送时系统归档的邮件。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止 PushMail(EAS) | 禁止用户通过 PushMail(EAS) 来同步邮件，联系人以及行事历。设置禁止后，域管理员无权来对域下用户启用/禁止此功能。
禁止网络磁盘 | 禁止用户使用网络磁盘。域名设置禁止后，域管理员无权来启用/禁止此功能。
禁止网络行事历 | 禁止用户使用网络行事历。域名设置禁止后，域管理员无权来启用/禁止此功能。
禁止网络记事本 | 禁止用户使用网络记事本。域名设置禁止后，域管理员无权来启用/禁止此功能。
禁止短信通知 | 禁止用户设置邮件短信通知。
禁止发送短信 | 禁止用户使用 Webmail 发送短信。

步骤六：发送/接收

发送 | 可以设置“禁止发送邮件到本域下其他用户”，“禁止发送邮件到系统内的其他域”，“禁止发送邮件到系统外的域”。
接收 | 可以设置“禁止接收本域下其他用户发来的邮件”，“禁止接收本系统内其他域发来的邮件”，“禁止接收系统外的域发来的邮件”。

步骤七：流量控制

发送限制 | 设置用户发送的最大邮件字节数和每小时发送的收件人数。
本地递送 | 设置用户发系统内邮件时，每天发送的收件人数限制和发送的邮件总字节数限制。
远程递送 | 设置用户外发邮件时，每天发送的收件人数限制和发送的邮件总字节数限制。

步骤八：密码策略

安全 | 设置用户下次登录必须修改密码，多少天必须修改密码以及禁止用户修改密码。
客户端授权码 | 第三方客户端（如 Outlook、移动设备上的邮件 APP）专属的授权密码，用授权码代替邮箱密码登录客户端，用户可以在 Webmail 里设置多个授权码；建议为每个客户端加不同的授权码； 用户启用使用授权码后，客户端里必须使用，不能再使用邮箱密码，Webmail 还是使用原邮箱密码登录。

步骤九：访问控制

设置指定用户访问 SMTP/Secure SMTP, POP3/Secure POP3, IMAP/Secure IMAP, Webmail/Secure Webmail, FTP/Secure FTP 各服务的允许和禁止的 IP 地址。

步骤十：邮箱设置

自动转发 设置了自动转发邮箱，则发往此用户的信件自动转发到此邮箱。
如果设置了保留备份，邮件自动转发后会继续递送此邮件给本邮箱。
启用自动回复 | 启用自动回复后，收到新邮件后将会自动回复发件人。
启用新邮件短信通知 | 启用新邮件短信通知后，收到新邮件会发手机短信给用户个人信息中设置的手机号码。前提条件是系统必须在“系统设置”-》“短消息通知”中，正确设置发送手机短信的参数。
垃圾邮件处理 收到的邮件如被判定为垃圾邮件，可以进行以下 2 种动作：
1.递送到垃圾邮件夹;
2.邮件主题增加[SPAM]标识，继续递送到[收件箱]。

步骤十：邮件处理

自动归档 | 设置用户邮件多少天前的，自动按年归档
自动删除 | 设置用户邮件的各个邮件夹邮件多少天前的自动删除。

2.编辑

对选定的用户做参数修改。画面同“新增”。

1)邮箱状态

在“个人信息”中，显示此用户自定的外部POP3邮箱信息及已用空间信息。

“重算邮箱空间”可以对用户的已用空间进行重新计算。
“清空用户邮箱”可以直接清除用户邮箱中的所有邮件。
“清空网络磁盘”可以直接清除用户邮箱的网络磁盘中的所有文件。

2)发送记录

显示邮箱用户最近的发送邮件记录，并统计当天的发送到本地/外部的收件人数和邮件字节数

3)接收记录

显示邮箱用户最近的接收邮件记录，并统计当天的接收到本地/外部的收件人数和邮件字节数

4)访问记录

显示邮箱用户的 POP3，IMAP，Webmail 访问的记录。

5)邮件删除记录

显示邮箱用户邮件删除的记录。

3.删除

删除选定的用户。支持单条和多条记录的删除。
注意：删除用户时，邮箱目录中的所有邮件和网络磁盘中的所有文件也会被删除。不能恢复
Winmail 6.0 增加邮箱目录邮件保留 15 天的功能。以防管理员误删除，过期会自动清除。

4.导入

1) 从文件导入

选择一下导入文件，并根据选择导入文件格式选择注释符号与分隔符号。

选择导入文件中的字段与用户信息字段的映射关系。

进行导入，如果导入文件很大时，可能需要等待。最后显示导入结果。

2) 从系统导入

设置要导入用户的服务器，列出服务器上的所有帐号，选择要导入的用户，导入到指定的域下。
如果导入用户比较多时，可能需要等待。最后显示导入结果。

5.导出

选择导出文件，然后选择要导出的字段，进行导出。

6.批量更新

选定需要批量更新的用户，选择需要批量更新的记录，然后更新批量更新。

7.迁移

域开启了分布式功能后，主服务器可以将用户从一台机器迁移到另一台机器。

说明：
1. 只迁移邮件帐号到新邮件主机，不迁移用户邮件。可以拷贝用户的邮件存储目录到新的邮件主机。
2. 请确保新邮件主机有足够的授权用户数，否则会影响新邮件主机的正常运行。

8.刷新

从后台数据库重新读取数据，刷新界面。

注意事项

1. 主域的用户在 Outlook 或 Foxmail 设置中 POP3 用户时只要邮箱地址的用户名，不需要域名；而非主域的用户在 Outlook 或 Foxmail 设置中POP3用户时要用写全地址。
如：设置邮件地址 test@domain.com，当为主域下邮箱时，POP3 用户名为 test；当为非主域下邮箱时，POP3用户名要写成 test@domain.com。


组管理

对系统中的邮件组进行管理。邮件组也是一个邮件地址，给组地址发邮件，组下的所有成员都将会收到该邮件。支持多层级邮件组。

功能选项

1.新增

步骤一：基本设置

步骤二：组成员

步骤三：发信权限

步骤四：允许发信组员

步骤五：组管理员

指定的组管理员可以通过 Webmail 来对组成员和发信权限进行管理。

步骤六：发信代表

指定的组发信代表，可以用组地址发信给其他人。

2.编辑

对选定的组作参数修改。画面同“新增”。

3.删除

删除选定的用户。支持单条和多条记录的删除。

4.导入

导入所有组的成员列表和组的所有信息。

5.导出

导出所有组的成员列表和组的所有信息。

4.刷新

从后台数据库重新读取数据，刷新界面。


用户别名管理

对系统中的用户别名进行管理。

功能选项

1.新增

步骤一： 输入用户别名

步骤二：选择真实邮箱地址

2.编辑

对选定的用户别名作参数修改。画面同“新增”。

3.删除

删除选定的用户。支持单条和多条记录的删除。

4.刷新

从后台数据库重新读取数据，刷新界面。


管理员管理

对邮件系统的管理员进行增加，删除和编辑操作。邮件系统有：超级管理员、域管理员、角色管理员。超级管理员可以管理全部系统设置；域管理员只可以管理得到授权的域下的部份属性，以及域下邮箱用户，邮箱别名以及组； 角色管理员可以管理一项或者多项指定功能。

功能选项

1.新增

用户名 | 管理员的登录名
密码 | 管理员的登录密码
描述 | 管理员的相关描述
管理员类型 | 三种类型：超级管理员、域管理员、角色管理员

2.编辑

对选定的管理员参数进行修改。各项内容与“新增”相同。

3.删除

删除选定的管理员。

4.刷新

从后台数据库重新读取数据，刷新界面。


公用地址簿

在LDAP中所有用户的信息，包括邮件系统的帐号和外部地址；利用此功能可以加入 其它联系人信息以供用户查找。
Outlook, Webmail 等可查找, 请参考公用地址簿客户端。

公用联系人的类型共有两种：
1.是邮件系统的用户，在用户管理中被设置加入了公用地址簿(系统帐号)；
2.在此新建的其它联系人的帐号(非系统帐号)

功能选项

1.新增

步骤一：联系人基本信息

填写帐号名称和E-MAIL地址，最上面的E-MAIL地址被优先查找

步骤二：联系人的业务信息

步骤三：联系人的家庭信息

2.编辑

对选定的联系人信息作参数修改；画面同“新增”。 系统帐号的信息此处不可修改，修改系统帐号的信息请到用户管理部分

3.删除

从 LDAP 公用地址簿删除联系人，不影响系统帐号原有的信息

4.导入

步骤一：选择导入文件，设置导入选项

步骤二：显示从导入文件中提取的联系人信息

步骤三：显示导入成功的联系人

5.导出

选择需要导入的字段

6.刷新

从后台数据库重新读取数据，刷新界面。


系统状态

邮件队列
短消息队列
系统状态统计表
系统流量统计图
用户流量统计表
活动连接


邮件队列

邮件标识 | 邮件在队列中的ID。
创建时间 | 邮件进行入队列的时间。
最近重发时间 | 邮件最近一次的发送时间。
邮件大小 | 邮件的字节数。
发件人 | 邮件的发送者地址。
接收人 | 邮件的接收者地址，多个接收人之间用分号分隔。
状态 | 标识邮件的在队列中的递送状态。 队列递送状态：正在递送；等待递送；等待重试递送；等待签核
认证用户 | 该邮件的认证用户，可能和发件人不一样。
客户端IP | 该邮件的来源IP。

功能选项

删除: 删除选中的邮件。支持单条和多条。

清空: 删除邮件队列中的所有的邮件。

查看: 查看邮件队列中的所选邮件。

刷新: 从后台数据库重新读取数据，刷新界面。

注意事项

当您邮件系统队列中总是有很多的邮件，可能是有的邮箱密码被猜解，邮件系统被作为垃圾邮件转发服务器了。 请修改一下对应"认证用户"的密码。
如果要清除队列里全部代发邮件， 可以停止邮件系统，删除邮件系统所在目录中的 server\queue 目录下的所有子目录和文件，系统会自动重新所有子目录，然后重新启动邮件系统。


短消息队列

队列标识 | 短消息在队列中的ID。
创建时间 | 短消息进行入队列的时间。
最近重发时间 | 短消息最近一次的发送时间。
发件者 | 短消息的发送者地址。
接收者 | 短消息的接收者地址，多个接收人之间用分号分隔。
状态 | 标识短消息的在队列中的递送状态。 队列中递送状态：正在递送；等待递送

功能选项

删除: 删除选中的短消息。支持单条和多条。

清空: 删除短消息队列中的所有的短消息。

刷新: 从后台数据库重新读取数据，刷新界面。


系统状态统计表

1. SMTP/Secure SMTP状态统计

显示了 SMTP/Secure SMTP 服务器当日的连接次数、连接失败次数、认证错误次数、递送的字节数、被过滤的邮件总数(邮件来源过滤)等统计情况。

2. POP3/Secure POP3状态统计

显示了 POP3/Secure POP3 服务器当日的连接次数、连接失败次数、认证失败次数、客户取得的总字节数等统计情况。

3. IMAP/Secure IMAP状态统计

显示了 IMAP/Secure IMAP 服务器当日的连接次数、连接失败次数、认证失败次数、上传的邮件数与下载的邮件数等统计情况。

4. FTP/Secure FTP状态统计

显示了 FTP/Secure FTP 服务器当日的连接次数、连接失败次数、认证失败次数、上传文件数与下载的文件数等统计情况。

5. ADMIN状态统计

列出了ADMIN服务器当日的连接次数、连接失败次数、登陆错误次数等统计情况。

6. 邮件队列状态统计

统计了当日内的队列处理过程中循环递送的邮件总数、延时再递送邮件总数、弹回的邮件总数、被过滤的邮件总数(符合用户自定义的过滤规则的邮件数)。

7. 邮件递送状态统计

统计了当日内的邮件递送过程中递送次数、递送邮件字节数、递送失败次数、本地递送次数、本地递送邮件字节数、本地递送失败次数、远程递送次数、远程递送邮件字节数、远程递送失败次数及被过滤的邮件总数。


系统流量统计图

显示一天各时段的各邮件相关网络服务（SMTP, POP3, IMAP等）的访问流量图，也可以按照日期显示30天的流量图。


用户流量统计表

[白金版功能] 显示各邮箱用户每天的发送邮件个数和字节数等数据，可以按照某个字段排序，让管理员可以分析系统运行情况，及时发现异常邮箱。
双击一个用户，可以显示该用户的详细访问记录、发送记录、接受记录。


活动连接

显示当前系统各邮件服务连接情况，只显示目前打开中的连接，正常的邮件服务连接时间都很短暂，通常不会有很多打开中的连接。


系统日志

管理员可以在系统日志中查看有关的系统的运行情况记录。系统记录了有关 SYSTEM(系统日志)、SMTP/Secure SMTP、POP3/Secure POP3、IMAP/Secure IMAP、QUEUE(邮件队列)、Webmail/Secure Webmail、FTP/Secure FTP(网络磁盘) 和 ADMIN 等运行情况，以便管理员能及时的了解系统的运行情况。

在上述的SMTP日志记录中，每条记录都遵循一定的记录格式：日期-时间 线程ID 日志信息

管理员也可以通过点击清空某一个日志文件或删除某一个日志文件，也可刷新日志。

可以在"系统设置"-"高级设置"-"系统参数"-"基本参数"里设置日志语言为简体中文 Chinese(Simplified)。


更改密码

修改当前管理员的登录密码


授权信息

授权给 | 本系统授权给谁来使用。
最多可用邮箱数 | 显示当前系统授权中允许使用的最多邮箱用户数。
已分配邮箱数 | 显示当前系统中已经增加的邮箱总数。
已有域名数 | 显示当前系统中已经增加的域名数。
授权日期/安装日期 | 显示当前系统授权授权日期。如果没有得到授权，则显示系统的安装日期。
还能使用天数 | 显示当前系统授权还能使用的时间。
技术服务与版本升级截止日期 | 本系统所享受的技术服务与版本升级的终止日期。

注册

客户可通过点击“注册”按钮，系统会弹出注册窗口用来输入用户和注册码。

如果正确，系统授权信息会显示为您实际注册最多可用信箱数。
如果系统提示出错“Invalid License”，则表示注册码不正确，请重新输入。
如果重试多次还是不成功，请和 register@winmail.cn 联系。

注意

1. 不要包含空格和换行，您可以采用从Email粘贴拷贝的方式输入。
2. 如果确认注册码正确，还是提示“Invalid License”，则要检查系统中已有用户数超过授权许可。


公用地址簿客户端

启用公用地址簿

如果管理员在域名设置时，选中“本域下的用户，增加个人信息到公用地址簿”，则在增加用户时，用户信息将会自动增加到公用地址簿中。

设置与使用

用户可以在Webmail中查看到公用地址簿中的用户信息。也可以通过邮件客户端软件来查看。前者在比较简单，在此不作详述。在此主要以Outlook Express来说明后者的设置与使用。

启用邮件客户端软件：“开始”->“程序”->“附件”->“通讯簿”。

增加公用地址簿主机：菜单上“工具”->“帐户...”

点击“添加...”，并输入您的公用地址簿LDAP的主机。

选中新加帐户属性，点击“属性”，设置主机属性。

当LDAP服务不允许匿名访问时，服务要选中此服务器要求登录。有关是否允许匿名访问，请见“高级设置”/“系统参数”

登录用户与用户邮箱登录用户名相同。主域下用户为：邮箱名；普通域下用户为：邮箱名@域名。
口令与用户邮箱登录口令相同。

在搜索范围中选择，公用地址簿主机。然后输入搜索关键字进行搜索。

如果 ldap 查询客户端需要输入 Base DN, 请输入 o=magicwinmail


 COM 组件功能

为了方便邮件系统与其他系统进行整合，邮件系统提供一个COM组件接口，可以用来增删用户、域以及管理员。COM组件接口程序存放在 ~\server\MailServerCtrl.dll，控件的名字为：MailServerCtrl.MailDBInterface， eg: newObject.CreateObject("MailServerCtrl.MailDBInterface")

方法说明

void InitControl(BSTR strProgPath)
说明：初始化控制
参数：strProgPath邮件系统数据库文件所在目录，如果为空串("")时，取回 Winmail 安装时记录在注册表中的路径。
返回：无。

BSTR GetDBPath()
说明：取得数据库文件所在目录。
参数：无。
返回：返回数据库文件所在目录。

short AddDomain(BSTR strDomain)
说明：增加一个域名
参数：
strDomain - 域名。
返回：
0 - 增加域名成功；
1 - 参数不正确或参数格式无效；
2 - 增加域名失败。

short ModifyDomain(BSTR strDomain, BSTR strNTDomain, BSTR strHost, BSTR strIP, BSTR strAdmin, short uRegister, short uConfirm)
说明：更改域的属性
参数：
strDomain - 域名。
strNTDomain - NT 认证域的域名；
strHost - 直接登录此域的主机名；
strIP - 直接登录此域的 IP 地址；
strAdmin - 此域的管理员邮箱；
uRegister - 是否允许 Webmail 注册新用户，1 - 允许，0 - 禁止；
uConfirm - Webmail 注册新用户后，是否需要管理员审核后生效，1 - 需要审核后生效，0 - 不需要审核直接生效。
返回：
0 - 更改域的属性成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域的属性失败。

short ModifyDomainStorage(BSTR strDomain, long lMailboxStorage, int iMailboxTotal, long lNetStoreStorage, long lMinMailboxQuota)
说明：更改域的容量限制
参数：
strDomain - 域名。
lMailboxStorage - 所有邮箱总容量， O 表示不限制，单位：千字节(KB)；
iMailboxTotal - 最多支持邮箱数， O 表示不限制；
lNetStoreStorage - 所有网络磁盘总容量， O 表示不限制，单位：千字节(KB)；
lMinMailboxQuota - 单个邮箱最小容量， 当值为 O 时，而 lMailboxStorage 值不为 0 时，自动设置为 3 M。
返回：
0 - 更改域的容量成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域的容量失败。

short ModifyDomainRight(BSTR strDomain, long lExpireTime, short uPop3Control, short uImapControl, short uWebmailControl, short uNetStoreControl, short uCalendarControl, short uNotebookControl, short uExternalPop3)
说明：更改域下邮箱的默认权限
参数：
strDomain - 域名。
lExpireTime - 邮箱过期时间， O 表示没有时间限制，时间值为 UNIX 时间戳；
uPop3Control- 禁止 POP3 服务， O 表示允许，1 表示禁止；
uImapControl - 禁止 IMAP 服务，O 表示允许，1 表示禁止；
uWebmailControl - 禁止 Webmail 服务， O 表示允许，1 表示禁止；
uNetStoreControl - 禁止网络磁盘， O 表示允许，1 表示禁止；
uCalendarControl - 禁止网络行事历， O 表示允许，1 表示禁止；
uNotebookControl - 禁止网络记事本， O 表示允许，1 表示禁止；
uExternalPop3 - 禁止外部 POP3 邮箱， O 表示允许，1 表示禁止。
返回：
0 - 更改域下邮箱的默认权限成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的默认权限失败。

short ModifyDomainRight1(BSTR strDomain, short uModifyUserInfo, short uExternalPop3, short uAutoForward, short uAutoReply, short uSpamControl, short uPublicContact)
说明：更改域下邮箱的默认权限
参数：
strDomain - 域名。
uModifyUserInfo - 禁止用户修改个人信息， O 表示允许，1 表示禁止；
uExternalPop3 - 禁止外部 POP3 邮箱， O 表示允许，1 表示禁止；
uAutoForward - 禁止设置自动转发， O 表示允许，1 表示禁止；
uAutoReply - 禁止设置自动回复， O 表示允许，1 表示禁止；
uPublicContact - 禁止公用地址簿， O 表示允许，1 表示禁止。
返回：
0 - 更改域下邮箱的默认权限成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的默认权限失败。

short ModifyDomainRight2(BSTR strDomain, short uSmsNotify, short uSendSms)
说明：更改域下邮箱的默认权限
参数：
strDomain - 域名。
uSmsNotify - 禁止新邮件短信通知 POP3， O 表示允许，1 表示禁止；
uSendSms - 禁止发送短信，O 表示允许，1 表示禁止。
返回：
0 - 更改域下邮箱的默认权限成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的默认权限失败。

short ModifyDomainSendRecv(BSTR pstrDomain, short uSendControl, short uRecvControl, BSTR pstrSendDomainList, BSTR pstrRecvDomainList)
说明：更改域下邮箱的默认收发权限
参数：
strDomain - 域名。
uSendControl - 发送限制， 1 - 禁止发送邮件到本域下其他用户， 2 - 禁止发送邮件到系统内的其他域， 4 - 禁止发送邮件到系统外的域；
uRecvControl - 接收限制， 1 - 禁止接收本域下其他用户发来的邮件， 2 - 禁止接收本系统内其他域发来的邮件， 4 - 禁止接收系统外的域发来的邮件；
pstrSendDomainList - 发送例外的域名列表，与上述发送限制执行相反的操作，填写多个域名时，各域名间用分号(;)隔开；
pstrRecvDomainList - 接收例外的域名列表，与上述接收限制执行相反的操作，填写多个域名时，各域名间用分号(;)隔开。
返回：
0 - 更改域下邮箱的默认收发权限成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的默认收发权限失败。

short ModifyDomainFlow(BSTR pstrDomain, long lSendMaxMsgSize, short uSendFreq, short uLocalTimes, long lLocalSize, short uRemoteTimes, long lRemoteSize)
说明：更改域下邮箱的默认流量控制
参数：
strDomain - 域名。
lSendMaxMsgSize - 允许的发送接收的单邮件最大字节数， O 表示使用“SMTP 设置”中的参数值，单位：字节(B)；
uSendFreq - 每小时发送的收件人数， O 表示不限制；
uLocalTimes - 发内部邮件时，每天发送的收件人数限制， O 表示不限制；
lLocalSize - 发内部邮件时，发送的邮件总字节数限制， O 表示不限制，单位是 KB；
uRemoteTimes - 发外部邮件时，每天发送的收件人数限制， O 表示不限制；
lRemoteSize - 发外部邮件时，发送的邮件总字节数限制， O 表示不限制，单位是 KB。
返回：
0 - 更改域下邮箱的默认流量控制成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的默认流量控制失败。

short ModifyDomainPwdPolicy(BSTR pstrDomain, short uChgPwd, short uExpiryDays, short uPwdLength, short uPwdStrength)
说明：更改域下邮箱的默认密码策略
参数：
strDomain - 域名。
uChgPwd - 设置密码安全性， 1 - 用户不能修改密码， 2 - 用户每隔 N 天必须修改密码，4 - 用户下次时登录必须修改密码；
uExpiryDays - 用户修改密码间隔的天数， 默认 30 天；
uPwdLength - 密码最少长度， O 表示不限制；
uPwdStrength - 密码的安全等级， 0 - 低， 1 - 中， 2 - 高。
返回：
0 - 更改域下邮箱的默认密码成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的默认密码失败。

short ModifyDomainLimit(BSTR strDomain, short uSignatureNum, short uAddressNum, short uMailFilterNum, short uExternalMailNum, long lMaxPop3MailSize, short uMaxPop3MailTotal)
说明：更改域下邮箱的配置
参数：
strDomain - 域名。
uSignatureNum - 允许的最多签名数量， O 表示不限制；
uAddressNum - 允许的最多联系人数量， O 表示不限制；
uMailFilterNum - 允许的最多过滤规则数量， O 表示不限制；
uExternalMailNum - 允许的最多外部 POP3 邮箱数量， O 表示不限制；
lMaxPop3MailSize - 外部 POP3 邮箱最大的邮件字节数， O 表示不限制，单位：字节(B)；
uMaxPop3MailTotal - 外部 POP3 邮箱最多的邮件数， O 表示不限制；
返回：
0 - 更改域下邮箱的配置成功；
1 - 参数不正确或参数格式无效；
2 - 域不存在或或读取域信息失败；
3 - 更改域下邮箱的配置失败。

short DeleteDomain(BSTR strDomain)
说明：删除一个域名
参数：
strDomain - 域名。
返回：
0 - 删除域名成功；
1 - 参数不正确或参数格式无效；
2 - 域名下存在用户，组或别名；
3 - 删除域名失败。

short AddDomainAlias(BSTR strAliasDomain, BSTR strRealDomain)
说明：增加一个域别名
参数：
strAliasDomain - 域的别名；
strRealDomain - 域名别名对应的实际域名。
返回：
0 - 增加域别名成功；
1 - 参数不正确或参数格式无效；
2 - 增加域别名失败。

short DeleteDomainAlias(BSTR strAliasDomain)
说明：删除一个域别名
参数：
strAliasDomain - 域的别名。
返回：
0 - 删除域别名成功；
1 - 参数不正确或参数格式无效；
2 - 删除域别名失败。

short AddUser(BSTR strUser, BSTR strDomain, BSTR strPassword)
说明：增加一个邮箱用户
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
strPassword - 邮箱的密码。
返回：
0 - 增加新邮箱成功；
1 - 参数不正确或参数格式无效；
2 - 已经存在同名的邮箱；
3 - 已经存在同名的用户别名；
4 - 已经存在同名的组名；
5 - 此域下，用户的邮箱数已经达到域的限制；
6 - 此域下，用户的邮箱空间或网络磁盘空间已经达到域的限制；
7 - 所要增加的域不存在。
8 - 密码太简单或不符合域名的密码策略，要用数字，字母和符号组合，要避免与用户名相同或包含用户名。

short ModifyUser(BSTR strUser, BSTR strDomain, BSTR strFullName, BSTR strDescription, BSTR strCompany, BSTR strOffice)
说明：更改用户信息
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
strFullName - 用户的全名；
strDescription - 用户的描述；
strCompany - 用户的公司/部门名称；
strOffice - 用户的办公室。
返回：
0 - 更改用户信息成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户信息失败。

short ModifyUser1(BSTR pstrUser, BSTR pstrDomain, BSTR pstrMobile, BSTR pstrHomePhone, BSTR pstrHomeAddress, BSTR pstrJobTitle, BSTR pstrOfficePhone)
说明：更改用户信息
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
pstrMobile - 用户的手机号码；
pstrHomePhone - 用户的住宅电话；
pstrHomeAddress - 用户的住宅地址；
pstrJobTitle - 用户的职务；
pstrOfficePhone - 用户的办公室电话。
返回：
0 - 更改用户信息成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户信息失败。

short ModifyUserStatus(BSTR strUser, BSTR strDomain, short uStatus)
说明：更改用户邮箱状态
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
uStatus - 邮箱状态， O 表示正常，1 表示禁止，2 表示等待审核。
返回：
0 - 更改用户邮箱状态成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱状态失败。

short ModifyUserQuota(BSTR strUser, BSTR strDomain, long lMailQuota, short iMailTotalLimit, short iWarningLimit, long lNetStoreQuota, int iNetStoreTotalLimit)
说明：更改用户邮箱容量
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
lMailQuota - 邮箱最大的容量， O 表示不限制，单位：字节(B)；
iMailTotalLimit - 邮箱最多的邮件数， O 表示不限制；
iWarningLimit - 邮箱的容量警告，O 表示不限制，单位：百分比；
lNetStoreQuota - 网络磁盘的最大容量， O 表示不限制，单位：字节(B)；
iNetStoreTotalLimit - 网络磁盘的最多文件数， O 表示不限制。
返回：
0 - 更改用户邮箱容量成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 邮箱用户所属域不存在或读取域信息失败；
4 - 此域下，用户的邮箱空间或网络磁盘空间已经达到域的限制；
5 - 更改用户邮箱容量失败。

short ModifyUserRight(BSTR strUser, BSTR strDomain, long lExpireTime, short uPop3Control, short uImapControl, short uWebmailControl, short uNetStoreControl, short uCalendarControl, short uNotebookControl, short uExternalPop3)
说明：更改邮箱用户的权限
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
lExpireTime - 邮箱过期时间， O 表示没有时间限制，时间值为 UNIX 时间戳；
uPop3Control- 禁止 POP3 服务， O 表示允许，1 表示禁止；
uImapControl - 禁止 IMAP 服务，O 表示允许，1 表示禁止；
uWebmailControl - 禁止 Webmail 服务， O 表示允许，1 表示禁止；
uNetStoreControl - 禁止网络磁盘， O 表示允许，1 表示禁止；
uCalendarControl - 禁止网络行事历， O 表示允许，1 表示禁止；
uNotebookControl - 禁止网络记事本， O 表示允许，1 表示禁止；
uExternalPop3 - 禁止外部 POP3 邮箱， O 表示允许，1 表示禁止。
返回：
0 - 更改用户邮箱权限成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 邮箱用户所属域不存在或读取域信息失败；
4 - 此域下，用户的网络磁盘空间已经达到域的限制；
5 - 更改用户邮箱权限失败。

short ModifyUserRight1(BSTR strUser, BSTR strDomain, short uModifyUserInfo, short uExternalPop3, short uAutoForward, short uAutoReply, short uSpamControl, short uPublicContact)
说明：更改邮箱用户的权限
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
uModifyUserInfo - 禁止用户修改个人信息， O 表示允许，1 表示禁止；
uExternalPop3 - 禁止外部 POP3 邮箱， O 表示允许，1 表示禁止；
uAutoForward - 禁止设置自动转发， O 表示允许，1 表示禁止；
uAutoReply - 禁止设置自动回复， O 表示允许，1 表示禁止；
uPublicContact - 禁止公用地址簿， O 表示允许，1 表示禁止。
返回：
0 - 更改用户邮箱权限成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱权限失败。

short ModifyUserRight2(BSTR strUser, BSTR strDomain, short uSmsNotify, short uSendSms)
说明：更改邮箱用户的权限
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
uSmsNotify - 禁止新邮件短信通知 POP3， O 表示允许，1 表示禁止；
uSendSms - 禁止发送短信，O 表示允许，1 表示禁止。
返回：
0 - 更改用户邮箱权限成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱权限失败。

short ModifyUserSendRecv(BSTR strUser, BSTR pstrDomain, short uSendControl, short uRecvControl, BSTR pstrSendDomainList, BSTR pstrRecvDomainList)
说明：更改用户邮箱的收发限制
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
uSendControl - 发送限制， 1 - 禁止发送邮件到本域下其他用户， 2 - 禁止发送邮件到系统内的其他域， 4 - 禁止发送邮件到系统外的域；
uRecvControl - 接收限制， 1 - 禁止接收本域下其他用户发来的邮件， 2 - 禁止接收本系统内其他域发来的邮件， 4 - 禁止接收系统外的域发来的邮件；
pstrSendDomainList - 发送例外的域名列表，与上述发送限制执行相反的操作，填写多个域名时，各域名间用分号(;)隔开；
pstrRecvDomainList - 接收例外的域名列表，与上述接收限制执行相反的操作，填写多个域名时，各域名间用分号(;)隔开。
返回：
0 - 更改用户邮箱的收发限制成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱的收发限制失败。

short ModifyUserFlow(BSTR strUser, BSTR strUser, BSTR pstrDomain, long lSendMaxMsgSize, short uSendFreq, short uLocalTimes, long lLocalSize, short uRemoteTimes, long lRemoteSize)
说明：更改用户邮箱的流量控制
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
lSendMaxMsgSize - 允许的发送接收的单邮件最大字节数， O 表示使用“SMTP 设置”中的参数值，单位：字节(B)；
uSendFreq - 每小时发送的收件人数， O 表示不限制；
uLocalTimes - 发内部邮件时，每天发送的收件人数限制， O 表示不限制；
lLocalSize - 发内部邮件时，发送的邮件总字节数限制， O 表示不限制，单位是 KB；
uRemoteTimes - 发外部邮件时，每天发送的收件人数限制， O 表示不限制；
lRemoteSize - 发外部邮件时，发送的邮件总字节数限制， O 表示不限制，单位是 KB。
返回：
0 - 更改用户邮箱的流量控制成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱的流量控制失败。

short ModifyUserPwdPolicy(BSTR strUser, BSTR pstrDomain, short uChgPwd, short uExpiryDays)
说明：更改用户邮箱的密码策略
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
uChgPwd - 设置密码安全性， 1 - 用户不能修改密码， 2 - 用户每隔 N 天必须修改密码，4 - 用户下次时登录必须修改密码；
uExpiryDays - 用户修改密码间隔的天数， 默认 30 天；
返回：
0 - 更改用户邮箱的密码成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱的密码失败。

short ModifyUserAccess(BSTR pstrUser, BSTR pstrDomain, short uSevice, short uControl, BSTR pstrIPList)
说明：更改用户邮箱访问控制
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
uSevice - 设置访问控制的服务， 0 - SMTP/Secure SMTP, 1 - POP3/Secure POP3, 2 - IMAP/Secure IMAP, 3 - Webmail/Secure Webmail, 4 - FTP/Secure FTP；
uControl - 设置访问控制动作， 0 - 不限制， 1 - 允许， 2 - 拒绝；
pstrIPList - 允许访问和拒绝访问的 IP 地址，填写多个 IP 地址时，各域 IP 间用分号(;)隔开。
返回：
0 - 更改用户邮箱的访问控制成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 更改用户邮箱的访问控制失败。

short DeleteUser(BSTR strUser, BSTR strDomain);
说明：删除一个邮箱用户
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域。
返回：
0 - 删除邮箱用户成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 删除邮箱用户失败。

short ChangePassword(BSTR strUser, BSTR strDomain, BSTR strOldPwd, BSTR strNewPwd)
说明：更改用户密码
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
strOldPwd - 邮箱的旧密码，旧密码为空串("")时，即不验证旧密码；
strNewPwd - 邮箱的新密码。
返回：
0 - 更改用户密码成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - 邮箱用户不是内部数据库认证；
4 - 旧密码不正确；
5 - 修改密码失败。

short CheckUser(BSTR strUser, BSTR strDomain)
说明：检查一个邮箱用户是否存在
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域。
返回：
0 - 不存在；
1 - 参数不正确或参数格式无效；
2 - 已经存在同名的邮箱；
3 - 已经存在同名的用户别名；
4 - 已经存在同名的组名；

short Authenticate(BSTR strUser, BSTR strDomain, BSTR strPass)
说明：检查用户密码
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
strPass - 邮箱的密码。
返回：
0 - 用户密码检查成功；
1 - 参数不正确或参数格式无效；
2 - 邮箱用户不存在或读取用户信息失败；
3 - NT 域名认证失败；
4 - 用户密码检查不成功。

short AddUserAlias(BSTR strAliasUser, BSTR strDomain, BSTR strRealMailbox)
说明：增加一个用户别名
参数：
strAliasUser - 用户的别名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
strRealMailbox - 邮箱名别名对应的实际邮箱。
返回：
0 - 增加用户别名成功；
1 - 参数不正确或参数格式无效；
2 - 增加用户别名失败。

short DeleteUserAlias(BSTR strAliasUser, BSTR strDomain)
说明：删除一个用户别名
参数：
strAliasUser - 用户的别名；
strDomain - 邮箱的域名；为空串("")时，即为主域。
返回：
0 - 删除用户别名成功；
1 - 参数不正确或参数格式无效；
2 - 删除用户别名失败。

short AddGroup(BSTR strName, BSTR strDomain, BSTR strDescription, BSTR strMemberList, short uRight, BSTR strSenderList)
说明：增加一个通信组
参数：
strName - 通信组名；
strDomain - 通信组的域名；为空串("")时，即为主域；
strDescription - 组描述。
strMemberList - 组成员列表，各个成员邮箱地址用分号(;)隔开。
uRight - 发信权限。
0 - 表示“任何人都可以给组员发信”；
1 - 表示“只有组员可以发信”；
2 - 表示“指定成员可以发信”。
strSenderList - 允许发信的成员列表，各个成员邮箱地址用分号(;)隔开。
返回：
0 - 增加新通信组成功；
1 - 参数不正确或参数格式无效；
2 - 已经存在同名的邮箱；
3 - 已经存在同名的用户别名；
4 - 已经存在同名的组名；
5 - 所要增加的域不存在。

short ModifyGroup(BSTR strName, BSTR strDomain, BSTR strDescription, BSTR strMemberList, short uRight, BSTR strSenderList)
说明：修改一个通信组
参数：
strName - 通信组名；
strDomain - 通信组的域名；为空串("")时，即为主域；
strDescription - 组描述；
strMemberList - 组成员列表，各个成员邮箱地址用分号(;)隔开；
uRight - 发信权限， 0 - 表示“任何人都可以给组员发信”，1 - 表示“只有组员可以发信”，2 - 表示“指定成员可以发信”， 3 - 表示“本域下用户可以发信”。
strSenderList - 允许发信的成员列表，各个成员邮箱地址用分号(;)隔开。
返回：
0 - 修改通信组成功；
1 - 参数不正确或参数格式无效；
2 - 邮件组不存在或读取邮件组信息失败；
3 - 修改通信组失败；

short ModifyGroup1(BSTR pstrName, BSTR pstrDomain, BSTR pstrSubGroup, BSTR pstrManager, short uVisual, short uSender)
说明：修改一个通信组
参数：
strName - 通信组名；
strDomain - 通信组的域名；为空串("")时，即为主域；
pstrSubGroup - 子分组，各个组地址用分号(;)隔开；
pstrManager - 组管理员员列表，各个管理员地址用分号(;)隔开；
uVisual - 组的可见权限，
0 - 表示“任何人可以看到此通讯组及其成员”，1 - 表示“任何人可以看到此通讯组”，
2 - 表示“本域用户可以看到此通讯组及其成员”， 3 - 表示“域用户可以看到此通讯组”，
4 - 表示“组成员可以看到此通讯组及其成员”， 5 - 表示“组成员可以看到此通讯组”，
6 - 表示“只有管理员可以看到此通讯组及成员”；
uSender - 发信成员的可见度，0 - 没有特别可见权限，1 - 发信成员有相同的可见度。
返回：
0 - 修改通信组成功；
1 - 参数不正确或参数格式无效；
2 - 邮件组不存在或读取邮件组信息失败；
3 - 修改通信组失败；

short DeleteGroup(BSTR strName, BSTR strDomain)
说明：删除一个通信组
参数：
strName - 通信组名；
strDomain - 通信组的域名；为空串("")时，即为主域；
返回：
0 - 删除通信组成功；
1 - 参数不正确或参数格式无效；
2 - 删除通信组失败。

short AddAdminUser(BSTR strUser, BSTR strPass, short uUserType, BSTR strAdminRange)
说明：增加一个系统管理员
参数：
strUser - 系统管理员用户名；
strPass - 管理员的密码；
uUserType - 管理员类型，0 - 超级管理员，1 - 域管理员；
strAdminRange - 允许管理的域，多个域名之间用逗号分隔（;），域管理员的允许管理的域不能为空。
返回：
0 - 增加管理员成功；
1 - 参数不正确或参数格式无效；
2 - 增加管理员不成功。

short DeleteAdminUser(BSTR strUser)
说明：删除一个系统管理员
参数：
strUser - 系统管理员用户名；
返回：
0 - 删除系统管理员成功；
1 - 参数不正确或参数格式无效；
2 - 删除系统管理员失败。

BSTR GetFolderMsgCount(BSTR strUser, BSTR strDomain, BSTR strPasswd, BSTR strFolder, short uOnlyNew)
说明：取得用户邮箱中指定邮件夹的新邮件数或邮件数
参数：
strUser - 用户的邮箱名；
strDomain - 邮箱的域名；为空串("")时，即为主域；
strPasswd - 邮箱的密码；
strFolder - 要取得邮件数的邮件夹，多个邮件夹用 | 隔开，如：取得收件箱与发件箱的邮件数，参数为 "inbox|sent"。
系统邮件夹的名称，inbox - 收件箱，sent - 已发送发件，draft - 草稿箱，trash - 已删除邮件，spam - 垃圾邮件，
如为空串("")时，则取回所有系统邮件夹（inbox|sent|draft|trash|spam）的新邮件数和邮件数；
uOnlyNew - 仅取新邮件数；0 -- 新邮件数和邮件数， 1 -- 新邮件数。
返回：
如果取得新邮件数和邮件数（uOnlyNew = 0），返回值为：新邮件数/邮件总数， 如 2/3
如果仅取得新邮件数（uOnlyNew = 1），返回值为：新邮件数， 如 2
如果取得邮件数的邮件夹为多个邮件夹，则取得新邮件数和邮件数（uOnlyNew = 0）时，返回值为：新邮件数1/邮件总数1|新邮件数2/邮件总数2， 如 2/3|5/8；仅取得新邮件数（uOnlyNew = 1）时，返回值为：新邮件数1|新邮件数2，如 2|5

操作实例


Webmail 与其他 Web 服务器整合

Winmail 内置了 Web 服务器，也可以整合到其他 Web 服务器里运行，如 IIS，Apache，Nginx、Lighttpd。本节主要讲述与 IIS 和Apache 整合，其他服务器可以参考相关方档，自行研究。

设置 Webmail 到 IIS
设置 Webmail 到 Apache


应用实例

请访问 http://www.winmail.cn/technic_case.php


 版本历史

Version 7.3(Build 0306)(2025/03/06)

1. 标准版支持64位安装包，64位运行程序效率更高.
2. 反垃圾邮件功能增加拒绝 SPF、PTR 不存在选项.
3. 猜密码和群发检测增加同主题邮件发送限制.
4. 邮箱用户状态增加休眠，休眠用户可以收到邮件，不能登录.
5. 邮箱用户属性可设置是否记录该用户的收发删除邮件等操作.
6. Secure SMTP 465 端口发信必须认证.
7. SMTP、POP3、IMAP 服务去掉 NTLM 标识，仅域名描述加 [NTLM] 时显示.
8. SMTP、POP3、IMAP 服务过滤 HTTP 命令.
9. 云附件功能增加支持客户端发大邮件时，生成网络磁盘下载链接.
10. 域名下系统签名档支持部分邮件客户端.
11. 邮件头增加 X-WM-AuthUser 选项，可关闭.
12. 邮件队列、活动连接可关闭自动刷新.
13. 增加密码过期邮件模板.
14. 更新自带 IP 地址库.
15. Pushmail 代码更新.
16. 优化 Internet 设置，移除陈旧拨号协议支持.
17. 删除 RWL、SMTP 延时响应功能.
18. Webmail 用户配置箱里可设置 POP3 收取后邮件标记为已读.
19. Webmail 增加“邮件附件”，集中显示所有邮件里的附件.
20. Webmail 写邮件收件人用标签化格式.
21. Webmail 写邮件 Excel 表格粘贴成图片，防止表格样式丢失.
22. Webmail 删除发送自写短信功能.
23. 修正分布式部署时组邮件重复收件问题.
24. 修正附件过滤失败问题.
25. 修正单副本时部分 IMAP 邮件信体丢失问题.
26. 修正 IMAP 公共邮件夹错误.
27. 升级 Apache 到 2.4.62.
28. 升级 PHP 到 8.2.27.
29. 升级 OpenSSL 到 3.0.15.
30. 升级 ClamAV 到 1.4.1.（Windows 2012 以上系统）

Version 7.2(Build 0524)(2024/05/24)

1. [企业版]增加其他邮件存储目录设置，优先存放在空闲空间占比最大磁盘.
2. [企业版]增加邮箱代理功能，邮箱用户可在 Webmail 配置箱发件人管理里设置.
3. Webmail 设置增加二次认证（2FA双因素认证）设置，支持 TOTP 动态口令验证.
4. 高级设置中增加 ADMIN 配置，管理端可配置 TOTP 动态口令验证、密码防猜解.
5. 猜密码检测增加主机名白名单，可结合动态域名设置访问白名单.
6. 猜密码检测去掉认证次数超限、外发超限屏蔽 IP，防止影响同网络其他用户收发.
7. 邮件过滤下内嵌图过滤支持识别二维码的内容.
8. Webmail 大量发信，将显示图形验证码，防止群发.
9. [企业版]管理端增加垃圾邮件过滤统计.
10. 系统状态下邮件队列和活动连接 15秒自动刷新.
11. 取回密码可增加企业微信、钉钉扫码.
12. 管理端用户属性里增加密码修改记录.
13. 用户管理可清除企业微信、钉钉ID、TOTP密钥.
14. 用户组可以设置发信代表，可以在 Webmail 直接以组名义发信.
15. 修正定时邮件没有发信记录问题.
16. 修正 MSMS 服务没有启动，短信队列不重试，永远堆积问题.
17. 修正 LDAP导入时，用户姓名不对问题.
18. 升级 Apache 到 2.4.58.
19. 升级 PHP 到 8.2.20.
20. 升级 OpenSSL 到 3.0.13.
21. 升级 ClamAV 到 1.3.0.
22. 修正数个 Webmail 安全漏洞.

Version 7.1(Build 0518)(2023/05/18)

1. [企业版/白金版]域名属性下增加用户和组同步，支持 ADSI、LDAP.
2. [企业版/白金版]域名属性下增加用户和组同步，支持企业微信，后台绑定新邮件通知.
3. [企业版/白金版]域名属性下增加用户和组同步，支持钉钉，后台绑定新邮件通知.
4. 增强密码策略设置功能，可设置多项细分策略规则，可设置弱口令字典.
5. Webmail 可配置双因素认证，支持短信验证码.
6. Webmail 双因素认证可配置支持企业微信扫码或发验证码.
7. Webmail 双因素认证可配置支持钉钉扫码或发验证码.
8. 用户属性密码策略中可设置是否开启双因素认证.
9. HTTP 设置中增加允许主机头，满足域名备案要求.
10. 外部数据库增加支持 ODBC 连接达梦数据库.
11. 猜密码检测中增加仅允许指定归属地的 IP 认证，可实现仅特定地区使用邮件功能.
12. 允许修改普通域的域名，主域、普通域都可以改名.
13. 调整用户邮件存储目录结构，按域名分目录存放，已有用户邮件会自动迁移。
14. 允许修改组名和用户别名.
15. 增加自定义 IP 归属地记录功能，自行增加内置 IP 归属地记录.
16. [企业版/白金版]支持导出用户访问记录、发送记录、接收记录.
17. 域名属性 Webmail 定制功能中增加 ICP 备案号设置.
18. 邮件迁移支持多线程下载邮件.
19. 修正一些安全和功能问题.
20. 升级 Apache 到 2.4.55.
21. 升级 OpenSSL 到 1.1.1t.
22. 升级 PHP 到 7.4.33.
23. 升级 Clamav 到 1.0.1.
24. 升级 Spamassassin 到 3.4.4.

Version 7.0(Build 0630)(2022/06/30)

1. [企业版/白金版] 增加内置 MySQL 数据库支持，提高系统性能.
2. [企业版/白金版] 增加支持外部 MySQL、MariaDB、PostgresSQL 数据库.
3. [企业版/白金版] 增加 LDAP 协议自动同步用户功能.
4. [企业版]支持分布式、内嵌查毒引擎、通讯组排序等原白金版特有功能.
5. 增加批量更新用户密码功能.
6. 域和用户属性里，增加密码不符合策略强制修改选项.
7. 增强邮件过滤规则设置，设置组合规则更方便.
8. 增加客户端登录授权码功能，让用户密码更安全.
9. 增强信息安全，可设置邮件头不记录客户端IP.
10. Webmail 增加时区设置，跨国使用更方便.
11. Webmail 个人信息中显示 APP 设备列表.
12. Webmail忘记密码可通过短信验证码重设密码，增加验证手机号码.
13. Webmail 邮件列表显示发件人联系信息.
14. 增强整合企业微信功能，可使用企业微信 APP 扫描登录 Webmail.
15. 增强整合钉钉功能，可使用钉钉 APP 扫描登录 Webmail.
16. 修正 IMAP 已发邮件，Webmail 删除失败问题.
17. 修正某些隔离邮件发件人显示不正确问题.
18. 修正无法在线更新垃圾邮件库问题.
19. 升级 Apache 到 2.4.53.
20. 升级 OpenSSL 到 1.1.1n.
21. 升级 PHP 到 7.4.29.
22. 支持 Windows Server 2022，Windows 11.

Version 6.7(Build 0112)(2021/01/12)

1. 内置 Apache 支持 http2 协议.
2. 增强检查伪造邮件功能.
3. 猜密码检测模块屏蔽列表增加屏蔽原因字段.
4. 猜密码检测模块可设置将屏蔽 IP 加入系统防火墙.
5. 猜密码检测模块可设置 IP 位置白名单.
6. 增加 SMTP 过滤次数达到限制自动屏蔽功能.
7. 取回密码安全性加强，增加安全问题答案长度检查.
8. 分布式认证增强防止猜密码.
9. Webmail 刷新邮件列表时，更新对应文件夹的邮件数.
10. 修正外发超过限制时，程序异常重启问题.
11. 修正打开乱码日志时长时间等待问题.
12. 修正 Outlook 部分邮件误判成撤回邮件问题.
13. 升级 Apache 到 2.4.46.
14. 升级 OpenSSL 到 1.1.1i.
15. 升级 PHP 到 7.2.34.

Version 6.6(Build 0812)(2020/08/12)

1. 增加角色管理员，可授权使用指定功能.
2. 改善SSL/TLS 兼容性和安全性.
3. [白金版]邮件密级改为限制、秘密、机密，更符合国标.
4. 域名管理列表增加域下用户已用空间统计.
5. 修正特定计划任务导致用户信息丢失问题.
6. 修正公共地址簿导入错误问题.
7. 修正Web注册新邮箱密码规则检查异常问题.

Version 6.6(Build 0706)(2020/07/06)

1. [白金版]支持 IPv6，可设置优先使用 IPv6.
2. [白金版]增强分布式部署功能，可实现负载均衡架构.
3. SMTP、POP3、IMAP 等各服务可以绑定多个本机IP和多个端口.
4. 优化 SMTP、POP3、IMAP 等服务程序代码，提高系统性能.
5. 增加系统级新邮件消息推送，可指定 URL，推送数据格式支持 JSON、XML、Form.
6. 增强在线迁移功能，让迁移更平滑无感.
7. 通讯组发信成员可指定某个外域、某个通讯组及子组.
8. 邮件监控、邮件签核、外发中继、计划任务、归档等支持选择组作为动作对象.
9. 可禁止 25 端口发信认证，防密码猜解更安全.
10. OpenSSL 升级到 1.1.1d, 支持更安全的 TLSv1.3 版本协议(Windows 2008 以上系统).
11. 证书管理中可以设置禁止特定的 SSL/TLS 版本，让系统更安全.
12. 改进密码策略设置，强度规则更清晰明白.
13. 导出用户账号数据增加状态、创建时间、最近访问时间字段.
14. 用户属性里可显示最近修改密码时间.
15. 增加邮箱密码加密格式，支持更安全的 SHA256 和国密SM3算法.
16. 增加垃圾邮件内嵌图片里文字识别过滤识别功能.
17. 增加垃圾邮件规则库在线更新功能.
18. 增加日志记录等级.
19. 增强日历功能.
20. 增加 Webmail 登录、取回密码和修改密码要求短信验证功能.
21. Webmail 忘记密码功能可直接设置新的密码.
22. 增加发送内部邮件的阅读情况统计功能.
23. Webmail 行事历增加搜索功能.
24. 增强 Webmail 写邮件编辑器，支持表格编辑、邮件模板.
25. Webmail 登录后，如果密码强度不符合域名默认密码策略会出现提醒信息.
26. 修正繁体系统中 IP 来源地文字显示乱码问题.
27. 修正 Windows 2012 以上查看日志初始不滚动到最新记录行问题.
28. 修正 Windows 10 以上系统信息中操作系统版本显示不正确问题.
29. 修正隔离区取回，邮件监控规则不生效问题.
30. 修正间隔时间设置 24 小时时，隔离区不发通知邮件问题.
31. 升级 Apache 到 2.4.43.
32. 升级 PHP 到 7.2.31.
33. 升级 ClamAV 到 0.102.3.
34. 升级 SpamAssassin 到 3.4.2.

Version 6.5(Build 0305)(2019/03/05)

1. 全新设计 Webmail Simple 界面风格.
2. 邮件存储可设置单副本保存，提高磁盘利用率和内部投递效率.
3. Webmail 支持使用 Winmail APP 扫码登录.
4. 可以设置 Webmail 发送大附件时自动使用网络磁盘中转.
5. 改进归档存储，防止目录下文件过多，改进 Web 归档管理.
6. 移动界面增加邮件搜索功能，改进地址簿搜索.
7. 修正网络磁盘 Web 上传文件时容量无法限制问题.
8. 修正邮件网关下载 263 企业邮局特殊邮件发生格式错误问题.
9. 增强用户邮件过滤规则，动作可设置为标记为已读.
10. 可以设置隔离区通知邮件发送间隔时间，并修正隔离邮件超期不删除问题.
11. 管理工具多个列表框可以使用 Ctrl, Shift 多选.
12. 系统日志中 Admin 日志将不能删除与清空.
13. 猜密码检测可设置 IP 和用户白名单，屏蔽 IP 地址可导出.
14. 认证发信默认限制发件人必须是本系统域，拒绝非法中继.
15. 给组地址发信时，可设置收件人显示组成员的地址，也可以设置以组地址发信.
16. 增强自动回复，可设置同一发件人每天只回复一次.
17. 升级 Apache 到 2.4.37.
18. 升级 PHP 到 7.1.23.
19. 升级 OpenSSL 到 1.0.2p.
20. 升级 ClamAV 到 0.100.1.

Version 6.3(Build 0408)(2018/04/08)

1. [白金版]提供64位安装包，提高系统运行效率.
2. 提供全新的适配移动设备的 Webmail.
3. 系统后台经过配置后，Webmail 可以在线预览 Office 附件.
4. 改进内存分配，防止内存分配异常重启.
5. 改进数据库读取，改善邮件读取速度.
6. 增加异地登录提醒功能.
7. 中文日志和用户访问记录增加 IP 地理位置信息.
8. 增强 SSL/TLS 证书管理，可以针对不同的访问主机名配置各自证书.
9. 修正发信到系统通讯组可能会重复发信问题.
10. 修正 Webmail 阅读邮件时，特殊邮件内容不显示问题.
11. 归档功能可以支持单副本存储，也可以按照用户分目录保存.
12. 防病毒和附件过滤支持 7z 附件解压.
13. 修正病毒扫描时部分 .zip 附件误报感染病毒.
14. 管理工具的用户列表记忆调整后的列宽度和次序
15. 增强反垃圾模块，增加查询域名过滤列表 DBL 功能.
16. 修复多项 Webmail 安全漏洞.
17. 修正部分格式邮件 DKIM 编码错误.
18. 升级 Apache、PHP 版本.

Version 6.2(Build 0620)(2017/06/20)

1. 微信绑定增加支持企业微信.
2. 用户属性字段增加了部门，公司和部门字段分开.
3. 导入用户时，增加邮箱容量、网络磁盘容量字段.
4. Webmail 公用地址簿显示更多常用字段.
5. 修正 Pushmail 不能创建子目录问题.
6. 修正 Outlook Pushmail 子目录里邮件不能阅读问题.
7. 修正 Webmail 中下载中文名附件有时出现文件名乱码问题.
8. 修正 Webmail 写邮件无法正确选择多个地址问题.
9. 修正 Webmail 网络磁盘上传、下载中文文件丢失文件名问题.
10. 修正 Webmail 几项安全漏洞.

Version 6.2(Build 0330)(2017/03/30)

1. [白金版]新增归档邮件查询模块，用户和管理员可在 Web 上查询和恢复系统归档邮件.
2. IMAP 自动订阅系统邮件夹，Outlook 2013 以上自动识别已发送、已删除等系统邮件夹.
3. 公用地址簿 OpenLDAP 后台数据库引擎升级，增加自动修复和清空功能.
4. 系统通讯组增加导入和导出功能.
5. 管理端公用地址簿增加搜索功能.
6. 改进用户管理易用性，可方便的按部门管理用户.
7. 用户属性中增加系统归档查询和 Pushmail 访问权限设置.
8. AD 帐号同步时，AD 用户信息修改的会同步更改邮箱用户信息，AD 用户禁用的邮箱用户自动禁用.
9. 改进退信内容，增加中文解释和处理建议.
10. 改进邮件签核的通知邮件.
11. 管理员可以在管理工具里查看隔离区邮件的摘要信息，进行重发被隔离邮件、加白名单等操作.
12. 用户隔离通知邮件中增加取回和加白名单链接，用户可以直接点击链接取回被隔离邮件.
13. SMTP 过滤中增加 SpamAssassin 过滤选项，可疑邮件可以设置放入隔离区.
14. 邮件过滤动作增加放入隔离区选项.
15. 默认 admin 管理员可以删除.
16. SMTP 可以禁止明文认证.
17. 系统安全性提升，加密保存用户密码等多项敏感数据，升级后无法回到老版本.
18. 增强了 Webmail 安全性检查，修复多项安全漏洞.
19. 修正"已发送"中邮件递送状态不正确问题.
20. 修正 Webmail 某些情况下 Word 表格格式被过滤掉问题.
21. 修正 OpenAPI 接口修改用户时没有传入的字段数据丢失的问题.
22. 升级 Apache、PHP 版本.
23. 编译器更新，新版本不再支持 Windows 2000，XP系统必须安装 sp3.

Version 6.1(Build 0720)(2016/07/20)

1. 新增邮件密级功能，支持用户密级与邮件密级控制[白金版支持].
2. LDAP 服务升级到 2.4.44，支持 Outlook 直接访问服务器上的公用地址簿.
3. 支持阿里钉钉绑定，可以实现新邮件钉钉通知和在钉钉中登录收发邮件.
4. 微信绑定增加支持微信企业号.
5. 短信网关功能增加支持阿里大于和网易易信服务，支持 RTX 提醒.
6. 支持同时启用短信、微信、钉钉新邮件提醒和绑定.
7. 增强网络磁盘、行事历共享安全性.
8. 系统邮件模板支持 HTML 格式.
9. 改善 IMAP、POP3 认证速度.
10. 可以设置是否发送系统邮箱使用情况报表.
11. 邮件签核增加签核成功是否通知收件人选项.
12. Webmail 支持在 PHP7 环境运行.
13. 修正 IMAP 收件箱下子文件夹订阅状态丢失问题.
14. 修正 iOS 邮件客户端 IMAP 命令异常问题.
15. 修正分布式系统数据同步问题.
16. OpenSSL 升级到 1.0.2h 版本, 支持 TLS 1.1、TLS 1.2.
17. 升级 Apache、PHP 版本.

Version 6.0(Build 0330)(2016/03/30)

1. 支持与已认证微信服务号绑定，可以实现新邮件微信通知和在微信中登录收发邮件.
2. 支持 Outlook 2013 Pushmail 连接方式，支持邮件、日历、联系人、任务同步[白金版支持].
3. 行事历功能标准化，兼容 outlook，支持共享.
4. 可以设置只读邮箱，该邮箱用户无论使用何种客户端都不能删除邮件.
5. 反垃圾邮件支持隔离区功能，邮箱用户可以自行取回被隔离的疑是垃圾邮件.
6. 反垃圾邮件支持 DKIM 过滤和签名，设置 DKIM 也可以提高外发邮件的到达率.
7. 被反垃圾邮件模块临时屏蔽的IP，管理员可以清除释放.
8. 归档功能增强，可设置归档邮件保留时间.
9. 备份功能增强，可设置备份数据保留时间.
10. 多IP服务器，可以设置外发邮件连出ip.
11. 邮箱密码输错多次被系统暂停后，管理员可以解锁被暂停的账号.
12. 域名管理里可以定制 Webmail 里的 Logo 图片和公司名称.
13. 待签核邮件签核成功后，会给发通知邮件给发件人.
14. 来自邮件监控、邮件归档的邮件主题插入"监控邮件""归档邮件"标记，可取消.
15. 可以禁止一个邮箱的 SMTP 功能.
16. 所有客户端发出的邮件，如果在服务器上"已发送"邮件夹中保留的，可以在 Webmail 上撤回.
17. Webmail 里可以查看本邮箱的访问记录、发信记录、删信记录、隔离邮件.
18. Webmail 增加定时发信功能.
19. Webmail 增加会话方式显示邮件功能.
20. Webmail 可发送加密码邮件，兼容 Foxmail 和腾讯邮箱系统相关功能.
21. Webmail 写邮件功能在新版浏览器中支持插入剪切板里的图片，支持qq截图.
22. Webmail 写邮件功能在新版浏览器中支持拖放方式上传附件.
23. 可以设置 POP3 收取后是否保留服务器上的邮件，不管客户端软件是否设置保留备份.
24. 增加多种邮箱使用情况报表，让管理员及时了解系统运行状况.
25. 提供 OpenAPI 二次开发接口，HTTP 协议请求使用 GET/POST 方式，返回数据采用 JSON 格式.

Version 5.5.2(Build 0504)(2015/05/04)

1. 修正 IMAP 部份邮件下载不全.
2. 中继服务器增加指定域和用户限制.
3. 附件名过滤增加指定域和用户限制.
4. 修正垃圾邮件递送指定邮箱错误.
5. 修正占用内存大问题.
6. 修正 IE9,IE10 下HTML 编辑器回车间隔大问题.
7. 修正 Webmail 占用资源多的问题.
8. 发邮件时 XSS 过滤，导致 style 标签过滤问题.
9. 邮件自动索引时，删除无用的缓存记录.
10. PHP 升级到 5.4.35.
11. Sqlite 升级到 3.8.7.2.
12. 修正服务器端程序异常终止问题.

Version 5.5(Build 1009)(2014/10/09)

1. 增加分布式部署功能，支持单域名多主机，满足多分支机构系统架设需求[白金版支持].
2. 增加支持第三方 LDAP 认证 、Radius 认证 [白金版支持].
3. 增加自动迁移第三方邮件系统数据的邮箱搬家功能，自动迁移原系统账户、密码和邮件.
4. 增加用户邮件自动归档，自动清理功能[标准版、白金版支持].
5. 优化 Webmail 邮件列表功能，提高大邮件量显示速度.
6. Webmail 增加标签管理、置顶、备注、星标、显示内容摘要等功能.
7. Webmail 邮件列表按时间分类，按照今天、昨天、本周、本月显示邮件.
8. 在 Webmail 已发送邮件夹可以查看发出邮件的递送情况.
9. 多项系统和用户数据保存到 SQLite 数据库，提高系统效率.
10. 系统通讯组增加名称栏位，方便设置中文名.
11. 用户 POP3 下载，增加发送邮件设置.
12. 修正使用 Pushmail 协议时，无法显示Outlook 日历提醒邮件内容问题.
13. 修正使用 IE11 下载文件名乱码、HTML 编辑器部份功能不正常使用问题.
14. Apache 升级到 Apache 2.4.10.
15. PHP 升级到 5.4.31.
16. SpamAssassin 升级到 3.4.0.
17. ClamAV 升级到 0.98.4.
18. OpenSSL 升级到 0.9.8zb.

Version 5.1.2(Build 0522)(2014/05/22)

1. 修正 IE11 访问 Webmail 部分功能无法使用问题.
2. 系统通信组发信权限设置调整.
3. Apache 升级到 Apache 2.4.6，修正 webmail 无响应问题.
4. 修正 webmail 安全漏洞.

Version 5.1(Build 0718)(2013/07/18)

1. 反垃圾模块新增灰名单(Greylisting)和连接延迟响应功能.
2. 部分系统数据改用数据库保存，提高系统效率.
3. 增加各系统服务流量统计图，保留30天统计记录.
4. 增加查看活动连接功能.
5. 邮件实时备份改名为归档，可设置排除用户.
6. 查看系统日志界面增加查找功能(Ctrl+F).
7. 域名密码策略设置，增加无策略选择，可设置不做密码复杂性检查.
8. 用户和域属性，增加最多收件人限制[标准版和白金版支持].
9. 用数据库保留邮件缓存，提高网页大邮件量显示速度.
10. 管理端可以设置选择以 FastCGI 运行 php, 提高网页速度.
11. iPhone,iPad使用网页写邮件时支持上传照片作为附件.
12. 电脑访问登陆页时可生成二维码，方便手机扫描登陆.
13. 地址簿里的联系人信息可生成二维码，方便扫描加入手机通讯录.
14. 增加用户收发流量记录[白金版支持].
15. 增加用户接收邮件记录[白金版支持].
16. 增强计划任务指定对象，可以设置排除特定用户.
17. 修正 Outlook 2013 使用 IMAP 占用资源过大的问题.
18. Apache 升级到 Apache 2.4.4.
19. PHP 升级到 5.4.16.
20. SpamAssassin 升级到 3.3.2.
21. ClamAV 升级到 0.97.7.
22. OpenSSL 升级到 0.9.8x.

Version 5.0(Build 0620)(2012/06/20)

1. 增加邮箱密码被猜解和邮箱被盗用转发垃圾邮件行为检测功能.
2. 外发邮件时，一次连接递给同域下的多个收件人，提高外发效率.
3. 优化 DNS 缓存，记录 TTL 时间，提高查询效率.
4. Webmail 默认界面风格支持多标签窗口，使用更方便.
5. Webmail增加一种 pad 专用界面风格，支持 iPad、Android 等触摸平板电脑.
6. 新的Webmail 风格支持 iPhone、Android 等大尺寸触屏手机.
7. 邮箱用户可以设置发件人黑白名单.
8. 个人地址簿中的联系人做为白名单用户，不进行过滤.
9. Webmail 支持 IE 10.
10. 基础版和标准版也支持Wap 访问.
11. 个人地址簿可以增加多种电话号码.
12. 个人地址簿支持按分组导入导出.
13. 网络磁盘 FTP 数据端口允许设置一段范围.
14. 增强短信网关功能.
15. 支持 Windows 8.
16. 修正邮箱监控和邮件签核误判问题.
17. 修正 COM 组件新增用户方法无法增加到全局地址簿的问题.
18. SSL 安全服务可以设置关闭 SSLv2 和 Weak Ciphers.

Version 4.9(Build 0715)(2011/07/15)

1. [白金版] 提供Push Mail模块，可以用常用的智能手机同步邮件和联系人.
2. 增加邮件撤回功能, 支持 Webmail 和 Office Outlook.
3. 系统日志可以设置记录语言，支持简体、繁体、英文.
4. 系统退信可以设置语言模板，支持简体、繁体、英文.
5. 邮件监控功能支持条件设置.
6. 邮件签核功能支持条件设置.
7. 增加收件签核功能.
8. 增强密码安全策略，支持密码强度设定，支持定期修改密码.
9. 用客户端通过 SMTP 发的邮件可以设置自动保存到服务器上的发件箱.
10. 增加一个附加的非25的 SMTP 端口，可以用于客户端发信.
11. Webmail增加一种简洁版 simple 界面风格，类似 Hotmail.
12. Webmail增加一种 3G mini 界面风格，适合用手机和移动设备登录.
13. Webmail阅读邮件时，增加[邮件往来]链接，可以列出与这个发件人通讯过的邮件.
14. 可以用邮箱别名或域别名登录Webmail.
15. Webmail 支持 IE 9、Firefox 4、Chrome 10.
16. Webmail 上发网络磁盘下文件链接，无需先设置共享，下载链接有截止日期.
17. 新版 Winmail 不再支持在 Windows NT 系统上安装.
18. 修正同时给内部和外部地址发邮件时，内部监控规则会失效问题.
19. 修正新增加用户时，新用户丢失域的收发控制参数问题.
20. OpenSSL 升级 0.9.8r .
21. Apache 升级到 2.2.19 .

Version 4.8(Build 0811)(2010/08/11)

1. 系统通信组可以支持多层级，实现树形企业通讯录.
2. 系统通信组外部组成员增加名字字段.
3. Webmail 新增界面风格.
4. 改进 Webmail 邮件列表和读邮件代码.
5. Webmail 更好的支持IE7和IE8.
6. 增强 HTML Editor 支持 Firefox, Safari, Chrome.
7. 管理端可以设置常用的 Webmail 参数.
8. 改进 Webmail 地址簿，增加查询功能.
9. SpamAssassin 改成服务方式运行，提高垃圾邮件评分效率.
10. 修正清空网络磁盘时子目录不会删除问题.
11. 修正访问时间不更新 bug.
12. 修正外发大邮件时，超时重复发信问题.
13. PHP 升级到 php 5.3.2.
14. Apache 升级到 Apache 2.2.15 ，以服务方式运行，提高 Webmail 效率.
15. OpenSSL 升级到 0.9.8n.
16. [白金版]整合 ClamAV 查毒引擎，自动更新病毒库.
17. [白金版]系统通信组可以排序.
18. [白金版]系统通信组成员可以排序.
19. [白金版]增加用户邮箱访问记录.
20. [白金版]增加发信流量控制，系统、域、单个邮箱可以设置每小时和每日发信量.
21. [白金版]增加用户邮箱发信记录.
22. [白金版]自动同步 AD 账户

Version 4.7(Build 0217)(2009/02/17)

1. 增强 Webmail 邮件列表，搜索功能，增加标签设置.
2. 增加域的邮箱的存储目录和网络磁盘存储目录设置.
3. 增加域的签名档设置.
4. 增加单个用户邮箱的存储目录和网络磁盘存储目录设置.
5. 增加多条中继服务器.
6. 增加系统广播邮件，可以直接发邮件给系统内所有用户或指定域名下的用户.
7. 增加 FTP 数据传输(PASV 模式)外网 IP 地址和端口设置.
8. 增加自动备份的时间设置.
9. 增强邮件监控功能，可以设置内部/外部邮件监控.
10. Webmail 地址簿，过滤规则等列表分页显示.
11. Webmail 增加发件人地址设置.
12. Webmail 发邮件时可以选择发通知短信.
13. 增强 MS-TNEF(winmail.dat附件) 格式邮件转码.
14. 修正地址簿排序出错，可以按照拼音排序.
15. Webmail 增加图形识别码检查，用户登录出错时，注册新邮箱时.
16. Webmail 用户登录出错次数限制
17. 修正 SSL 出错不超时错误.
18. 修正管理工具登录时“服务器无响应” 的 Bug .
19. 修正行事历提醒邮件的 mail from 问题.
20. 升级 Apache 到 1.3.41 版.
21. 升级 PHP 到 4.4.9 版.
22. 升级 OpenSSL 到 0.9.8i 版.

Version 4.6(Build 0618)(2008/06/18)

1. Webmail 采用 AJAX 技术, 提高页面速度.
2. 增加磁盘可用空间容量警告功能.
3. 增加 Webmail 写邮件时邮件字符集选择.
4. 增强域管理和用户管理中增加拒绝或允许与某些域收发.
5. 增加访问用户邮箱时各服务的 IP 限制.
6. 增加 SMTP 设置中 发件人过滤，收件人过滤，ehlo主机过滤等设置的导入和导出.
7. SMTP/POP3/IMAP 等各服务过滤 IP 的导入和导出.
8. 系统过滤规则和 POP3 下载记录的导入和导出.
9. 计划任务的“清除用户邮件”的动作对象可以指定特定的用户.
10. 增强反垃圾邮件功能，增加连接发件人的邮件服务器校验发件人地址是否存在功能.
11. 系统级过滤处理动作可以设置为终止、放到指定公用邮箱、放到改用户的垃圾邮箱里并且主题加[SPAM]标记.
12. 用户级 SpamAssassin 垃圾邮件过滤动作可以设置为"主题增加前缀[SPAM], 递送到收件箱".
13. 单个邮箱空间设置允许超过 2G.
14. 增加更多的短信服务商.
15. 域管理员增加 邮件监控，邮件签核 权限.
16. Web 管理增加邮件监控，邮件签核设置.
17. 在Webmail里查看已发送的邮件时，可以选择重发.
18. Webmail 邮件签核时可直接点击“允许”/“拒绝”来进行审核
19. 改进 Webmail 写邮件时地址簿加载，加快显示速度
20. 修正已经签核的邮件，再次签核报告用户不存的错误.
21. 新建联系人的时可以选择加入地址组.
22. 修正 COM 接口删除用户出错.
23. 用户管理和域管理增加 http 接口.
24. 系统 POP3 下载时记录丢弃邮件的信息.
25. 修正 Secure FTP 文件上传和下载的错误.
26. 修正邮件内容有多个字符集时不能正确显示的问题.

Version 4.5(Build 0912)(2007/09/12)

1. 增强国际化支持，字符集转换成 UTF-8 .
2. 增加日志文件存放目录设置.
3. 各个域名可以设置独立的系统信发件人.
4. 非主域用户登录 SMTP/POP3/IMAP/FTP 服务时，可以通过访问的主机名和IP区分来用户.
5. 系统 POP3 下载，可以设置保留副本的天数和邮件头自定义要分析字段.
6. 用户管理中增加导入 Windows AD 的用户功能.
7. 短信通知增加发送短信时间段设置.
8. Webmail 的地址簿/通信组/过滤规则/签名档/外部POP3 邮箱增加批量删除功能.
9. Webmail 行事历中的任务/事件列表增加排序功能.
10. Webmail 增加默认签名档设置.
11. Webmail 增加登录次数及最后一次登录时间显示.
12. [白金版]增加 WAP 功能.
13. 行事历中共享事件/任务增加时间控制和访问密码.
14. 网络磁盘共享文件增加时间控制和访问密码.
15. 修正域名 MX 指向 IP 时，查询结果不正确.
16. 修正多条邮件监控时，只有第一条监控生效的错误.
17. 修正电信 DNS 服务器不正确时，RBL/RWL 检查结果错误.
18. 修正 Webmail 在 PHP5 环境下邮件列表出现警告提示
19. 修正备份邮件时，旧的同名备份文件没有删除的错误.
20. 增加 Winmail 中的白名单添加到 SpamAssassin 配置文件中.
21. 升级 Apache 到 1.3.37 版.
22. 升级 PHP 到 4.4.6 版.
23. 升级 OpenSSL 到 0.9.8e 版.
24. 升级 SpamAssassin 到 3.17 版.
25. 不再支持在 Windows 9x,ME 上安装 Winmail 程序.

Version 4.4(Build 1124)(2006/11/24)

1. 增加 SPF(Sender Policy Framework) 检查.
2. 增加陷阱邮箱功能.
3. 增强 HELO/EHLO 主机名检查.
4. 增强用户权限设置.
5. 修正多层邮件监控时，管理员收到重复信问题.
6. Webmail 增加了一种新风格，该风格可以选择多种配色.
7. 修正系统 POP3 下载时，邮件日期修改问题.
8. 修正队列临时文件删除失败的问题.
9. SMTP 过滤调整，可以通过 http://www.abuse.net/relay.html 测试.
10. 增加Webmail 注册时用户名和密码强度检查.
11. 修正行事历不能设置在某一日运行问题.
12. 修正 Webmail 邮件列表排序错误.
13. 修正 Webmail 显示附件图片太大问题
14. 修正系统 Pop3 下载无限别名邮箱时重复问题.
15. 修正用户 Pop3 下载错误提醒信重复问题.
16. 增强 COM 接口，增加通讯组操作方法.
17. 新邮件短信通知可以显示发送者姓名.
18. 升级 SpamAssassin 到 3.13 版.

Version 4.3(Build 0302)(2006/03/02)

1. Web 管理中增加“管理员管理”功能.
2. FTP 服务数据端口使用固定端口6020.
3. 域管理增加了重算所有域的已经分配空间.
4. 邮件网关的 POP3 下载，信头分析可以选择需要分析的信头字段.
5. 修正了不能发送给 aol.com 等多行回应信息的服务器时的出错.
6. 修正了 postmaster 不能收信问题.
7. Web 管理中的域名管理增加域名查询功能.
8. Webmail 写邮件时，可以分隔收件人.
9. Webmail 写邮件时，可以直接插入内嵌图片，表情.
10. Webmail 预览 HTML 附件时过滤附件中的 JavaScript.
11. Webmail 写邮件时，可以直接从网络磁盘中选择文件.
12. Webmail 行事历增加共享行事历功能.
13. Webmail 草稿中的邮件发送后可选择不删除.
14. Webmail 优化，加快访问速度.
15. 升级 Apache 到 1.3.34 版.
16. 升级 PHP 到 4.4.1 版.
17. 升级 OpenSSL 到 0.9.8a 版.
18. 升级 SpamAssassin 到 3.10 版.
19. 修正了 IMAP 服务与 JavaMail 的兼容错误.
20. 修正了 IMAP 服务下载邮件时多“\r\n.\r\n”字串的错误.
21. 修正 Webmail 中阅读了“查找”结果的邮件后出错.
22. 修正 Web 管理域管理员在普通域下邮箱容量设置不正确的错误.

Version 4.2(Build 0824)(2005/08/24)

1. 增强了 SMTP 过滤功能，增加发信者白名单服务器列表 RWL 检查.
2. 增强了用户收发限制，可以设置用户能与特定域进行收发.
3. 增强了密码存储方式，支持 md5, sha1, plain, crypt(DES).
4. 增强了新邮件短信通知功能，支持 GSM 短信猫，可以设置短信通知内容.
5. 升级数据库引擎，提高数据库分析速度.
6. 升级 SpamAssassin 到 3.02 版.
7. 中继递送，支持 SSL 连接的服务器做中继服务器(如 gmail).
8. Webmail 增加数字证书管理，可以收发和阅读 S/MIME 格式的邮件.
9. NT 域名认证用户可以使用 Webmail 和 foxmail 来收发邮件.
10. Webmail 增加个人联系人分组.
11. 调整了 Webmail 写邮件时的地址选择方式（树形显示）.
12. Webmail 增加了最近联系人列表功能.
13. Webmail 写信时收件人地址自动提示功能.
14. Webmail 可以阅读和下载 eml 格式附件中的附件.
15. Webmail 可以标识邮件为已读/未读邮件.
16. Webmail 支持 Punycode 格式的域名（中文域名）.
17. Webmail 附件下载时，减少多次分析，提高速度.
18. Webmail 下载文件时，提示文件大小，修正下载文件不完整错误.
19. Webmail 发信时，可以选择发件人地址.
20. 修正了 SMTP SSL 通讯兼容问题.
21. 修正了 Mozilla Thunderbird IMAP 浏览图片慢以及发件箱邮件状态出错问题.
22. 移除了 Secure LDAP.
23. IMAP 服务支持 IDLE 扩展命令.
24. 分离防病毒的通知邮件和附件过滤通知邮件.
25. COM 组件增加了修改用户和域发信限制的方法.
26. 修改了 POP3 下载后递送会自动回复到管理员的错误.

Version 4.1(Build 0428)(2005/04/28)

1. 增加了 SMTP 服务增加允许 Mail From 为空地址选项（MAIL FROM:<>）.
2. 增加了 SMTP 发送和接收邮件的大小限制分开来.
3. 增强了 POP3 下载，支持 SSL 连接.
4. 增强了个人垃圾过滤，整合 SpamAssassin.
5. POP3 服务支持 LAST 命令.
6. 增强了邮件监控和签核功能，可以授权给域管理员.
7. 增强了计划任务，可以禁止长期未登录用户和清空用户的指定邮箱.
8. 增强了邮箱用户的权限设置.
9. Webmail 可以导入导出个人地址簿.
10. Webmail 新增加两种界面风格.
11. Webmail 菜单显示新邮件数.
12. 自动回复增加时间限制.
13. 调整了 Webmail 目录结构，以增加安全性.
14. 修正了导出用户邮箱帐号出错.
15. 修正了计划任务时间段设置问题.
16. 修正了 Webmail 文本格式下邮件回复出错.
17. 修正了 Mozilla Thunderbird POP3 认证问题.
18. 中继递送，直接递送可设置 MAIL FROM，支持 163.com, sohu.com 中继递送.
19. 修正了加密的 RAR 压缩包释放误判为病毒邮件.
20. 修正了更新密码时，共享文件不能访问.
22. 更新了 Outlook Express 插件.
23. 修正了递送给组的邮件，邮件大小记录不正确的问题.
24. 修正了 IMAP 服务和 Opera, Mozilla Thunderbird 兼容性的问题.
25. Webmail 新增加 English 的拼写检查功能.
26. webmail 增加了日语和法语支持.
27. 增加了不进行 SMTP 过滤的主机地址列表.
28. 增加了邮件组可见度设置.

Version 4.0(Build 1318)(2005/01/18)

1. 修正了 Webmail 中网络磁盘文件日期显示的问题.
2. 修正了 Webmail 暴露安装路径的问题.
3. 修正了 Webmail 文件上传下载有效性校验的问题.
4. 修正了 Webmail 对 JavaScript 过滤不全的问题.
5. 修正了 IMAP 服务文件夹有效性校验的问题.
6. 修正了网络磁盘服务 Port 命令有效性校验的问题.
7. 更新了unzipdll.dll.

Version 4.0(Build 1112)(2004/11/12)

1. 增加了网络磁盘（FTP 服务器），支持文件共享.
2. 增加了网络行事历和网络记事本.
4. Webmail 增加公告板功能.
5. 增强了 IMAP 服务.
6. 域名直接递送支持用户认证.
7. 邮件查毒时释放 unzip, unrar 格式的附件.
8. 邮箱用户权限细分，可设置有效时间等.
9. 增加了公用地址簿数据的备份.
10. 增强了 COM 组件功能，增加用户容量，域容量限制，个人信息修改等.
11. 用户列表显示邮箱容量，已用容量等.
12. Webmail 增加了通过问题和答案生成临时密码.
13. Webmail 可以设置页面宽度.
14. Webmail 可以设置退出到指定制的页面.
15. Webmail 支持保存密码自动登录.
16. Webmail 读邮件时增加过滤邮件.
17. Webmail 发邮件支持直接发到公共邮件夹.
18. 增加了用户过滤邮件直接递送到公共邮件夹
19. 修正了 WinXP 列表中图标不显示问题.
20. 修正了 Webmail 弹出窗口时出现登录页面.
21. 修正了 RBL 查询时死循环问题.
22. 修正了 HTTP 服务启动状态报告不正确的情况.
23. 修正了 Webmail 转发 TNEF 格式的邮件不正确的问题.
24. 修正了 Webmail 发送大附件时系统资源占用过大的问题.
25. 修正了用户不存在时，发送到 Internet 检发送者是否允许外发.
26. 修正了自动转发检查发件人是否有发信限制.
27. 修正了 Mac OS 上 POP3 收到普通域下的邮箱.
28. 修正了 POP3 download 多线程死循环的问题.
29. 在 SMTP 中增加 VRFY，EXPN 命令，可以选择是否开启.
30. 组管理员与指定发信人可以是非组员和外部邮箱.

Version 3.8(Build 0820)(2004/08/20)

1. 增加了SMTP通讯中识别虚假信头的功能.
2. 增加了发件人白名单和收件人白名单.
3. 增加了组合过滤功能.
4. 增加了附件个数过滤的功能.
5. 重写 IMAP 服务.
6. 修正了 Webmail Session Timeout 问题.
7. 修正了 Webmail 显示乱码问题.
8. 修正了 Pop3 下载多线程问题.
9. 修正了 RBL 检查出错问题.
10. 修正了公用地址簿导入含中文文件乱码问题.
11. 修正了在 Windows 2003 上安装 Webmail 出错问题.

Version 3.8(Build 0509)(2004/05/10)

1. 增加支持 SSL 的 HTTP 服务.
2. 增加了过滤邮件正文的功能.
3. 增加了在管理程序里直接清空某一用户邮箱的功能.
4. 增加了管理工具保存登陆密码的功能.
5. 增强了 SMTP 对 SSL 通信的支持.
6. 增加了 SMTP/POP3/IMAP4 客户 IP 访问频率限制的功能.
7. 增加了 SMTP/POP3/IMAP4 同一 IP 同时连接次数限制的功能.
8. 管理工具中查看公用地址薄的时候显示全名.
9. 增加了邮件组可设置管理员的功能.
10. 增加了邮件组组成员导入和导出的功能.
11. 邮件备份按发送者接收者分目录存放.
12. SMTP 中增加了EHLO/HELO 主机名检查.
13. Webmail 中增加了用户邮箱级过滤设置的功能.
14. Webmail 中增加了帐号保留的功能.
15. Webmail 中增加了下载邮件全文的功能.
16. Webmail 可以屏蔽外部pop3, 短信, 修改口令.
17. Webmail 支持 Greek 语言.
18. 修正了过滤文件扩展名处理错误.
19. 修正了更换安装目录后备份数据无法用程序恢复的错误.
20. 修正了查看邮件队列有时管理工具异常中止的错误.
21. 修正了一些 IMAP 命令处理错误，提高 IMAP 邮件处理效率, 支持 Outlook 2003.
22. 修正了域名 MX 记录查找不到的问题.
23. 修正了用 Web 界面中无法修改域名“直接登录URL”属性的错误.
24. 修正了 Webmail 中写邮件时列公用地址簿慢的错误.
25. 修正了 LDAP 有时停止响应的错误.
26. 修正了 Webmail 显示邮件有时出现 one_filtered 的错误.
27. 修正了 Webmail 显示邮件有时暴露物理路径的错误.

Version 3.6(Build 0202)(2004/02/02)

1. 修正了无限别名失效的问题.
2. 修正了过滤空主题失效的问题.
3. 修正了多邮箱监控失效的问题.

Version 3.6(Build 0116)(2004/01/16)

1. 增强了过滤规则功能, 过滤规则顺序可调整.
2. IMAP 支持子文件夹和包含空格的文件夹.
3. 增强了快速设置工具的功能.
4. 增加了删除临时文件的功能.
5. 增加了设定单个用户最大的允许发邮件字节数.
6. 增加了邮件组可以增加外部邮箱地址的功能.
7. 防病毒设置里增加支持 Norman 杀毒引擎.
8. 公用地址簿增加导入,导出功能.
9. Webmail 增加了写邮件时每隔一段时间自动存盘的功能.
10. Webmail 增加了直接收取用户外部 POP3 帐号中邮件功能.
11. Webmail 写邮件可以直接从公用地址簿和邮件组中选取收件人.
12. Webmail 增加拷贝邮件功能.
13. Webmail 增强了对UTF7, UTF8, UUCODE 格式邮件的支持.
14. Webmail 增加了允许用户选择是否加入公用地址簿.
15. Webmail 增加MS-TNEF(winmail.dat)类型附件自动剥离功能.
16. Web 管理程序增加查找用户功能.
17. 帮助文件增加了让 Webmail 运行在 Apache 环境中的方案
18. 修正了有时用户最后访问时间丢失问题.
19. 修正了更改主域时公用地址簿出错问题.
20. 修正了 SMTP 设置 DNS 反查，发邮件给本域时的问题.
21. 修正了 SMTP 设置查找用户是否存在，发邮件给域别用户的问题.
22. 修正了域属性的默认邮箱被清空的错误.
23. 修正了 IE5 浏览 Webmail 出错问题.
24. 修正了 Webmail 阅读新浪发来带附件邮件的问题.

Version 3.5(Build 1106)(2003/10/07)

1. 增加 Webmail 浏览 IMAP 公共文件夹中的邮件功能.
2. 增强了公用地址簿的删除用户名单功能.
3. 增加个人地址簿个数限制功能.
4. 增加了新建的用户可以自动增加到 everyone 组中的功能.
5. 增强了邮件过滤功能，方便用户利用此功能来分发邮件.
6. Webmail 可以创建中文文件夹.
7. 支持自定义系统的各服务显示名称.
8. 解决了Web 管理功能中加邮箱页面出错的问题.
9. 解决了 Webmail 中签名档格式和保存问题.
10. Web 管理程序的语言包新增瑞典语.
11. 解决了 Webmail 中文文件名有时无法查看的问题.

Version 3.4b(Build 1022)(2003/10/24)

1. 支持短信提醒，有新邮件到达时，可在手机上获得通知.
2. 对 SMTP, POP3, IMAP, LDAP 可以支持 SSL 加密传输, 防止网络侦听.
3. SMTP 设置里增加HELO主机名设置功能, 解决了发信到 sina 邮箱的问题.
4. 公用地址簿可以增加非本系统的地址.
5. 增加 IMAP 公共邮件夹功能, 可以设置读写权限.
6. 支持使用外部 Socks4,Socks5 服务器代理发信和 POP3 下载.
7. 邮件过滤增加信头任意内容过滤功能.
8. 防病毒设置里增加附件文件名和类型过滤功能.
9. 防病毒设置里增加支持 Panda, RAV, F-Secure 杀毒引擎.
10. 增加接受邮件时对发信地址做域名 DNS 反向检查功能.
11. 增加接受邮件时立刻对本地邮箱是否存在做检查功能.
12. 增加 COM 接口组件, 可以编程操作用户账号,域名,管理员, 提供 asp, php 实例.
13. 邮件网关的 POP3 下载中增加公用外部地址用户名替换功能, 可以实现多人共享一个邮件帐号而互不干扰.
14. SMTP 设置中增加公用外部地址替换功能.
15. 增加 Web 管理功能, 可以进行在网页上在线管理系统的邮箱和域名.
16. Webmail 增加请求阅读收条的功能.
17. Webmail 增加保存到草稿箱的功能.
18. Webmail 增加 customer 目录, 使修改页面更方便, 并可以针对不同的域定制不同的.
19. Webmail 中公用地址簿将显示用户全名.
20. Webmail 支持 Norwegian, Danish 语言.
21. Webmail 登陆支持直接输入域名.
22. Webmail 写HTML格式邮件支持选择多种信纸.
23. 解决了webmail 拷贝URL能登录的问题.
24. 解决了修改POP3端口后 Webmail 无法登陆的问题.
25. 解决了 Webmail 中签名档格式问题.
26. 解决了 Webmail 登陆名加空格无法正常看信的问题.
27. 解决了用 Ximain Evolution 访问时, IMAP, POP3 格式兼容的问题.
28. 解决了有时出现错误的邮箱满的问题.
29. 解决了POP3下载有时出现重复收信的问题.

Version 3.0(Build 0808)(2003/08/08)

1. 增加公用地址簿(LDAP), Outlook等可查看, 增加更多的用户信息字段.
2. 增加IMAP功能.
3. 增加邮件签核功能, 可以在邮件发出前进行签核.
4. 增加系统备份, 可以增强邮件备份功能.
5. 增加外域直接发送主机.
6. 管理工具语言包新增繁体中文, WebMail 的语言包新增德语和瑞典语.
7. 增强过滤规则的功能.
8. 修正在大量发送邮件时，查找用户找不到的BUG.
9. 增加计划任务的执行时间段.
10. 可以设置保存历史日志的天数.
11. Webmail与IIS整合后，可以上传较大的附件.
12. 修改有时出现用户的邮件大小和邮件数为负数的问题.
13. SMTP设置功能增加检查SMTP交互命令中的邮件地址是否合法的功能.
14. SMTP设置功能增加邮件收件人过滤.
15. 对查找MX的结果按优先级进行排序.
16. 修正某些情况下，SMTP发送过程中发生的通信异常.
17. 修正在CheckPoint防火墙下，查找MX出错.
18. 增加用户列表，域名列表等排序功能.
19. 增加用户导入与导出功能.
20. 改善管理工具超时提示功能.
21. 修正Netscape Messenger认证发送出错.
22. Webmail增加永久删除功能.
23. 增加单独的管理程序安装包.
24. 病毒警告信可以设置发给收件人.
25. 修改了其它一些小问题, 改变了一些提示写法.

Version 2.4(Build 0530)(2003/05/30)

1. 更新帮助文件, 解决了 Webmail 设置到IIS中无法修改口令和设置参数的问题.
2. 解决了使用快速设置向导工具后SMTP认证功能不立刻生效的问题.
3. 解决了一个系统内存溢出的问题.
4. 解决了Webmail发信信头标签不全的问题.

Version 2.4(Build 0516)(2003/05/20)

1. 允许多个管理员, 支持单独的域管理员功能.
2. 支持更多的域属性.
3. 用户邮箱转发功能可支持多个地址.
4. 增加将 MS-TNEF (winmail.dat) 类型附件自动剥离功能.
5. 可以将 WebMail 设置为 IIS 的虚拟目录或虚拟站点.
6. WebMail 的语言包新增繁体中文.
7. 优化了 WebMail 登陆速度.
8. 支持 Windows 2003 Server.
9. POP3下载中的用户名支持包含 %.
10. 解决了smtp改端口后 Webmail 无法发信的问题.
11. 解决了使用DNS纪录缓存后无法发信到某些域的问题.
12. 解决了升级安装时WebMail 脚本出错的问题.

Version 2.3(2003/04/02)

1. 新增快速设置向导工具, 让您一分钟内设置好邮件系统.
2. 新增直接用邮件客户端打开邮件队列里邮件的功能.
3. WebMail 新增在线注册新邮箱的功能.
4. WebMail 的 HTML 编辑器新增插入表格,Image链接和Flash链接的功能.
5. 优化了 WebMail 性能, 运行速度更快.
6. 解决了在特殊设置时 WebMail 无法使用的问题.
7. 解决了 WebMail 日期格式显示错位的问题.
8. 解决了 WebMail 多域时无法正常使用的问题.
9. 未注册版本可加入的邮箱数增加到20个.
10. 解决了多附件邮件格式处理有误的问题.
11. 解决了外发权限控制不严格的问题.
12. 解决了开机自动运行无法关闭的问题.
13. 修改了其它一些小问题; 改变了一些提示写法.

Version 2.02(2003/03/04)

1. 全功能多语言Webmail, 可以在网页上收发邮件.
2. 增强邮件杀毒功能, 可支持内嵌API在内三种模式, 支持几乎所有的杀毒引擎.
3. 增强邮件监控功能, 被监控邮箱和监控人邮箱可以任意组合.
4. 增加邮件备份功能, 可以将所有发送的邮件本域内或外域外的邮件备份到指定邮箱.
5. 用户邮箱自动转发可设置保留备份.
6. 增加用户邮箱不成功的提示信息更加清楚明确.
7. 可以设置smtp外发超时时间和邮件网关中POP3接收外部邮件的超时时间.
8. 定时任务可以设置有效或禁用.
9. 增加对防垃圾邮件功能 RBL(Real-time Blackhole Lists) 支持.
10. 增加DNS 缓冲功能, 让外发邮件更迅速.
11. 解决了SMTP发信快结束时变慢的问题.
12. 解决了有些系统上CPU占用超过90%的问题.
13. 解决了老的系统日志无法清除的问题.

Version 1.22(2003/01/16)

1. SMTP 认证可以设置检查认证用户和发件人字段一致.
2. 外发服务器的验证用户名可以包含 "@" 符号.
3. 改正POP3下载和域属性里的"本域中不存在的邮箱发送到Internet"可以出现的循环问题.
4. 改正了发送回退信提示不明确的问题.
5. 在防毒功能中增加超时控制.
6. 优化安装包,使其更小.

Version 1.20(2003/01/08)

1. 新增邮件队列病毒扫描功能,用户可以选择多种扫毒引擎
2. 可以手工设置两个DNS服务器
3. 获取MX记录时超时处理
4. 检查最新版本时显示版本变动信息
5. 将启动失败信息写到系统事件中
6. 控制单个用户发外部邮件和收外部邮件的权限
7. 修正发信到Hotmail.com出现异常BUG
8. 修正邮件网关/POP3下载按信头分拣BUG
9. 修正邮箱监控部分特殊信无法监控的BUG

Version 1.04(2002/11/29)

1. 可以监控被监控邮箱的所有收到和发出邮件
2. 管理程序通过SSL加密协议和服务器通信，所以 1.04 不能和 1.02通讯
3. 修正了一些BUG：发信到邮件组、修改邮件组等等
4. 增加了检查最新版本功能
5. 修改用户功能显示用户已用空间、用户自设POP3
6. 管理工具的界面和程序图标美化调整
7. 支持Windows 95 和 97
8. 增加简体中文安装程序

Version 1.02 (2002/11/01)

1. SMTP/ESMTP
2. POP3
3. NT域认证
4. 用户和用户别名
5. 邮件组
6. 域和域别名
7. 邮件网关: POP3、ETRN
8. 远程控制: 设置用户POP3、设置自动转发、设置自动回复
9. 过滤和监控
10. 计划任务
11. 日志


注册购买与升级

Winmail Server是一款共享软件，任何人都可以免费下载使用，注册前可以使用90天， 支持 20 用户 5 个域名。
如果想获得更多用户数和及时的技术支持，请购买注册本软件，购买可以让我们更好地改进我们的产品。

有关注册购买的详细信息请到 http://www.winmail.cn/register.php
有关本软件的最新版本升级信息请到 http://www.winmail.cn


联系我们

关于我们

Winmail 由华美科技（苏州）有限公司于2002年发布 1.0 版本，2020 年 1 月成立了专门的 Winmail 产品公司苏州华兆科技有限公司， 华兆科技将专注核心业务，秉承工匠精神，成为一个小而专的科技公司，秉承诚实守信，重合同守信用，成为中小型邮件系统解决方案的领导者。

联系我们

日常联系: webmaster@winmail.cn (负责处理日常事务、建议、意见)
技术支持: support@winmail.cn (负责处理有关安装、 使用、BUG等技术的问题)
注册服务: register@winmail.cn (负责处理所有和销售有关事项)
更详细的联系方式请访问 Winmail 简体中文主站: https://www.winmail.cn


常见问题

请访问 http://www.winmail.cn/faq.php 查看网站上更全的常见问题

安装相关问题
安装完毕一定要重新启电脑吗？
版本升级会影响原有数据吗？怎样升级？
安装后，为什么总是不能启动SMTP/POP3/ADMIN/HTTP/IMAP/LDAP服务？
安装后，为什么邮件系统启动不成功？
安装后，除了ADMIN 服务启动，其他服务都停止？
我的操作系统需要重新安装，如何保留 Winmail 的设置和数据？
我的邮件系统要迁移到新的服务器上，如何移植 Winmail 的设置和数据？

注册相关问题
注册版有什么不同？
我给您们汇款后，多久可以收到注册码？

使用与设置相关问题
1) 发邮件问题
Winmail 中 SMTP 服务启动了，但无法发送邮送呢？
我的邮件系统能收不能发，请问可能是什么原因呢？
为什么我向外部（英特网）邮箱发信总是失败？
我用Outlook 和 Foxmail 发信总是提示 550 5.7.1 Unable to relay for xyz@abc.com，怎样解决？
我用Outlook 和 Foxmail 发信到其它域总是提示 '553 sorry, your don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)，怎样解决？
在 Outlook 已设定了"我的服务器需要验证", 但发信时, 仍出现 550 5.7.1 Unable to relay for <company.com>
邮件服务器设置了SMTP发信认证，为什么非法用户一样可用本邮件服务器的SMTP发信？
为何总是运行不稳定，有时向外发信有好几小时的延迟？
我的邮件系统，被其他人用来转发！怎么解决？
在没有域名及没有固定IP的情况下，本软件可不可以外发邮件？有没有什么好的解决办法？
我用SMTP协议通过 Winmail 邮件服务器发信，如果地址中使用了不存在的域名或者帐号，有什么提示？
为什么我在用邮件客户端收、发信时，总是出现“无法连接到服务器。 套接字错误: 10061"的错误？
为什么服务器上安装了瑞星防毒程序后不能正常收发邮件？
我已经开启了发信认证，为什么有时候发邮件不需要认证？

2) 收邮件问题
我可以向外部发送邮件，使用非SMTP标准端口（25），但无法收取外部邮件？
本地能正常收发，能发给外域，但外域发过来不能收到，问题出现在哪里？
邮件系统装在内部网中（如：IP是192.168.x.x），有外IP是202.x.x.x（固定），现在可以发邮件，但不能收邮件，怎样设置才能收到邮件？
为什么收不到外部信箱（如：yahoo.com 或 hotmail.com）发给我的邮件？
为什么我的 Winmail 装上以后，在远程邮件客户端使用 POP3 收信总是说密码错误，而无法收信？
用 Outlook 2002 收信会出现停止响应的现象，怎样解决？
接收邮件的附件是 winmail.dat，无法打开，请问如何解决？
为什么我在用邮件客户端收、发信时，总是出现“无法连接到服务器。 套接字错误: 10061"的错误？
为什么服务器上安装了瑞星防毒程序后不能正常收发邮件？

3) 域名和DNS问题
能不能告诉我几个能用的DNS服务器地址？
在Windows 98 和拨号上网的服务器出现系统DNS找不到的问题，怎样解决？
我有多个域名 aaa.com, bbb.com, ccc.com，能够实现一个用户 user 可以对应于所有域名？
怎样申请动态DNS服务（可以方便架设ADSL互联网邮件服务器）？
是否一定要申请域名并解析才能通过INTERNET收发邮件？
如何查找域名的 MX 记录是否正确？
如果判断我的邮件服务是否已经开启发信认证？

4) 管理工具相关
网络是通的，输入的密码也是对的，我的管理端为什么连不上服务器？
邮件服务器管理员密码丢失后怎么办？

5) 邮件系统架设问题
申请了企业邮局之后，是否还有必要设置邮件服务器吗？
我们公司现在有自己的域名和企业邮箱，但现在自己建一个邮件系统。我想问的是能不能添加两条MX记录，使同一封信可以转到两个不同的邮件系统？
由于公司是通过FTTP＋Lan方式上网的，具体怎样来设置呢？
Mail服务器是否可以和用于拨号上网的服务器分开？

6) 日常维护问题
 如何手工对邮件系统的数据进行备份？
邮件服务器是否支持帐号权限控制？例如，只能收不能发；收发的email能否自动在服务器上保存并备份？
 我的邮件系统被人作为垃圾邮件服务器，现在已设SMTP认证，但队列中有上万封垃圾邮件，请问怎么删除？
别人发给我的信是存放到哪里的？能不能长期存放？
如何设置才能将服务某个特定网段的用户使用？
可否禁止使用TELNET 25 或 TELNET 110？ 如可以TELNET 25，可否禁止支持EXPN及VRFY？

7) 其它问题
为什么服务器上安装了诺顿 Norton 防毒程序后 Winmail 有时会自动关闭？
在服务器上安装该软件，服务器配置正常。服务器有一块网卡，两个地址，如何让两个地址都能正常使用？
Winmail 是否支持自由申请，以及申请确认。
RBL 是什么？
服务程序的注册和注销命令是什么？
Winmail 和防火墙配合

8) 错误回弹信分析
如何根据错误回弹信发现出错原因？
常见的错误回弹信
发到 sina.com 的邮件会被退回
发到 tom.com 的邮件会被退回
发到 aol.com 的邮件会被退回
收到退信错误提示为"554 5.7.1 Rejected xxx.xxx.xxx.xxx found in dnsbl.sorbs.net"，怎么办？

Webmail 相关问题
 我想在我们主页上加入 Webmail 的登陆栏，如何实现？
如何更改 Webmail 发出邮件的底部签名？
我想更换 Webmail 的 LOGO 图片、 广告图片和提示信息，如何实现？
我可以使用 http://mymailserver:6080 登陆 Webmail。如何换成 http://mymailserver登陆？
多域名时，WebMail 登陆页面用户要选择自己的域很不方便，怎样解决？
怎样在 WebMail 登陆页面加自由申请功能？
Webmail 设置到 IIS 中无法修改口令和设置自动转发等参数, 怎样解决？
Webmail 设置到 IIS 中无法上传附件, 怎样解决？
Webmail 设置到 IIS 中, 页面出错, 怎样解决？
为什么当我在 Webmail 登陆时会出现“create com instance error”的提示？
Webmail 使用中, 显示" Can't contact LDAP server" 出错, 怎样解决？
使用 WebMail 发信时，提示"SMTP Error:could not connect to SMTP host server(s)" 错误怎么办？
使用 WebMail 发信时，提示"SMTP Error: Data not accepted，552 sorry， the message size exceeds databytes limit (#5.3.4)"错误怎么办？
我想让 Webmail 退出和错误返回到指定的网页，如何实现？
如何开启与关闭 Webmail 自动登录功能？
如何开启与关闭 Webmail 取回密码功能？
设置用自己安装的 PHP 程序后，Webmail 不能正常使用，怎么解决？
如何在我的系统中能取得用户新邮件数？
如何在我的系统中嵌入Webmail，以实现列邮件夹列表，读邮件，写邮件等工作？
怎么禁止修改界面风格和设定默认界面风格？


常见问题

安装相关问题
安装完毕一定要重新启电脑吗？
版本升级会影响原有数据吗？怎样升级？
安装后，为什么总是不能启动 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 服务？
安装后，为什么邮件系统启动不成功？
安装后，除了ADMIN 服务启动，其他服务都停止？
我的操作系统需要重新安装，如何保留 Winmail 的设置和数据？
我的邮件系统要迁移到新的服务器上，如何移植 Winmail 的设置和数据？
请访问 http://www.winmail.cn/faq.php 查看网站上更全的常见问题

注册相关问题
注册版有什么不同？
我给您们汇款后，多久可以收到注册码？

安装完毕一定要重新启电脑吗？ ↑
如果安装结束后不提示则不需要重启即可使用。在老版本上升级建议重启。

版本升级会影响原有数据吗？怎样升级？ ↑
在安装新版本时选择保留数据(leave)，则可以继续使用原有数据和系统设置参数。当然为保险起见， 可以在升级前备份一下 Winmail Server 的全部文件。详细安装说明请参考软件帮助文件。 升级步骤: 1. 退出winmail; 2. 运行新的安装包; 3. 选择保留数据; 4. 重新启动服务器.

安装后,为什么总是不能启动 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 服务？ ↑
出现上述情况可能会是以下几个问题：
    一、SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 启动不成功（“系统设置”/“系统服务”所显示的列表中，SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 行首是图标是红色的，用telnet连接25/110/6000/6080/143/389 看没有响应，如：POP3 则telnet xxx.xxx.xxx.xxx 110）
     1.首先您要确定您的 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 端口没有被占用（用aports　http://www.winmail.cn/download_other.php 查看正在使用此端口的程序）。如果已经占用请停用占用端口的程序，或者更换端口。
     2.“系统设置”/“系统服务”中，选中 SMTP/POP3/HTTP/IMAP/LDAP 行点击“启动”按钮。
     3.看一下“系统日志”/“SYSTEM”的启动LOG中有关 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 的启动信息。
     4.如果SMTP/POP3/ADMIN/HTTP启动正常，但本系统启动时，SMTP/POP3/HTTP/IMAP/LDAP 不能自动启动。请在“系统设置”/“系统服务”中，选中POP3行点击“设置”按钮，将“本系统启动时自动运行”选中。
    如果以上操作还不能正常启动，请更改POP3设置中的端口，再重新启动。看是否能正常运行。
    二、SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 启动成功，而正常工作（“系统设置”/“系统服务”所显示的列表中，SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 行首是图标是绿色的）
     1.“系统设置”/“系统服务”中，选中SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 行点击“设置”按钮。
     2.查看本服务绑定的IP（不要用127.0.0.1，而应用您的网卡IP，或是0.0.0.0）和端口、超时时间以及存取控制。
     3.“系统设置”/“系统服务”中，选中 SMTP/POP3/HTTP/IMAP/LDAP 行点击“停止”按钮，然后点击“启动”按钮。

安装后，为什么邮件系统启动不成功？ ↑
出现这种情况，可能是以下情况：
1. ADMIN 服务端口(端口号为6000)被占用，请按“安装后,为什么总是不能启动 SMTP/POP3/ADMIN/HTTP/IMAP/LDAP 服务？”查看 ADMIN 服务端口是否占用。
2. 注册码无效，试用过期或机器时间不对。
3. 数据库或系统配置文件出错。

安装后，除了ADMIN 服务启动，其他服务都停止？ ↑
出现这种情况，可能是以下情况：
1. 注册码无效，试用过期或机器时间不对。
2. 各服务端口被占用。
3. 安装了多次，每次安装方式不一致，需要先卸载后，重新安装。

我的操作系统需要重新安装，如何保留 Winmail 的设置和数据？ ↑
1. 备份Winmail Server安装目录( 默认是在C:\Program Files\Magic Winmail，可自定义 )，邮件存放目录( 默认是在C:\Program Files\Magic Winmail\server\store，可自定义 );
2. 重新安装操作系统;
3. 将备份的2个文件夹复制回原来的存放路径: Winmail Server 安装目录( 默认是在C:\Program Files\Magic Winmail，可自定义 )，邮件存储目录( 默认是在C:\Program Files\Magic Winmail\server\store，可自定义 );
4. 重新安装 Winmail Server，安装路经选择之前 Winmail Server 安装目录( 默认是在C:\Program Files\Magic Winmail，可自定义 );安装过程中提及"当配置文件已存在时"选择"保留原有配置";安装完成后进入Winmail Server管理工具，在 高级设置->系统参数->邮件存储 目录设置为之前的邮件存储目录路径。

我的邮件系统要迁移到新的服务器上，如何移植 Winmail 的设置和数据？ ↑
1. 备份Winmail Server安装目录( 默认是在C:\Program Files\Magic Winmail，可自定义 )，邮件存放目录( 默认是在C:\Program Files\Magic Winmail\server\store，可自定义 );
2. 将备份的2个文件夹复制到新的邮件服务器上，( 例如存放在默认的安装目录C:\Program Files\Magic Winmail下 );
3. 在新的邮件服务器上运行Winmail Server安装包，安装路经选择之前Winmail Server安装目录;安装过程中提及"当配置文件已存在时"选择"保留原有配置";安装完成后进入Winmail Server管理工具，在 高级设置->系统参数->邮件存储 目录设置为之前的邮件存储目录路径。

注册版有什么不同？ ↑
软件使用没有时间限制
服务期内免费升级
支持更多用户
服务期内获得免费、及时的Email技术支持
新版本发布通知

注册版有什么不同？ ↑
我们收到凭证传真或确认到帐（网上汇款）后，会在半小时内将注册码通过邮件先发给您。如果下午4：30之前完成的，发票、注册授权书当天通过快递寄出，否则第二个工作日寄出。


常见问题

请访问 http://www.winmail.cn/faq.php 查看网站上更全的常见问题

使用与设置相关问题
1) 发邮件问题
Winmail 中 SMTP 服务启动了，但无法发送邮送呢？
我的邮件系统能收不能发，请问可能是什么原因呢？
为什么我向外部（英特网）邮箱发信总是失败？
我用Outlook 和 Foxmail 发信总是提示 550 5.7.1 Unable to relay for xyz@abc.com，怎样解决？
我用Outlook 和 Foxmail 发信到其它域总是提示 '553 sorry, your don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)，怎样解决？
在 Outlook 已设定了"我的服务器需要验证", 但发信时, 仍出现 550 5.7.1 Unable to relay for <company.com>
邮件服务器设置了SMTP发信认证，为什么非法用户一样可用本邮件服务器的SMTP发信？
为何总是运行不稳定，有时向外发信有好几小时的延迟？
我的邮件系统，被其他人用来转发！怎么解决？
我用SMTP协议通过 Winmail 邮件服务器发信，如果地址中使用了不存在的域名或者帐号，有什么提示？
为什么我在用邮件客户端收、发信时，总是出现“无法连接到服务器。 套接字错误: 10061"的错误？
为什么服务器上安装了瑞星防毒程序后不能正常收发邮件？
我已经开启了发信认证，为什么有时候发邮件不需要认证？

2) 收邮件问题
我可以向外部发送邮件，使用非SMTP标准端口（25），但无法收取外部邮件？
本地能正常收发，能发给外域，但外域发过来不能收到，问题出现在哪里？
邮件系统装在内部网中（如：IP是192.168.x.x），有外IP是202.x.x.x（固定），现在可以发邮件，但不能收邮件，怎样设置才能收到邮件？
为什么收不到外部信箱（如：yahoo.com 或 hotmail.com）发给我的邮件？
为什么我的 Winmail 装上以后，在远程邮件客户端使用 POP3 收信总是说密码错误，而无法收信？
用 Outlook 2002 收信会出现停止响应的现象，怎样解决？
接收邮件的附件是 winmail.dat，无法打开，请问如何解决？
为什么我在用邮件客户端收、发信时，总是出现“无法连接到服务器。 套接字错误: 10061"的错误？
为什么服务器上安装了瑞星防毒程序后不能正常收发邮件？

3) 域名和DNS问题
能不能告诉我几个能用的DNS服务器地址？
我有多个域名 aaa.com, bbb.com, ccc.com，能够实现一个用户 user 可以对应于所有域名？
怎样申请动态DNS服务（可以方便架设ADSL互联网邮件服务器）？
是否一定要申请域名并解析才能通过INTERNET收发邮件？
如何查找域名的 MX 记录是否正确？
如果判断我的邮件服务是否已经开启发信认证？

4) 管理工具相关
网络是通的，输入的密码也是对的，我的管理端为什么连不上服务器？
邮件服务器管理员密码丢失后怎么办？

5) 邮件系统架设问题
申请了企业邮局之后，是否还有必要设置邮件服务器吗？
我们公司现在有自己的域名和企业邮箱，但现在自己建一个邮件系统。我想问的是能不能添加两条MX记录，使同一封信可以转到两个不同的邮件系统？
由于公司是通过FTTP＋Lan方式上网的，具体怎样来设置呢？
Mail服务器是否可以和用于拨号上网的服务器分开？

6) 日常维护问题
 如何手工对邮件系统的数据进行备份？
邮件服务器是否支持帐号权限控制？例如，只能收不能发；收发的email能否自动在服务器上保存并备份？
 我的邮件系统被人作为垃圾邮件服务器，现在已设SMTP认证，但队列中有上万封垃圾邮件，请问怎么删除？
别人发给我的信是存放到哪里的？能不能长期存放？
如何设置才能将服务某个特定网段的用户使用？
可否禁止使用TELNET 25 或 TELNET 110？ 如可以TELNET 25，可否禁止支持EXPN及VRFY？

7) 其它问题
为什么服务器上安装了诺顿 Norton 防毒程序后 Winmail 有时会自动关闭？
在服务器上安装该软件，服务器配置正常。服务器有一块网卡，两个地址，如何让两个地址都能正常使用？
Winmail 是否支持自由申请，以及申请确认。
RBL 是什么？
服务程序的注册和注销命令是什么？

8) 错误回弹信分析
如何根据错误回弹信发现出错原因？
常见的错误回弹信
发到 sina.com 的邮件会被退回
发到 tom.com 的邮件会被退回
发到 aol.com 的邮件会被退回
收到退信错误提示为"554 5.7.1 Rejected xxx.xxx.xxx.xxx found in dnsbl.sorbs.net"，怎么办？

9) Winmail 和杀毒引擎软件
Winmail 和杀毒引擎
Winmail 和诺顿防毒
Winmail 和瑞星防毒
Winmail 和金山毒霸
Winmail 和江民 KV 防毒
Winmail 和McAfee防毒
Winmail 和趋势防毒
Winmail 和AVG防毒
Winmail Server和朝华安博士防毒
Winmail 和卡巴斯基(Kaspersky/AVP)防毒
Winmail 和熊猫卫士防毒(Panda)

Winmail 中 SMTP 服务启动了，但无法发送邮送呢？ ↑
出现上述情况是主要是SMTP参数设置不正确。一般是SMTP服务器设置要求发信认证，而客户端发信工具没有设置发信认证。这种情况 Outlook 的错误提示包含: 服务器响应: '553 sorry, your don't authenticate and the domain isn't in my list of allowed rcpthosts(#5.7.1)' . 还有一种情况是服务器上安装了瑞星防毒程序, 邮件服务器上不要打开瑞星的邮件监控功能，这样会带来无法发送邮件问题, 具体说明请看下面的FAQ。

我的邮件系统能收不能发，请问可能是什么原因呢？ ↑
1. 首先要确定您的机器能不能正确的连接到外面的主机。在命令行方式下执行如下命令：
C：> telnet mx.mail.163.com 25
220 Welcome to coremail System(With Anti-Spam) 2.1 for 163.com
C：> telnet sinamx.sina.com.cn 25
220 sina.com ESMTP
如果能见到上述住处就表示能正常连接，否则表示不能正常连接。
2. 您的机器上没有安装一些邮件防火墙软件。如果用了请停止。因为邮件防火墙软件，会接管SMTP、POP3端口，请邮件系统不能正常工作。 如果用了瑞星，请见：邮件服务器与瑞星防火墙整合
3. 可能是DNS Server不正确，请用管理工具登录邮件系统后，在“系统设置”-》“高级设置”-》“系统参数”，在“DNS设置”属性页中，选择“使用下面的DNS服务器地址”，并在“首先DNS服务器”和“备用DNS服务器”中，增加当地的dns服务器地址，然后“应用”。 如果您不能确定当地的DNS地址，也可以用 Google 的DNS: 8.8.8.8 和 8.8.4.4。

为什么我向外部（英特网）邮箱发信总是失败？ ↑
一、在绝大部分情况下对外部（英特网）邮箱发信失败都是因为DNS设置不当引起的。您可以在服务器上点击右下角图标，然后在弹出菜单中选取“服务”项后查看所设置的DNS服务器地址。您需确认：
1) 是否设置有DNS服务器地址。
2) 所设置的DNS服务器地址是否是有效的。
3) 此DNS服务器是否正常工作。
4) 如果使用默认的DNS服务，要确定可以进行正常DNS解析
二、系统安全设置或防火墙的设置造成无法对外进行UDP通讯引起的
解决办法：允许UDP包通过。

我用Outlook 和 Foxmail 发信总是提示 550 5.7.1 Unable to relay for xyz@abc.com，怎样解决？ ↑
这儿提示信息不是 Winmail 的, 可能是IIS自带smtp服务器的信息, 请进入IIS管理程序停止它的smtp服务器, 然后重新启动 Winmail 的smtp服务。彻底停止请到系统服务设置里将 "Simple Mail Transport Protocol (SMTP)"的启动类型设为"手动"或"已禁用"。

我用Outlook 和 Foxmail 发信到其它域总是提示 '553 sorry, your don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)，怎样解决？ ↑
您的SMTP服务器设置要求发信认证，而客户端发信工具没有设置发信认证, 请设置。

在 Outlook 已设定了"我的服务器需要验证", 但发信时, 仍出现 550 5.7.1 Unable to relay for (New) ↑
1) Telnet yourserverip 25 , 出现 220 ******************************************
2) 输入 EHLO 命令, 出现 502 unimplemented (#5.5.1)
3) 前端使用Cisco PIX 防火墙

此为Cisco PIX 內建的 MailGuard 或 MailHost 阻挡了 ESMTP 的指令 (如EHLO)
请关掉 Mail Guard 功能或与防火墙供应商联系。
请查考 Winmail 和防火墙配合

邮件服务器设置了SMTP发信认证，为什么非法用户一样可用本邮件服务器的SMTP发信？ ↑
发信时不需要认证的情况：
1) 发邮件主机的地址在“信任主机”列表中；
2) 收件人的地址所属域在本系统的域名，域别名或“直接递送域”列表中。

为何总是运行不稳定，有时向外发信有好几小时的延迟？ ↑
建议您检查以下几个方面：
1. 网络状况。
2. DNS解析的情况。
3. 保证没有尺寸很大的邮件，导致处理速度慢。
4. 保证邮件服务器没有被别人用来转发邮件。

我的邮件系统，被其他人用来转发！怎么解决？ ↑
请开始服务器的SMTP认证功能。用管理工具登录邮件系统，“系统设置”-》“SMTP设置”, 在“基本参数”属性页，选中“启用发信认证”选项。然后点击“应用”。

在没有域名及没有固定IP的情况下，本软件可不可以外发邮件？有没有什么好的解决办法？ ↑
即使在没有注册域名及没有固定IP的情况下，只要能连接到INTERNET就，本系统一样可以往外发邮件，但是可能会收不到从外域发过来的邮件。
如果是ADSL上网用户，可以有申请动态域名，来实架构邮件服务器。具体请见我们的资料：http://www.winmail.cn/technic_dnip.php

我用SMTP协议通过 Winmail邮件服务器发信，如果地址中使用了不存在的域名或者帐号，有什么提示？ ↑
该邮件在指定时间里如果没有被发送出去的话，会被退回给发信人（并在退信中提示是向哪个地址发送邮件时失败的），而在当时是没有提示的。

为什么我在用邮件客户端收、发信时，总是出现“无法连接到服务器。 套接字错误: 10061”的错误？ ↑
1) IP地址设置错误：在邮件客户端软件中设定的POP3以及SMTP服务器的ip地址，不是当前正在运行的Winmail服务器的IP地址；
2) 端口号设置错误：在邮件客户端软件中设定的POP3以及SMTP服务的端口号错误；
3) Winmail的服务程序没有被运行（您可以查看系统进程中是否有mailserver.exe）。

为什么服务器上安装了瑞星防毒程序后不能正常收发邮件？ ↑
邮件服务器上不要打开瑞星的邮件监控功能，这样会带来无法收发邮件问题, 具体设置是: 打开瑞星的管理程序, 选择菜单"选项"/"设置", 在"计算机监控"设置页面, 不要选择"开机时启动邮件监控", 注意必须重新启动电脑才能生效。
再关闭瑞星的邮件监控后, Winmail 可以和瑞星配合使用, 不过还有进行以下设置: 打开瑞星的管理程序, 选择菜单"选项"/"设置", 在"计算机监控"设置页面, 选择"开机时启动文件监控", 再选择"高级设置", 打开"杀毒设置"窗口, 在"发现病毒后处理方式"选择"删除文件", 在"发现清除失败后处理方式"选择"忽略"; 注意必须重新启动电脑才能生效。 然后在 Winmail 的"防病毒设置"选择"病毒防火墙"模式。 不过需要注意的是在打开瑞星的管理程序时, 瑞星的防护功能无效, 而且正常使用时瑞星的防护功能也可以失效。
详细设置请看 Winmail 和瑞星防毒

我可以向外部发送邮件，使用非标准的SMTP端口（25），但无法收取外部邮件？ ↑
如果SMTP用非标准的25端口肯定是收不到外面发来的邮件的。其它邮件服务器发邮件给您的邮件服务器时，不知道您SMTP服务器现在采用什么端口，默认还是连接的邮件服务器的SMTP服务默认端口25，所以连接就不可能成功，也就自然收不到外域发来的邮件。如果您的邮件服务器要与其它邮件服务器进行交换邮件，就不能更改SMTP服务器的端口。

本地能正常收发，能发给外域，但外域发过来不能收到，问题出现在哪里？ ↑
如果您收发本地的邮件正常，信发往外部邮件系统也可以，可能是以下情况引起：
1. 您没有公网的地址，外部邮件系统连不到您的服务器或服务器的SMTP (25) 端口拒绝外部访问；
2. 您所用的域名是否是已经注册过的域名, 域名及此域名的邮件交换记录（MX）记录有没有DNS解析名, MX是否已经指向到您现在的邮件服务器的主机地址。如果不是请与您的域名服务商联系, 请他们帮助设好DNS和将MX记录指向您的邮件服务器。有关域名和MX记录的技术资料，可以参考相关的书籍，或是通过搜索引擎寻找相关网页，我们的网站上也有一些资料。
3. 您的机器上有没有安装一些邮件防火墙软件。如果安装了请停止。因为邮件防火墙软件，会接管SMTP、POP3端口，让邮件系统不能正常工作。
4. 还有请确定您的域名是否到期。

邮件系统装在内部网中（如：IP是192.168.x.x），有外IP是202.x.x.x（固定），现在可以发邮件，但不能收邮件，怎样设置才能收到邮件？ ↑
1、要申请一个域名。要能收信一般需要一个顶级域名（可在www.net.cn等网站上申请）；如果觉得成本较高可以也采用动态域名。域名相关知识、动态域名的相关知识
2、如果是代理服务器上网的话，可在代理服务器上做NAT映射，也即将202.x.x.x（固定）地址的25，110，6080的端口映射到装邮件服务器的IP是192.168.x.x上。具体请见“Magic Winmail 邮件服务器与代理服务器软件配合方案”；如果是路由器上网，也可必须设置端口（NAT）映射的，您可以找一下您所用路由器的型号相关的配置的说明书或文章。
3、如果采用的是顶级域名，还需要设置域名的MX（Mail eXchange，邮件交换记录）使用指向到您安装邮件服务器的INTERNET上的地址。这步操作可以与您的域名服务商联系。

为什么收不到外部信箱（如：yahoo.com 或 hotmail.com）发给我的邮件？ ↑
成功接收来自Internet的邮件必须要做到以下条件：
1.要拥有Internet上的有效域名。（如：www.domain.com）
2.可成功将此域名解析到安装 Winmail 服务器的IP地址。
3.在 Winmail 中增加一个邮件域名：domain.com，相对应的用户邮件地址为：username@domain.com
如果以上工作你都做了而仍然收不到邮件时，最大的可能性就是您的域名解析出现了问题，请做以下测试。假设你的邮件地址是: username@domain.com，请：
确认domain.com的MX记录被指向了正确的地址；（可使用nslookup命令进行查询）
nslookup命令的使用方式，mail exchanger = mail.nsmc.edu.cn内容就是nsmc.edu.cn域名的MX记录指向的真实地址

C:\> nslookup

Server: dns.nsmc.edu.cn
Address: 211.83.0.66
>set type=mx
>nsmc.edu.cn (输入您想解析的邮件地址中“@”符号后的域名)
Server: dns.nsmc.edu.cn
Address: 211.83.0.66
nsmc.edu.cn　　　　preference = 10, mail exchanger = mail.nsmc.edu.cn
smc.edu.cn　　　　nameserver = dns.nsmc.edu.cn
mail.nsmc.edu.cn　　　　internet address = 211.83.0.67
dns.nsmc.edu.cn internet address = 211.83.0.66

>exit

C:\>

您在得到了 mail exchanger = mail.nsmc.edu.cn 信息后，请使用：
C:\> telnet mail.nsmc.edu.cn 25
命令以确认安装在此机器上的 Winmail 服务程序可以正常工作。

为什么我的 Winmail装上以后，在远程邮件客户端使用pop3收信总是说密码错误，而无法收信？ ↑
1) 没有在Winmail中添加该用户或添加了该用户但密码和邮件客户端的设定不相同；
2) 端口冲突：因为Winmail使用了标准的smtp端口（端口：25）和pop3端口（端口：110），所以如果您运行Winmail的机器上已经占用了这两个主要端口时（如：已经架设有其他的邮件服务器，MS Exchange 或 Windows 内置的smtp服务等），将会造成 Winmail 无法正常运行
3) 如果您将Winmail装在拨号服务器上时，有可能会因为同时启动了WinGate程序而占用了Winmail需要的110和25两个端口，从而导至Winmail无法正常提供服务。
解决办法：停止其他的邮件服务器的服务或关闭其他占用smtp及pop3端口的应用程序，或者开放WinGate的25和110两个端口。
4) 非主域的用户在Outlook或Foxmail设置中用户名时要用写全地址，如在一个非主域 abc.com 中的用户 test 的用户名要写成 test@abc.com。

用 Outlook 2002 收信会出现停止响应的现象，怎样解决？ ↑
这是Microsoft的bug, 请看 http://support.microsoft.com/default.aspx?scid=kb;EN-US;Q329349? , http://support.microsoft.com/?kbid=331866

接收邮件的附件是 winmail.dat， 无法打开，请问如何解决？ ↑
winmail.dat 是 Microsoft Outlook 发的 RTF 格式文件, 只能由Outlook打开。 解决的办法一是 在Outlook设置不用 RTF 格式发邮件。 二是将winmail.dat另存, 用其它工具打开, 我们网站上有一个名为 wmopener 的工具可以展开这种附件(下载); 有关 winmail.dat 资料可以参见： http://www.ust.hk/itsc/email/tips/tnef/ 。从2.4版开始增加将 MS-TNEF (winmail.dat) 类型附件自动剥离功能, 您可以到“SMTP设置”功能里设置启用该功能。 从3.6版开始Webmail 增加将MS-TNEF (winmail.dat) 类型附件自动剥离功能。

能不能告诉我几个能用的DNS服务器地址？ ↑
直接询问本地ISP服务提供商，也可以用 Google 的DNS: 8.8.8.8 和 8.8.4.4。

我有多个域名 aaa.com, bbb.com, ccc.com，能够实现一个用户 user 可以对应于所有域名？ ↑
可以配置域的别名。

怎样申请动态DNS服务（可以方便架设ADSL互联网邮件服务器）？ ↑
国内用户可以到 http://www.88ip.com 网站申请这些域名解析服务。需要在服务器上安装一个88ip的客户端软件，就可以了。

是否一定要申请域名并解析才能通过INTERNET收发邮件？ ↑
邮件系统一般都要和其他邮箱进行收发邮件，所以要有一个确定的域名。如果仅是内部使用，则可以不要申请域名。

网络是通的，输入的密码也是对的，我的管理端为什么连不上服务器？ ↑
出现上述情况可能是:
1. 管理端的版本要和服务器端的版本不一致。
2. 可能是您通过防火墙联接，但是防火墙没有开放 Winmail 管理端口，管理端口缺省是6000，当然您可以改成其它。

邮件服务器管理员密码丢失后怎么办？ ↑
将server安装目录下的 adminuser.cfg 文件用记事本打开(对于 Winmail 4.3 以前的版本，修改 userauth.cfg 文件; 4.9 以后版本修改 data/adminuser.cfg)，将如下内容
<adminuser>
<item>
<username>admin</username>
<password>{md5}21232f297a57a5a743894a0e4a801fc3</password>
</item>
</adminuser>
修改为
<adminuser>
<item>
<username>admin</username>
<password>newpassword</password>
</item>
</adminuser>
然后就可以使用新密码（newpassword)等录，登录进管理端后要及时更改管理员密码。

申请了企业邮局之后，是否还有必要设置邮件服务器吗？ ↑
申请了企业邮局，可以不设置邮件服务器，也可以架设自己的邮件服务器。
架设自己的邮件服务器的情况，有以下几种：
1. 不是所有人都开设企业邮局的帐号。如：主管级以上人员开设外部帐号，大多员工使用内部邮件帐号。
2. 上网条件比较差，不能永久连接INTERNET。

我们公司现在有自己的域名和企业邮箱，但现在自己建一个邮件系统。我想问的是能不能添加两条MX记录，使同一封信可以转到两个不同的邮件系统？ ↑
您可以架设好新的邮件系统，同时创建好所有的新邮箱，在非工作日的晚上，将MX指向到新的邮件服务器。所有发过来的信都会自动发到新的邮箱中去。 这时候老的企业邮箱的信还是可以继续用OUTLOOK，Foxmail来接收。只是不能收到外域邮件系统递送来的信，所有外域发来信都发到了新的邮箱去了。

由于公司是通过FTTP＋Lan方式上网的，具体怎样来设置呢？ ↑
请参见“系统应用方案”

Mail服务器是否可以和用于拨号上网的服务器分开？ ↑
不一定要装在拨号上网服务器上，可以装在局域网内其它能访问INTERNET的机器上。具体请见“Magic Winmail 邮件服务器与代理服务器软件配合方案”。

如何手工对邮件系统的数据进行备份？ ↑
目前本系统本身没有提供备份功能，计划在以后的版本中增加此功能。目前您可以根据实际情况，用操作系统的计划任务进行备任。具体方法如下：
1.备份邮箱账号：可以将~/server目录下所有后缀后为.cfg的文件（4.9以后版本备份 ~/server/data/ 目录），定时（设置操作系统的计划任务）拷贝到其它目录中。
2.备份用户邮件：可以将~/server/store目录打包后，定时（设置操作系统的计划任务）拷贝到其它目录中。
3.全备份：可以将~/server目录打包后，定时（设置操作系统的计划任务）拷贝到其它目录中。
上述~指的是安装时选择的系统安装到的目录。默认为：C:\Program Files\Magic Winmail

邮件服务器是否支持帐号权限控制？例如，只能收不能发；收发的email能否自动在服务器上保存并备份？ ↑
本邮件系统的可以对帐号设置权限，如不能发邮件到外域，不能接收外域发来的邮件等。同时所有邮件也能自动备份到某一帐号或被某一管理员监控。

我的邮件系统被人作为垃圾邮件服务器，现在已设SMTP认证，但队列中有上万封垃圾邮件，请问怎么删除？ ↑
先停止邮件系统，然后删除邮件队列目录 (在“高级设置”/“系统参数”设置的“邮件队列目录”，默认是在 ~\server\queue)下的所有子目录和文件， 系统会自动重新所有子目录，重新启动邮件系统。~是本系统安装时选择的路径，默认安装在“C:\Program Files\Magic Winmail”。

别人发给我的信是存放到哪里的？能不能长期存放？ ↑
别人发给系统中的邮箱用户的信是存放在在“高级设置”/“系统参数”设置的“邮件存储目录”下(默认是在 ~\server\store)。当然可以长期存放。 ~是本系统安装时选择的路径，默认安装在“C:\Program Files\Magic Winmail”。

如何设置才能将服务某个特定网段的用户使用？ ↑
在管理端的“系统服务”中，对于每一个服务都可以进行存储设置，禁止或者许可指定主机地址或者网络地址的机器访问权限。

可否禁止使用TELNET 25 或 TELNET 110？ 如可以TELNET 25，可否禁止支持EXPN及VRFY？ ↑
TELNET 25 或 TELNET 110是不能禁止的。
本邮件服务器没有实现EXPN和VRFY命令，因为这两个命令会引起服务器安全性问题。现在邮件系统大多已经不实现了。

为什么服务器上安装了诺顿 Norton 防毒程序后 Winmail 有时会自动关闭？ ↑
这种情况出现在Norton企业版, Norton网络版, Norton单机版。 由于诺顿可以直接杀信体文件的病毒, 和 Winmail 的队列处理程序产生冲突, 导致系统资源占用很大, Winmail 自动关闭。
解决办法: 在诺顿中排除以下目录:（如果在“高级设置”->“系统参数”中更改了“队列存储目录”、“邮件存储目录”、“网络磁盘存储目录”，请排除更改后的目录。）
~\server\queue\bounce
~\server\queue\header
~\server\queue\msg
~\server\queue\status
~\server\queue\todo
~\server\store
~\server\webmail
~\server\netstore
~ 表示邮件系统安装的目录，默认为：C:\Programe Files\Magic Winmail
另外还要在诺顿中设置发现病毒自动删除受感染的文件, 并且关闭警告提示, 删除不成功则忽略。
然后在 Winmail 的"防病毒设置"选择"病毒防火墙"模式。
详细设置请看 Winmail 和诺顿防毒

在服务器上安装该软件，服务器配置正常。服务器有一块网卡，两个地址，如何让两个地址都能正常使用？ ↑
对于上述出现的情况，SMTP，POP3属性的“绑定地址”不应该设为固定地址（内部地址或为外部地址），应该设为0.0.0.0（服务器上的所有IP地址）。

Winmail 是否支持自由申请，以及申请确认。 ↑
Winmail支持自由申请和申请确认。
管理员可以设置各个域是否允许Webmail申请，管理员可以选中左边的“域名设置”->“域名管理”，然后修改一个域的扩展属性中有关Webmail申请设置即可。

RBL 是什么？ ↑
RBL 全称是 Real-time Blackhole Lists, 是国外的反垃圾邮件组织提供的检查垃圾邮件发送者地址的服务。
以下网址有几乎所有国外RBL的列表. http://www.declude.com/junkmail/support/ip4r.htm, http://rbls.org/
常用的RBL服务器地址有: dnsbl.njabl.org;bl.spamcop.net;sbl.spamhaus.org;dun.dnsrbl.net;dnsbl.sorbs.net
国内有CBL反垃圾邮件组织, 请看 http://www.anti-spam.org.cn, CBL服务器地址有: cblless.anti-spam.org.cn;cbl.anti-spam.org.cn;cdl.anti-spam.org.cn;cblplus.anti-spam.org.cn

服务程序的注册和注销命令是什么？ ↑
Install service ---- MailServer /install
UnInstall service ---- MailServer /uninstall
Run as service ---- MailServer /service
Startup service ---- MailServer /startup
Stop service ---- MailServer /stop
Run as alone ---- MailServer /alone

如何查找域名的 MX 记录是否正确？ ↑
C:\> nslookup

Server: dns.nsmc.edu.cn
Address: 211.83.0.66
>set type=mx
>nsmc.edu.cn (输入您想解析的邮件地址中“@”符号后的域名)
Server: dns.nsmc.edu.cn
Address: 211.83.0.66
nsmc.edu.cn　　　　preference = 10, mail exchanger = mail.nsmc.edu.cn
smc.edu.cn　　　　nameserver = dns.nsmc.edu.cn
mail.nsmc.edu.cn　　　　internet address = 211.83.0.67
dns.nsmc.edu.cn internet address = 211.83.0.66

>exit

C:\>

如果判断我的邮件服务是否已经开启发信认证？ ↑
为了防止邮件服务器变成垃圾邮件转发服务器，现在架设在 Interent 上的绝大多数邮件服务器都开设了发信认证功能。检测方法如下：
C:\>telnet 119.119.119.212 25
Trying 119.119.119.212...
Connected to 119.119.119.212.
Escape character is '^]'.
220 steven.chinanusa.local Winmail Mail Server ESMTP ready
ehlo
250-steven.chinanusa.local Winmail Mail Server
250-PIPELINING
250-AUTH=NTLM LOGIN PLAIN
250-AUTH NTLM LOGIN PLAIN
250-STARTTLS
250-SIZE 5242880
250 8BITMIME
mail from: steven@abcdefg123.com (输入一个非本系统中用户的邮件地址)
250 ok
rcpt to: steven@abcdefg123.com (输入一个非本系统中用户的邮件地址)
553 sorry, you don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1)
quit
221 steven.chinanusa.local Winmail Mail Server
Connection closed by foreign host.

C:\>

如果上述输入 rcpt to 命令后，出现 553 sorry, you don't authenticate or the domain isn't in my list of allowed rcpthosts(#5.7.1) 错误信息就表示系统是需要认证的。

我已经开启了发信认证，为什么有时候发邮件不需要认证？ ↑
为了防止邮件服务器变成垃圾邮件转发服务器，现在架设在 Interent 上的绝大多数邮件服务器都开设了发信认证功能。有两种情况下通过邮件系统发邮件是不需要认证：
1. 发信主机是信任主机；
2. 收信人所在的域是本系统中的域或信任域。

如何根据错误回弹信发现出错原因？
错误回弹信格式通常如下:

Hi. This is the smtp delivery program.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.
=====================================================
您好！
您的邮件不能成功的递送到指定地址。这是一个永久的错误，因此不得不放弃继续递送。
<aaa@bbb.com>， sorry， no mailbox here by that name

注：以上反弹信中红色部分内容才是错误的原因。

常见的错误回弹信
no mailbox here by that name: 系统中没有该邮箱地址，请检查收件人地址填写是否正确。
don't find mail exchanger and domain's ip address: 邮件服务器使用的DNS服务器无法解析到收件人地址的域名，请检查域名填写是否正确；或更换邮件服务器使用的DNS服务器地址后重试。
connect remote host error (xxx.xxx.xxx.xxx : 25): 无法连接到收件人的邮件服务器的25端口，原因可能为网络阻塞，对方邮件服务器忙，或对方邮件服务器IP地址已更换等。
mail size/count over quota (count : xxxx): 收件人邮件数量达到最大限制数。可以删除一些邮件，或要求管理员增加该用户能存放的最大邮件数。
mail size/count over quota (size : xxxx): 收件人邮箱容量达到最大限制数。可以删除一些邮件释放空间，或要求管理员增加该用户邮箱的容量。
delivery failure: the message matches up to the filter rule(level: system， name: 1). 邮件符合过滤规则1的过滤条件，因此被过滤。
delivery failure: the message has been infected virus: 邮件中发现病毒。
anti-virus killed the attachment(s) with infected virus, file:test.rar: 防毒软件清除了邮件中带病毒的附件test.rar。
delivery failure: the message's attachment file (Filename: xxx.exe) matches the pattern string (Pattern: *.exe)： 邮件系统过滤后缀为.exe的附件。附件过滤可以在管理工具->防病毒设置中设置。
delivery failure: the message's attachment number exceeds the limited: 邮件所带的附件数量超过限制，请减少附件数或要求管理员增加邮件允许的最大附件数。
connect DNS server failure. 连接DNS服务器失败，可能你邮件服务器上设置的DNS服务器不是很稳定。可以换一个试试。
Relay server said: 554 too many hops, this message is looping (#5.4.6) 中继递送设置了不对，形成了递送循环，不要设置中继，直递送试试。
也可以参考 Winmail 退信分析

发到 sina.com 的邮件会被退回
我发到 sina 的邮件会被退回，并提示"remote server said: 553 Spam Mail http://mail.sina.com.cn/FAQ.html"错误，怎么办？
1. 确认您邮件系统使用的域名是合法的，而不是随意填写的。
2. 确认您的邮件服务器使用的IP地址是固定的，而不是动态的IP地址。
3. 正确设置Winmail Server管理工具->系统设置->SMTP设置->基本参数->HELO/EHLO 主机名。可用nslookup命令查找，YourDomain MX preference = 10， mail exchanger =后面的内容即为正确的HELO/EHLO 主机名。
4. 如满足以上三点，发到 sina 还是被退回相同的信件，请和 sina 联系。联系方式如下
邮箱地址：antispam@staff.sina.com.cn 或 lanjiang@staff.sina.com.cn
联系电话：010-82624488 转 5602
也可以申请个 sina 的邮箱，在Winmail Server管理工具->系统设置->SMTP设置->外发递送 中设置递送失败后启用中继递送，中继服务器: smtp.sina.com.cn， 再输入您在 sina 注册的用户名和密码。

发到 tom.com 的邮件会被退回
我发到 TOM.COM 的邮件会被退回，并提示"550 CoremailSys:IP blocked by RBL，Please see http://whitelist.mail.tom.com"错误，怎么办？
1. 确认您邮件系统使用的域名是合法的，而不是随意填写的。
2. 确认您的邮件服务器使用的IP地址是固定的，而不是动态的IP地址。
3. 正确设置Winmail Server管理工具->系统设置->SMTP设置->基本参数->HELO/EHLO 主机名。可用nslookup命令查找，YourDomain MX preference = 10， mail exchanger =后面的内容即为正确的HELO/EHLO 主机名。
4. 如满足以上三点，发送到 TOM.COM 还是被退回相同的信件，请到http://whitelist.mail.tom.com申请加入到TOM.COM的白名单。

发到 aol.com 的邮件会被退回
我发到AOL.COM的邮件会被退回，并提示"554- (RTR:DU) http://postmaster.info.aol.com/errors/554rtrdu.html"错误，怎么办？
AOL.COM除了要求您的邮件服务器使用合法的域名，固定公网IP地址，还需要该IP地址能够作反向解析。但国内要申请作反向解析比较困难，所以我们可以使用中继服务器转发，例如：
可以申请个 sina 的邮箱，在Winmail Server管理工具->系统设置->SMTP设置->外发递送 中设置递送失败后启用中继递送，中继服务器: smtp.sina.com.cn， 再输入您在 sina 注册的用户名和密码。

收到退信错误提示为"554 5.7.1 Rejected xxx.xxx.xxx.xxx found in dnsbl.sorbs.net"，怎么办？
这是因为收件人所在的邮件服务器使用RBL过滤垃圾邮件，而您的邮件服务器IP地址在RBL列表中，因此被拒绝了。一般此类的退信会包含一个连接，可以按网站上面的要求来申请把您的邮件服务器IP地址从列表中移除。 也可以尝试使用中继服务器转发，例如：
可以申请个 sina 的邮箱，在Winmail Server管理工具->系统设置->SMTP设置->外发递送 中设置递送失败后启用中继递送，中继服务器: smtp.sina.com.cn， 再输入您在 sina 注册的用户名和密码。


常见问题

请访问 http://www.winmail.cn/faq.php 查看网站上更全的常见问题

Webmail 相关问题
 我想在我们主页上加入 Webmail 的登陆栏或自动登录邮箱，如何实现？
如何更改 Webmail 发出邮件的底部签名？
我想更换 Webmail 的 LOGO 图片、 广告图片和提示信息，如何实现？可以针对域定制图片吗？
我可以使用 http://mymailserver:6080 登陆 Webmail。如何换成 http://mymailserver登陆？
多域名时，WebMail 登陆页面用户要选择自己的域很不方便，怎样解决？
怎样在 WebMail 登陆页面加自由申请功能？
Webmail 设置到 IIS 中无法修改口令和设置自动转发等参数, 怎样解决？
Webmail 设置到 IIS 中无法上传附件, 怎样解决？
Webmail 设置到 IIS 中, 页面出错, 怎样解决？
为什么当我在 Webmail 登陆时会出现“create com instance error”的提示？
Webmail 使用中, 显示" Can't contact LDAP server" 出错, 怎样解决？
使用 WebMail 发信时，提示"SMTP Error:could not connect to SMTP host server(s)" 错误怎么办？
使用 WebMail 发信时，提示"SMTP Error: Data not accepted，552 sorry， the message size exceeds databytes limit (#5.3.4)"错误怎么办？
使用 WebMail 发信时，提示"SMTP Error: Invalid username/password 535 5.7.3 Authentication unsuccessful" 错误怎么办？
我想让 Webmail 退出和错误返回到指定的网页，如何实现？
如何开启与关闭 Webmail 自动登录功能？
如何开启与关闭 Webmail 取回密码功能？
设置用自己安装的 PHP 程序后，Webmail 不能正常使用，怎么解决？
如何在我的系统中能取得用户新邮件数？
如何在我的系统中嵌入Webmail，以实现列邮件夹列表，读邮件，写邮件等工作？
怎么更改默认的界面风格？

我想在我们主页上加入 Webmail 的登陆栏或自动登录邮箱，如何实现？ ↑
可以在您的页面中增加如下代码，注意要根据您的实际情况做修改。

<!--
action的值改为您的实现登录URL
-->
<form name="form1" action="http://yourserverip:6080/login.php" method=post>
用户名:&nbsp;<input type="text" name="f_user" value="" size="12" maxlength="32">
<!--
将yourdomain替换成您所要使用的域名。
-->
<input type="hidden" name="f_domain" value="yourdomain">
密码:&nbsp;<input type="password" name="f_pass" value="" size="12" maxlength="32">
<!--
选择语言包，登录后的语言
f_lang=en --- 英语
f_lang=ch_gb --- 简体中文
f_lang=ch_big5 --- 繁体中文
-->
<input type="hidden" name="f_lang" value="ch_gb">
<input type="submit" name="submit" value="登录">
<input type="reset" name="reset" value="重置">
</form>

如需要自动登录，可以将上面上type="text" 改为 type="hidden"，然后在 value 中预先设置好用户名与密码，自动提交登录

<script language="JavaScript">
document.form1.submit();
</script>

如何更改 Webmail 发出邮件的底部签名？ ↑
可以在 Winmail 管理工具的“高级设置”->“系统参数”下的“系统签名”中做修改。

我想更换Webmail的LOGO图片、广告图片和提示信息，如何实现？可以针对域定制图片吗？ ↑
有关LOGO的更改：
首页、登录后的页面、用户注册页面的 LOGO 文件都放在 ~\server\webmail\customer 下，可以直接替换，要保持文件名一致， 图片的长和宽尽量和原来的保持一致。

有关网页 Title 和链接的更改：
请更改~\server\webmail\customer 下的所有语言文件 (*.txt) 的相关内容
common_page_title = WebMail | Power by Winmail Server
homepage = Power by Winmail Server
homepage_url = http://www.winmail.cn
contact_us = 联系我们
webmaster_mail = support@winmail.cn
banner_url = images/cn-banner.gif
请更改等于号右边的内容，左边的内容勿改动。

添加语言文件：
1. 请拷贝一份已有的语言的语言文件，并更名（扩展名为仍要为.txt），然后更改文件中各行的等于号右边的内容，左边的内容勿改动。
2. 在 ~\server\webmail\inc\config.languages.php 文件后，增加如下行：
$languages[] = Array(
"name" => "Simplified Chinese",
"path" => "ch_gb" //引号内更改为您的语言文件名（不含扩展名）
);

禁止更改语言、设定默认语言、禁止修改界面风格、设定默认界面风格：
在管理端程序"系统设置"/"高级设置"/"Webmail设置"/"首页设置"里设置。

针对域定制图片：
~\server\webmail\www\customer 目录下的图片
可以增加相同尺寸的图片，将图片的名称前名加上相应的域名和下划线开头
如登录 look.com 域要显示与其它域不同的图片，则增加以下名称的图片:
look.com_banner.gif
look.com_index_logo.gif
look.com_index_winmail.gif
look.com_main_logo.gif

针对域定制说明文字：
~\server\webmail\www\customer 目录下的语言文件（扩展名为 txt 的文件）
可以拷贝指定的语文件，将文件名称前名加上相应的域名和下划线开头，然后打开修改中间的内容（等号右边的）
如登录 look.com 域要显示与其它域不同的文本，则增加以下名称的语言文件:
look.com_ch_gb.txt
look.com_en.txt
look.com_ch_big5.txt
look.com_it.txt
....

我可以使用http://mail.mymailserver.com:6080 登陆Webmail。如何换成http://mail.mymailserver.com登陆？ ↑
将HTTP服务的改为80端口即可，但要确保您的机器上没有安装其它 web server。
更改HTTP服务端口：请用管理工具登录系统，选择左边的“系统设置”/“系统服务”，在右边的页面中选中“HTTP”然后点击“编辑”，修改端口。
如果你的服务器上已经安装了IIS, 也可以将Webmail设置到IIS中, 请参考 如何能让Webmail运行在IIS环境中。

多域名时，WebMail登陆页面用户要选择自己的域很不方便，怎样解决？ ↑
2.4版后, 在域属性里增加了一个"直接访问主机名"的参数, 添入该域的登陆URL即可实现登陆页面只显示该域, 例如有一个abc.com的域, 在DNS里加一个mail.abc.com指向邮件服务器IP地址, 在"直接访问主机名"输入: mail.abc.com , 注意不要包括6080端口。

怎样在WebMail登陆页面加自由申请功能？ ↑
Winmail支持自由申请和申请确认。管理员可以设置各个域是否允许Webmail申请，管理员可以选中左边的“域名设置”->“域名管理”，然后修改一个域的扩展属性中有关Webmail申请设置即可。

Webmail 设置到IIS中无法修改口令和设置自动转发等参数, 怎样解决？ ↑
将Webmail\temp目录，邮件存储目录和用户数据库文件的权限中增加Everyone允许访问，并将权限设置为“完全控制”。
Webmail\temp目录，其具体位置是在~\server\webmail\temp
邮件存储目录，其具体位置是在~\server\store
网络磁盘存储目录，其具体位置是在~\server\netstore
用户数据库文件，其具体位置是在~\server\data\userauth.cfg
域名数据库文件，其具体位置是在~\server\data\domain.cfg

注意：
1. ~ 表示Magic Winmail安装时选择的目录，黙认是安装在 C:\Program Files\Magic Winmail。
2. 目录的权限要选择“将父系可继承对象传播给该对象”
3. 如果更改了“邮件存储目录”，请直接设置更改后的目录权限。

同时为了发邮件能上传附件，还需要设置Windows 的 TEMP 目录 C:\Winnt\temp(假设Windows 安装在C:\Winnt 或 Windows 的 TEMP 目录路径没有更改)目录的权限，增加Everyone访问许可，并将权限设置为“完全控制”。

Webmail 设置到 IIS 中无法上传附件, 怎样解决？ ↑
设置Windows 的 TEMP 目录 C:\Winnt\temp(假设Windows 安装在C:\Winnt 或 Windows 的 TEMP 目录路径没有更改)目录的权限，增加Everyone访问许可，并将权限设置为“完全控制”。

Webmail 设置到IIS中, 页面出错, 怎样解决？ ↑
如果是提示"Warning .... Permission denied in..."，是文件和目录权限没有设置正确, 请按照帮助文档重新设置目录权限。

为什么当我在 Webmail 登陆时会出现“create com instance error”的提示？ ↑
这个问题可能是安装时注册COM组件出错引起的。您可以重新手动注册COM组件。“开始”菜单-》“运行”中行输入cmd

先注销这个COM组件
C:>regsvr32 /u "~\server\XmlDataBase.dll"

重新注册COM组件
C:>regsvr32 "~\server\XmlDataBase.dll"

在上述命令中，~表示安装时选择的系统安装到的目录。默认为：C:\Program Files\Magic Winmail
还有不要将 Winmail 安装到在中文目录中。

Webmail 使用中, 显示" Can't contact LDAP server" 出错, 怎样解决？ ↑
这个问题可能是 LDAP 服务不能正常启动引起的。
您用的 win2003 以上版本，系统中活动目录服务。这样就会和 LDAP 使用同一端口，
LDAP 就不能正常启动。解决办法，将 LDAP 服务的端口改为 489. 然后重启一下即可。
如果还不能正常连接，请停止 Secure LDAP 服务，并将此服务属性中不要选择“本系统启动时自动运行此服务”，然后重启一下邮件系统即可。

使用 WebMail 发信时，提示"SMTP Error:could not connect to SMTP host server(s)" 错误怎么办？ ↑
1. 邮件服务器上是否安装瑞星防毒软件？如安装请参考 Winmail Server和瑞星邮件监控结合防毒;
2. 打开 Winmail 管理工具，检查系统服务中的SMTP服务是否正常启动。

使用 WebMail 发信时，提示"SMTP Error: Data not accepted，552 sorry， the message size exceeds databytes limit (#5.3.4)"错误怎么办？ ↑
该错误是因为发送的邮件大小超过了系统允许的最大字节数而产生的，需要减小发送邮件的大小或增加系统允许发送邮件的最大字节数(在 "SMTP 设置"功能里设置)。

使用 WebMail 发信时，提示"SMTP Error: Invalid username/password 535 5.7.3 Authentication unsuccessful"错误怎么办？ ↑
该错误是因为Windows IIS的 smtp 服务没有停止，请进入IIS管理程序停止它的smtp服务器, 然后重新启动 Winmail 的smtp服务。彻底停止请到系统服务设置里将"Simple Mail Transport Protocol (SMTP)"的启动类型设为"手动"或"已禁用"。

我想让 Webmail 退出和错误返回到指定的网页，如何实现？ ↑
打开 ~\server\webmail\inc\config.php
查找以下内容，并将等号右边内容修改为指定的 URL。
$logout_location = '';
如需要返回到 oa.winmail.cn 这个网站，请在等号右边填写 http://oa.winmail.cn

如果要针对每个域名，设置返回到不同页面，可以在修改 ~\server\webmail\www\customer 目录下的语言文件（扩展名为 txt 的文件）
可以拷贝指定的语文件，将文件名称前名加上相应的域名和下划线开头，然后打开在中文件的最后增加下面内容：
logout_location = http://oa.winmail.cn

如登录 look.com，则增加以下名称的语言文件:
look.com_ch_gb.txt
look.com_en.txt
look.com_ch_big5.txt
look.com_it.txt
....

如何开启与关闭 Webmail 自动登录功能？ ↑
只需要选中或取消“高级设置”->“Webmail 设置”中的“Webmail 允许自动登录”即可。

如何开启与关闭 Webmail 取回密码功能？ ↑
只需要选中或取消“高级设置”->“Webmail 设置”中的“Webmail 登录页显示'忘记密码'”连接即可。

设置用自己安装的 PHP 程序后，Webmail 不能正常使用，怎么解决？ ↑
请参考 http://www.winmail.cn/setupiis/phpsetup.html 第二步, 修改 php 的配置文件php.ini

如何在我的系统中能取得用户新邮件数？ ↑
可以使用 Winmail 中所提供的接口控件中 GetFolderMsgCount 方法来取得。有关文档请见：COM 组件功能
如果你的系统与邮件系统不在同一台机器，也可以通过 http 方式访问指现的接口页面来取得相关邮箱的邮件数。相关文档可以参考 ~\server\webmail\doc 下的 get_newmsg_num 目录文档

http://yourmailserver:6080/getmsgnum.php?user=username&pass=CryptEncode(password)&folder=foldername&onlynew=1
user: 邮箱名
pass: 登录密码, 需要加码
folder: 指定的邮件夹，没有此参数，返回所有系统邮件夹
onlynew: 仅显示新邮件，没有此参数，返回新邮件和邮件总数。1 - 仅新邮件，0 - 新邮件和邮件总数
html: 返回结果输出格式，没有此参数，返回文本格式。1 - html 格式；0 - 文本格式
lng: 返回结果显示的语言索引号，没有此参数，为系统默认语言

如何在我的系统中嵌入Webmail，以实现列邮件夹列表，读邮件，写邮件等工作？ ↑
可以使用 Webmail 中所提供的专门嵌入式界面（仅有核心部份，去掉不必要的页眉和页脚信息），相关文档可以参考 ~\server\webmail\doc 下的 embed_interface 目录中文档

怎么禁止修改界面风格和设定默认界面风格？ ↑
在管理端程序"系统设置"/"高级设置"/"Webmail设置"/"首页设置"里设置。


'如何导入 namespace
'1. 启动VS
'2. 打开项目
'3. 在Solution Explorer 右击项目名
'4. Property pages
'5. 选择References
'6. 点击Add Reference
'7. 选择Com标签
'8. 找到MailServerCtrl 1.0 Type Library
'9. OK
'10. OK
'
'这样便完成了MailServerCtrl 的导入
'
'以下是程序例子
Imports MAILSERVERCTRLLib

Partial Class _Default
    Inherits System.Web.UI.Page
    Dim retCode As Short

    Protected Sub add_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles add.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface

        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")

        retCode = maildb.AddUser(name.Text, domain.Text, pass.Text)
        If retCode = 0 Then
            Response.Write("Add user successfully<br>")
        Else
            Response.Write("Add user failed<br>")
        End If

    End Sub

    Protected Sub Delete_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Delete.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface

        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")

        retCode = maildb.DeleteUser(name.Text, domain.Text)

        If retCode = 0 Then
            Response.Write("Delete user successfully<br>")
        Else
            Response.Write("Delete user failed<br>")
        End If
    End Sub

    Protected Sub changepwd_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles changepwd.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")

        retCode = maildb.ChangePassword(name.Text, domain.Text, pass.Text, newpass.text)

        If retCode = 0 Then
            Response.Write("Change user password successfully<br>")
        Else
            Response.Write("Change user password failed<br>")
        End If
    End Sub

    Protected Sub checkuser_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles checkuser.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.Authenticate(name.Text, domain.Text, pass.Text)

        If retCode = 0 Then
            Response.Write("Check user successfully<br>")
        Else
            Response.Write("Check user failed<br>")
        End If
    End Sub

    Protected Sub domain_Add_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles domain_Add.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.AddDomain(domain_name.Text)

        If retCode = 0 Then
            Response.Write("Add domain successfully<br>")
        Else
            Response.Write("Add domain failed<br>")
        End If
    End Sub

    Protected Sub domain_Del_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles domain_Del.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.DeleteDomain(domain_name.Text)

        If retCode = 0 Then
            Response.Write("Delete domain successfully<br>")
        Else
            Response.Write("Delete domain failed<br>")
        End If
    End Sub

    Protected Sub Admin_Add_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Admin_Add.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.AddAdminUser(admin_name.Text, admin_pass.Text, admin_usertype.Text, admin_adminrange.Text)

        If retCode = 0 Then
            Response.Write("Delete admin successfully<br>")
        Else
            Response.Write("Delete admin failed<br>")
        End If
    End Sub

    Protected Sub Admin_Del_Click(ByVal sender As Object, ByVal e As System.EventArgs) Handles Admin_Del.Click
        Dim maildb As MAILSERVERCTRLLib.MailDBInterface
        maildb = New MAILSERVERCTRLLib.MailDBInterface
        maildb.InitControl("C:\Program Files\Magic WinMail\server")
        retCode = maildb.DeleteAdminUser(admin_name.Text)

        If retCode = 0 Then
            Response.Write("Delete admin successfully<br>")
        Else
            Response.Write("Delete admin failed<br>")
        End If
    End Sub
End Class


Winmail Control PHP Test

<% option explicit if request("dest")="submit" then Dim name,domain,pass,newpass,usertype,adminrange Dim maildb Dim retCode,sub_action,mode name = request("name") domain = request("domain") pass = request("pass") newpass = request("newpass") usertype = request("usertype") adminrange = request("adminrange") sub_action = request("sub_action") mode = request("mode") Set maildb = Server.CreateObject("MailServerCtrl.MailDBInterface") ' Winmail Server DB Path maildb.InitControl("C:\Program Files\Magic WinMail\server") Select Case sub_action Case "user" Select Case mode Case "add" retCode = maildb.AddUser(name, domain, pass) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "delete" retCode = maildb.DeleteUser(name, domain) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "changpwd" retCode = maildb.ChangePassword(name, domain, pass, newpass) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "checkuser" retCode = maildb.Authenticate(name, domain, pass) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if End Select Case "domain" Select Case mode Case "add" retCode = maildb.AddDomain(domain) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "delete" retCode = maildb.DeleteDomain(domain) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if End Select Case "admin" Select Case mode Case "add" Response.write pass Response.write domain retCode = maildb.AddAdminUser(name,pass, usertype, adminrange) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if Case "delete" retCode = maildb.DeleteAdminUser(name) if retCode=0 then Response.write mode+" success
" else Response.write mode+" fail
" end if End Select End Select set maildb=nothing end if %> Winmail Control PHP Test User
name: @
pass:
new pass:

Domain
domain

Admin
user
pass:
usertype:
adminrange:


#include "stdafx.h"
#include "atlbase.h"

#import "C:\\Program Files\\Magic WinMail\\server\\MailServerCtrl.dll" no_namespace

int main(int argc, char* argv[])
{
    CoInitialize(NULL);

    CLSID clsid;
    CLSIDFromProgID(OLESTR("MailServerCtrl.MailDBInterface"), &clsid);

    CComPtr <IMailDBInterface> pGetRes;

    pGetRes.CoCreateInstance(clsid);

    //Set winmail database path
    pGetRes->InitControl(L"C:\\Program Files\\Magic WinMail\\server");

    //Add new mail user
    int iRet = pGetRes->AddUser(L"winmail", L"test.com", L"mail123");

    if (iRet == 0)
        printf("Added user successfully");
    else
        printf("Added user failed");

    pGetRes.Release();

    CoUninitialize();

    return 0;
}


//Simple1: use JACOB call COM object

import com.jacob.com.Dispatch;

public class TestSimple {
    public static void main(String[] args) throws Exception {
        String result = "";
        try {
            Dispatch ids = new Dispatch("MailServerCtrl.MailDBInterface");

            //Set Winmail database path
            Object[] param1 = new Object[]{"C:\\Program Files\\Magic WinMail\\server"};

            Dispatch.call(ids, "InitControl", param1);

            //Add new mail user
            Object[] param2 = new Object[]{"winmail", "test.com", "Mail123"};
            result = String.valueOf(Dispatch.call(ids, "AddUser", param2));

            System.out.println("result: "+result);
            ids.safeRelease();
        }
        catch(Exception e)
        {
            e.printStackTrace();
        }
    }
}

//Simple2: use JCOM call COM object

public class TestSimple {
    public static void main(String[] args) throws Exception {
        ReleaseManager rm = new ReleaseManager();
        String result = "";
        try {
            IDispatch ids = new IDispatch(rm,"MailServerCtrl.MailDBInterface");

            //Set Winmail database path
            Object[] param1 = new Object[]{"C:\\Program Files\\Magic WinMail\\server"};
            ids.method("InitControl", param1));

            //Add new mail user
            Object[] param2 = new Object[]{"winmail", "test.com", "Mail123"};
            result = String.valueOf(ids.method("AddUser", param2));

            System.out.println("result: "+result);
        }
        catch(Exception e)
        {
            e.printStackTrace();
        }
        finally {
            rm.release();
        }
    }
}


Winmail Control Test

InitControl("C:\Program Files\Magic WinMail\server"); switch($sub_action){ case 'user': switch($mode) { case 'add': $retCode = $ctrl->AddUser($name, $domain, $pass); switch($retCode){ case 0: echo '0 - Add success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same mail user
'; break; case 3: echo '3 - Existed the same mail group
'; break; case 4: echo '4 - Existed the same mail alias
'; break; case 5: echo '5 - In the domain, The user number has attache the limition
'; break; case 6: echo '6 - In the domain, The user available space has attache the limition
'; break; case 7: echo '7 - The domain isn\'t exist.
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteUser($name, $domain); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'changpwd': $retCode = $ctrl->ChangePassword($name, $domain, $pass, $newpass); switch($retCode){ case 0: echo '0 - Change password success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - The old password is error or user not exists
'; break; case 3: echo '3 - Modify user failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'checkuser': $retCode = $ctrl->Authenticate($name, $domain, $pass); switch($retCode){ case 0: echo '0 - Check user success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Check user failure or user not exists
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'modify': $retCode = $ctrl->ModifyUser($name, $domain, "test", "test", "test", "test"); switch($retCode){ case 0: echo '0 - Check user success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Check user failure or user not exists
'; break; case 3: echo '3 - Modify user failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'chguserinfo': break; case 'chgquota': $retCode = $ctrl->ModifyUserQuota($name, $domain, 20*1024*1024, 0, 0, 50*1024*1024, 0); echo $retCode.'
'; break; case 'chgright': $retCode = $ctrl->ModifyUserRight($name, $domain, 0, 0, 0, 0, 0, 0, 0, 0); echo $retCode.'
'; break; case 'chgstatus': $retCode = $ctrl->ModifyUserStatus($name, $domain, 0); echo $retCode.'
'; break; default: echo 'mode error
'; break; } break; case 'domain': switch($mode) { case 'add': $retCode = $ctrl->AddDomain($domain); switch($retCode){ case 0: echo '0 - Add domain success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same domain
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteDomain($domain); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; default: echo 'mode error'; break; } break; case 'admin': switch($mode) { case 'add': $retCode = $ctrl->AddAdminUser($name, $pass, intval($usertype), $adminrange); switch($retCode){ case 0: echo '0 - Add administrator success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same administrator
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteAdminUser($name); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; default: echo 'mode error
'; break; } break; case 'group': switch($mode) { case 'add': $retCode = $ctrl->AddGroup($name, $domain, $description, $memberlist, $right, $senderlist); switch($retCode){ case 0: echo '0 - Add group success
'; break; case 1: echo '1 - The paramenter is error
'; break; case 2: echo '2 - Existed the same mail user
'; break; case 3: echo '3 - Existed the same mail group
'; break; case 4: echo '4 - Existed the same mail alias
'; break; case 5: echo '5 - The domain isn\'t exist.
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'modify': $retCode = $ctrl->ModifyGroup($name, $domain, $description, $memberlist, $right, $senderlist); switch($retCode){ case 0: echo '0 - Modify success
'; break; case 1: echo '1 - Modify failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; case 'delete': $retCode = $ctrl->DeleteGroup($name, $domain); switch($retCode){ case 0: echo '0 - Delete success
'; break; case 1: echo '1 - Delete failure
'; break; default: echo $retCode.' - Invaild return
'; break; } break; default: echo 'mode error
'; break; } break; default: echo 'sub_action error
'; break; } echo '
'; } ?> Winmail Control Test User
mailbox: @
pass:
new pass:

Domain
domain:

Admin
user:
pass:
usertype:
adminrange:

Group
group: @
description:
memberlist:
right:
senderlist:


与代理服务器软件配合 - 普通模式

普通模式

代理软件：CProxy, CCProxy, Sygate, WinGate, WinRoute, WinProxy, ISA Server2000。
网络环境：Winmail和代理服务器软件装在同一台机器，内部IP为192.168.0.1, 外部IP为61.177.18.66。

1.CProxy

正常安装CProxy和 Winmail后，即可使用，两者并无冲突。

2.CCProxy

要将CCProxy的邮件代理功能关闭。

3.Sygate

要将"启用增强的安全机制"选项关闭。

4.Wingate

Wingate启动后，会把smpt, pop3服务绑定到ip地址127.0.0.1上。所以，需停止wingate的smtp,pop3服务。
1)单击"Control", 进入"System"。
2)双击"SMTP Server", 在弹出的窗口选择"Bindings"页，在"Bound"栏双击所有的ip, 取消smtp绑定，按Apply → OK。如下图：

或者也可以修改Winmail的SMTP, POP3服务端口号。 有关操作请见系统服务

5.WinRoute Pro

WinRoute Pro和 Winmail装同一机器，需停止WinRoute的NAT功能。
1)Settings → Interface Table → 选中网卡，点击“属性”→ 在弹出的对话框中取消NAT功能。如下图所示：

6.WinRoute Lite

需允许winRoute Lite打开所有端口。
1)Settings → Settings → Security → 打开所有端口。如下图：

7.WinProxy

WinProxy启动后，会把SMTP, POP3服务绑定到ip地址0.0.0.0上。所以，需停止WinProxy的smtp,pop3服务。同时让WinProxy工作在Classic Proxy模式。
1）File->Advanced Settings->设置客户端访问模式。如下图：

2）File → Settings → Protocols，勾掉Mail服务 → 确定。如下图：

或者也可以修改Winmail的SMTP, POP3服务端口号。有关操作请见系统服务

8.ISA Server 2000

ISA启动后，并不跟 Winmail冲突，但由于ISA的默认方式是内部网内，及内部网和外网并不能互相通讯，所以要添加相应的过滤规则，以便 Winmail可正常收发Mail。
1）Access Policy → IP Packet Filters → 新建Filter, 填入external_smtp（可任意）→ 选择 "Allow packet transmission" → 选择"Custom" → 设置protocol, 端口等，如下图 → 选择 "Default IP addresses for each external on the ISA Server computer" → 选择"All remote computes" → 点击"完成"。如下图所示

2）Access Policy → IP Packet Filters → 新建Filter, 填入internal_smtp（可任意）→ 选择"Allow packet transmission" → 选择"Custom" → 设置protocol, 端口等，如上图所示 → 选择"This compute（on the perimeter network）", 填入IP 192.168.0.1，如下图所示 → 选择"All remote computers" → 点击"完成"。如下图


与代理服务器软件配合 - 映射模式

映射模式

代理软件：CProxy, CCProxy, Sygate, WinGate, WinRoute, WinProxy, ISA Server2000。
测试环境：代理服务器（机器名为proxy）绑定2个IP,其中内部IP为192.168.0.1, 外部IP为61.177.18.66。装有Winmail的机器（机器名为mail）IP为192.168.0.2。mail在内部网中，通过代理服务器proxy收发邮件。Proxy负责把邮件服务器映射到mail机器。如图所示：

1.CProxy设置

映射SMTP Server
1）单击"设置" → "端口映射" →"E" 。
2）在弹出窗口填入映射端口号和IP地址，如图所示。

映射POP3 Server步骤同上，只是把端口25改为110。

2.CCProxy设置

映射SMTP Server
1）单击Protocols → SMTP Options。
2）在弹出窗口填入映射端口号和IP地址，如图所示。重起服务。

映射POP3 Server步骤同上，只是把端口25改为110。

3.Sygate设置

映射SMTP Server
1)单击Access Rules, 在弹出对话框选择"Add"。
2)选中"Import a rule from system", 在下拉框选择"Mail(SMTP)Server"，按OK。
3)在弹出的对话框中，"Direction"栏选择"IN", "PROTOCOL"栏选择"TCP", "CLIENT IP"填入192.168.0.2, "DesPort"添入25。如下图所示：

映射POP3 Server步骤同上，只是把端口25改为110。

4.WinGate设置

映射SMTP Server
1)单击"Control", 进入"system"。
2)双击"SMTP Server", 在弹出的窗口选择"Bindings"页，在"bound"栏双击所有的ip, 取消smtp绑定，按Apply → OK。如下图：

3)进入"Services", 添加"TCP Mapping Service", 选择"General"页，在"Start Option", 服务模式选为选择"Service will start automatic", 服务端口填入25，在"Default Maping"中，"Service"填入192.168.0.2, "on"填入端口25。如下图：

选择"Binding"页，选择IP 61.177.18.66进行绑定Smtp服务。

映射POP3 SERVER步骤同上，只是把端口25改为110。

5.WinRoute Pro设置

映射SMTP Server
1)选择菜单Settings → advanced → Port Mapping。
2)在弹出窗口单击"add", Protocl选TCP, 端口填入25，目标ip填入192.168.0.2, 目标端口25。如下图所示：

映射POP3 SERVER步骤同上，只是把端口25改为110。

6.WinRoute Lite设置

映射SMTP Server
1）Settings → Settings → Port Mapping → 添加端口映射规则。如下图:

映射POP3 SERVER步骤同上，只是把端口25改为110。

7.WinProxy设置

映射SMTP Server
1)选择菜单 file → advanced settings → Map Ports
2)单击new, 再弹出的窗口中，服务端口填入25， 目标ip填入192.168.0.2, 目标端口填入25， 个数填入1。 Type / Protocol选择TCP, DIRECTION 选择 Incoming。如下图：

映射POP3 Server步骤同上，只是把端口25改为110。

8.ISA Server 2000的配置

映射SMTP Server
1）添加过滤规则，使外网的机器能访问proxy的25端口。
Access Policy → IP Packet Filters → 新建Filter, 填入external_smtp（可任意）→ 选择 "Allow packet transmission" → 选择"Custom" → 设置protocol, 端口等，如下图 → 选择 "Default IP addresses for each external on the ISA Server computer" → 选择"All remote computes" → 点击"完成"。

2）添加过滤规则，使在内部网中，proxy能与mail在25端口通讯。
Access Policy → IP Packet Filters → 新建Filter, 填入internal_smtp（可任意）→ 选择"Allow packet transmission" → 选择"Custom" → 设置protocol, 端口等，如上图所示 → 选择"This compute（on the perimeter network）", 填入IP 192.168.0.2，如下图所示 → 选择"All remote computes" → 点击"完成"。

3）映射smtp服务。
Publishing → Server Publishing Rules → 新建Rules → 填入IP地址，如下图 → 在下拉框中选择 "SMTP Server" → 选择"any request" → 点击"完成"。

映射POP3 Server步骤同上，只是把端口25改为110。

4）关于的 ISA SMTP Filter
ISA 缺省是关闭"SMTP Filter", 如果你开启了"SMTP Filter"会导致 smtp 认证无法使用, 这时你可以按 http://www.isaserver.org/tutorials/smtpauth1.html 设置 ISA 以加入对 smtp auth 的支持。


与代理服务器软件配合

Winmail 邮件服务器可方便地跟常用代理服务器软件配合使用。一般 Winmail和代理服务器软件安装有两种方式

普通模式 | Winmail和代理软件安装在同一台机器，该机直接连在Internet上。 代理服务器设置：CProxy 3.4.3, CCProxy 5.30, SyGate 4.5, WinGate 5.0.1, WinRoute Pro 4.2.5, WinRoute Lite 4.2.5, WinProxy 5.0, ISA Server 2000
映射模式 | Winmail安装在局域网内部的某台机器，通过代理软件来映射SMTP,POP3服务。 代理服务器设置：CProxy 3.4.3, CCProxy 5.30, SyGate4.5, WinGate 5.0.1, WinRoute Pro 4.2.5, WinRoute Lite 4.2.5, WinProxy 5.0, ISA Server 2000